KT7A-RAID/Windows XP installation problem

Discussion in 'Abit' started by Frans Verhelst, Apr 3, 2004.

  1. I would appreciate suggestions where to look for solutions for the following
    unexpected problem:

    Motherboard with A9 BIOS with HPT BIOS 1.11.0402 in a RAID-1 configuration
    running fine under Windows ME, but now I am installing Windows XP without

    I have deleted RAID, uncoupled one HD, (re)formatted the other. Half way
    setup Windows XP reports a problem (without details, but suggesting amongst
    others to check for viruses), and installation is interrupted.

    Same HD, same cable, but now plugged into motherboard IDE slot gives an
    installation without any problem. Subsequently plugging the cable into the
    RAID slot leads to the message that Windows cannot start; choosing safe
    mode does not help.

    What to do??

    Regards from the Netherlands and thanks,

    Frans Verhelst, Apr 3, 2004
    1. Advertisements

  2. Frans Verhelst

    Jim Guest

    Sounds like you're still using the original HPT BIOS, which probably
    preceeds the existence of XP, it could very well have a bug! I sold my
    KT7A-RAID rev 1.3 mobo about 6 months ago, and it ran just fine on the HPT
    controller (albeit, the I was never impressed w/ the HPT RAID controller
    performance, but that's another story).

    I strongly recommend you get one of the "modified" BIOS versions, the one w/
    the more recent HPT BIOS releases. Unfortunately, the releases from Abit
    have always maintained the original HPT BIOS for some unexplained reason.
    Therefore, any bugs related to the HPT controller never get updated, no
    matter how recent the KT7A-RAID BIOS is updated. I supect if you had a more
    recent HPT BIOS your current problems would probably go away.

    Sudhian Media has been kind enough to continue hosting of the KT7A FAQ (
    http://www.sudhian.com/showfaqs.cfm?fid=2 ), although it's no longer
    maintained (AFAIK). If you check out the BIOS section, you'll see links to
    a download section where modified Abit BIOS's can be obtained that include
    the more recent HPT BIOS releases. Of course, these are "unofficial", but
    have worked fine for me. Be careful to use the one's for YOUR version of
    this board! The KT7A was released in RAID and NON-RAID versions, and the
    RAID version has 1.3 and pre-1.3 releases. So don't install the wrong one,
    triple-check before flashing!

    If you still have problems getting hold of the most recent modified
    releases, you can build a release yourself using the CBROM utility (also
    explained in the FAQ). Takes a little patience to learn the process, but
    it's not all that difficult, and employs exactly the same procedures used by
    the authors of the other modified releases. I used it myself to create an
    Abit 9R + HPT 2.32 modified BIOS (something never available from the FAQ),
    worked just fine. If you're REALLY stuck and confused by the process, I can
    probably dig out an old copy of my release somewhere, or make you a new
    release myself, or someone else in this forum probably already has one or
    knows where one might be posted. Just let us know.


    Jim, Apr 3, 2004
    1. Advertisements

  3. Frans Verhelst

    blah Guest

    You don't say if you need to install 3rd party drivers, which you probably
    do, is this the case.?
    When you first begin XP installation you need to have these drivers on a
    floppy disk and push F6 (look for message at bottom of screen)
    blah, Apr 3, 2004
  4. Frans Verhelst

    Qwest News Guest

    Ron A. Marraccini
    RAM Legal Systems - OBI #146
    2000 N.E. 42nd Ave., #192
    Portland, OR 97213
    (503) 232-2470
    Qwest News, Apr 3, 2004
  5. Frans Verhelst

    Qwest News Guest

    I have a modifed A9 bios w/ the latest 2.35 HP extensions
    for the RAID function. Additionally, there's a few more settings available
    like ACPI on/off etc.

    You would also have to install the 2.35 drivers from a floppy via the F6 at
    the XP install.

    This modded bios is for Versions 1.0 - 2.0 of the motherboard.

    Let me know if you need it.
    Qwest News, Apr 3, 2004
  6. Hello Jim, Blah and Ron,

    Many thanks for your advice: it works! I downloaded BIOS A9 including HPT
    BIOS 2.32 as well as the HPT driver 2.32 from www.sudhian.com, flashed the
    BIOS, installed the driver.............and the miracle happened: it
    functions! Great, thanks once more.

    Frans Verhelst, Apr 4, 2004
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.