1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

KVM refuses to allow >60 Hz refresh rate ... even though Windowsthinks it is

Discussion in 'ATI' started by bruce, Apr 17, 2004.

  1. bruce

    bruce Guest

    Here's an interesting question. I have an ATI 9600XT and a NEC Multisync
    FE950+ monitor, running under Windows 98SE.

    I can configure 75 Hz if I direct-connect the video card to the monitor.
    No problem. (I've downloaded the INF file so that the monitor is
    properly recognized as an NEC MultiSync FE950+ rather than a
    Plug-And-Play monitor, i.e. Windows knows exactly what refresh rates
    are supported, and isn't relying on the DDC signal from the
    monitor to find out)


    However, I just bought a D-Link DKVM-2K KVM switch and I only get 60 Hz
    at 1152 x 864 now. Sometimes.

    I can use Windows Display Properties to tell the 9600XT to output
    1152 x 864 x 85 Hz, but only 60 Hz shows up at the monitor (as
    proved by painful flickering, and the NEC's on screen display).
    If I exit Display Properties and come back in, I can confirm that
    Windows believes it is truly outputing 85 Hz.

    However, if I now directly connect the 9600XT to the monitor
    (no KVM), only 60 Hz results. So the 9600XT thinks it's putting
    out 85 Hz but it's only 60Hz. In other words, it's NOT the
    KVM switch that degrades the signal.

    Rather, the KVM switch seems to be blocking the signal and
    preventing the initial setup of 75 Hz.



    The only workaround I could come up with sucks. It's to boot up
    with the 9600XT directly connected to the monitor. 75 Hz is okay
    in that case. Then I unplug the monitor cable and hook it up
    through the KVM. In this case, the video card keeps pumping out
    a 75 Hz signal, and the monitor keeps displaying a 75 Hz signal.

    But all this plugging and unplugging kind of defeats the purpose
    of having a KVM switch!



    So ... is this a problem with the ATI drivers where it relies
    on some signal back from the monitor, which the KVM is blocking?


    Any advice would be appreciated. Thanks --

    Bruce
     
    bruce, Apr 17, 2004
    #1
    1. Advertisements

  2. bruce

    Kev Guest

    I've got the integrated KVM from Linksys and found this out:

    The computer needs to see the monitor when Windows boots up otherwise
    Win will not see any monitor and thus 60hz. Not bad for flat screens but
    lousy for crt's.

    So make sure the KVM is set to what ever computer is booting up then
    switch over.

    In XP the welcome screen is the refresh of Windows.
     
    Kev, Apr 18, 2004
    #2
    1. Advertisements

  3. bruce

    Mike Guest

    Dumb question. Did you do the video setup with the NEC ini file without
    the KVM connected. Monitor the PC. Then put the KVM in place.
    I have a Belkin KVM with a NEC FE950 and a keyboard plugged in. I use
    a separate mouse on each PC. I have no problems. One PC is a PIII
    with video at 1152x864 75Hz and the other is a PIV at 1280x1024 75Hz.
    I can boost that one to 85Hz with more res. The only issue is once
    in a great while, when I start to PIV, the monitor doesn't get the
    signal.
     
    Mike, Apr 18, 2004
    #3
  4. bruce

    bruce Guest

    Dumb questions lead to smart answers - I re-did the monitor setup
    without the KVM connected (switched from NEC FE950+ to generic
    SVGA 1280x1024x75 Hz monitor) and then hooked up the KVM. Now I
    can switch back and forth between 60 Hz and 75 Hz with no problem!

    (To double-check, I tried to change the monitor definition
    with the KVM in place, and sure enough, I was back to 60 Hz)

    So your suggestion was exactly right. Thanks! I owe you a beer
    in the name of dumb questions.

    Bruce
     
    bruce, Apr 18, 2004
    #4
  5. bruce

    bruce Guest

    One last follow-up, because it looks like the problem is
    a little more subtle than I had thought.

    If I install the ATI Control Panel software, I can't
    change refresh rates with the KVM inline - the refresh
    rate instantly locks on to 60 Hz. It looks like the ATI
    "Display" tab overrides Win98SE's Display Properties,
    determines that the monitor can only run at 60 Hz, and
    forces that mode.

    After uninstalling ATI Control Panel, I can switch refresh
    rates with no problems ...

    Anyway, thought I'd post this for the benefit of KVM users
    searching Google Groups in the future.


    Bruce
     
    bruce, Apr 18, 2004
    #5
  6. bruce

    Mike Guest

    I'm glad it works, but it does sound a bit odd on the final outcome.
    The cards that I switch between are; on the PIII an ATI Rage Fury Pro
    and on the PIV an ATI AIW 9000Pro. I run Win XP on both and SP1 with
    most of the updates on the PIV. I also use Catalyst 4.4 with MMC9.0.
    I just checked the frequency. It is at 75Hz and I just changed it to
    85Hz and back to 75Hz with no problem. I have heard of issues with
    Catalyst above 3.7 in some cases. The message Kev sent has a good
    point also, I have to make sure the KVM is locked in to the PC to boot
    or I may not get video.
     
    Mike, Apr 18, 2004
    #6
  7. bruce

    borolad Guest


    Quote : -

    PROBLEMS WITH XP REFRESH RATES

    This problem is about WinXP not applying the refresh rates and is
    always stuck at 60Hz no matter which resolution or Refresh rate you
    choose. This is how to fix it:

    1- Make sure you monitor is identified as Plug & Play or WinXP is
    using your Monitor driver.

    2- Right Click an empty space in your desktop and click PROPERTIES, in
    the display properties, click the followings: SETTINGS, ADVANCED,
    DISPLAYS, MONITOR. On monitor attributes, you will see that "USE DDC
    INFORMATION" is marked, and you will also see that the maximum
    resolution and refresh rate for your monitor are selected. Uncheck
    "USE DDC INFORMATION" and press APPLY. Now you can select ANY refresh
    rate supported by your monitor.

    If the control "USE DDC INFORMATION" is grayed out, here's a fix:

    1- Download and install the latest PowerStrip.
    2- Run it, it should Autodetect the problem and fix it automatically.
    3- Close and uninstall PowerStrip (if you desire)
    4- Restart your PC.

    When you return to XP the monitor controls should be enabled.

    There are two BAD things you should know:
    1- OpenGL games STILL have the refresh rate problem. (they will
    default to 60Hz)

    2- Your currently selected desktop refresh rate will be used for ALL
    your games, no matter which resolution you use in the game. Ex. If you
    choose a desktop setting of [email protected] then any game, even
    running at 800x600 or 640x480 will run at 75Hz.

    I hope one day MICROSOFT fixes this BUG and make the
    resolution+refresh rate system just like the one used in Win9x, where
    each resolution had it's own refresh rate setting and games run
    accordingly with it.

    Un-Quote, goto Ati help here :

    http://www.omegacorner.com/index_ati.html


    BoroLad
     
    borolad, Apr 18, 2004
    #7
  8. bruce

    chuckk Guest

    You found the cigar! The later monitors and LCDs send a block of
    information to the video card and driver, listing the the monitor ID and
    capabilities. The Belkin somehow blocks the information. So, windows assumes
    that the monitor was changeed from whatever the monitor reported to a
    generic monitor.
    Evidently Several of the ATI drivers do the same thing independent of the
    windows internal operations. To get around the problem, I generally set
    windows and the drivers as appropriate to allow all resolutions
    combinations. Another way is to find an inf file or the equivilent that
    defines a monitor that has similar characteristics and does not send the
    capability info to the video card and driver. This works well with older
    versions of windows. I haven't tested it with XP. Some games allow you to
    set both resolution and refresh rate regardless of the display sennings at
    the game start.A few of the older ones don't reset the display properly (or
    in a compatable manner with the current windows reset scheme).
     
    chuckk, Apr 18, 2004
    #8
  9. bruce

    bruce Guest

    Argh. Next time I'm going to wait a week and totally understand
    the issue before posting. After one or two reboots the
    "solution" didn't work any more. Now I'm relying on PowerStrip
    to take care of the refresh rate. So far it seems to work ...

    Bruce
     
    bruce, Apr 18, 2004
    #9
  10. bruce

    Mike Guest

    I don't like trouble making components, I would just return the Dlink
    and get a Belkin, which works just fine for me (using 98se and xp
    pro).
     
    Mike, Apr 20, 2004
    #10
  11. bruce

    Kev Guest

    However, I just bought a D-Link DKVM-2K KVM switch and I only get 60 Hz
    It's like i said. Boot into windows so that the computer sees the
    monitor than switch over.
     
    Kev, Apr 20, 2004
    #11
  12. bruce

    PhxGrunge Guest

    The KVM does not pass the DCC info to the video card. You must turn off DCC
    in display properties to stop Windows from looking for the signal. As long
    as DCC is set to on, and Windows does not see the signal, Windows will
    always revert to 60 Hz refresh. That's why when you direct connect monitor
    to video card, refresh is right, but remove the signal thru the KVM, and
    windows reverts to 60 Hz.
     
    PhxGrunge, Apr 20, 2004
    #12
  13. bruce

    Bruce Lin Guest

    Where is this setting? As I understand it, Windows XP has a specific
    setting where it says "use DDC settings" However, in Windows 98SE,
    which I run, there's no such choice. I can__ define the monitor type
    as something like "Generic Super VGA 1024 x 768" (which I understand
    it should not look for DDC information) instead of "Plug and Play
    monitor" (which should look for DDC information).

    However, even with the Generic monitor setting, and it still falls
    back to 60 Hz upon bootup.

    I think it's actually the ATI drivers which force the video card back
    to 60 Hz.

    Bruce
     
    Bruce Lin, Apr 20, 2004
    #13
  14. bruce

    PhxGrunge Guest

    In Windows 9x, display properties, advanced, monitor tab. Uncheck "Monitor
    is Energt Star compliant" and "Automatically detect Plug & Play monitors".
    This should stop Windows from using the DCC info. If not, then the inf file
    for the monitor must be edited so that DCC=0(or false).
     
    PhxGrunge, Apr 20, 2004
    #14
  15. bruce

    bruce Guest

    Okay, got it. Basically PhxGrunge was correct.

    In WinXP apparently there is an option to ignore the DDC
    signal. In Win98, the ATI drivers have this idiotic registry
    setting called

    "IDCRegOptionDontUseOSMonitorInfo" = hex 01,00,00,00

    which overrides whatever Win98 has configured under Display
    Properties. Changing the values to 00,00,00,00 (i.e.
    Use OS Monitor Info) and then rebooting fixed things.

    Uninstalling the Catalyst control panel turned out to be a
    wild goose chase.

    Anyway, thanks to all those people who had this ATI driver
    problem in the past who posted their solutions on Google
    Groups. And thanks to everyone here who offered suggestions
    and insight.

    Let this is my last post on the subject ...

    Bruce
     
    bruce, Apr 21, 2004
    #15
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.