1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Launch app (or shut off speakers) when docked?

Discussion in 'Laptops' started by Nick Spacek, Jul 10, 2006.

  1. Nick Spacek

    Nick Spacek Guest

    Hi there,
    I've got a Thinkpad T40p and I'm wondering if there is either an IBM or
    third party program to fire apps when you dock the laptop? Really I
    just want to disable the onboard speakers, but apparently the only real
    way to do that is to use the volume down button to lower it to nothing
    (if you hit mute it mutes through Windows I think).

    Thanks!
     
    Nick Spacek, Jul 10, 2006
    #1
    1. Advertisements

  2. Nick Spacek

    - Bobb - Guest

    Control Panel - SYSTEM - PROPERTIES - HARDWARE - Hardware Profiles
    There should be a Docked and a Undocked profile there and should config
    "however it was saved".
    So disable the onboard speakers in that profile and it should stay that
    way - when in that profile.
     
    - Bobb -, Aug 30, 2006
    #2
    1. Advertisements

  3. Nick Spacek

    Nick Spacek Guest

    Great, I didn't even know about that! Looks like it would work... my
    only problem now is, there's only an Undocked profile listed there, and
    if I make a copy of that I can't change the docked/undocked settings (I
    can't do that for the one that's there either).

    I was reading around the net and it seems like maybe I was supposed to
    install while on the dock? Though come to think of it, I'm pretty sure
    I did... I may refresh the machine but I'll have to go through all the
    updates again... oh well.

    Thanks,
    Nick
     
    Nick Spacek, Aug 31, 2006
    #3
  4. Nick Spacek

    - Bobb - Guest

    NICK,

    Do not reimage !!!!!!!!!!!!!

    Go back to the profiles screen.
    Copy the exiting and rename the new to be DOCKED
    Modify that Docked profile/ check the box to be a "portable computer".
    Turn off/on speakers/ network cards/ whatever.
    Boot the machine in the dock.
    If it does prompt you for which profile to use - select docked and then
    tweak it however you'd like.
    Rather than me tyiping it all, I just went to Google
    and entered:
    "creating a docked profile" to find this -

    Go here for the step by step:
    http://support.microsoft.com/kb/225810/
     
    - Bobb -, Sep 1, 2006
    #4
  5. Nick Spacek

    Nick Spacek Guest

    Right right, but the problem is the part where I can select portable is
    greyed out and I can't change the options for my new hardware profile.
    I did search around but nobody had posted a similar experience that I
    could find.

    Thanks for your help!
    Nick
     
    Nick Spacek, Sep 1, 2006
    #5
  6. Nick Spacek

    - Bobb - Guest

    Nick,

    You NEED to have admin rights to be able to enable "portable computer"
    box.
    Do you know what that means ? The account that you are logged on as -
    is it an admin account ?

    Right-click " My Computer " on desktop - MANAGE - Local Users -
    Groups - Administrators - Is your logon name listed there ?

    I'm on a DESKTOP PC right now running XP SP2 and if I go to System
    properties - Harware tab - hardware profiles it lists my only profile
    which is called Profile 1 ( Current). With it highlighted, I click
    properties and the box for " This is a portable computer" is unchecked,
    but it's not greyed out - even on a desktop. Under that box, the 3
    options are greyed, and the top one of those ( the docking state is
    unknown) is selected . Obviously this was never a laptop and it's an
    option for me.

    On your PC click HELP - type portable - hit <Enter>
    it will list a few SUGGESTED Topics- ignore those - click on "Full-text
    Search Matches (15 results)" tab further down that column - then #5 -
    "Hardware profiles overview" for a wlakthru.

    Still no good ? Let us know . I'd hate to have you go thru reinstall and
    find out - same thing.
     
    - Bobb -, Sep 2, 2006
    #6
  7. Nick Spacek

    - Bobb - Guest

    Nick

    If you have ANY account with admin rights, login there and just create a
    new account with admin rights.
    Call it Nick - logoff and back on as Nick - see if that works.
    Good luck.
     
    - Bobb -, Sep 6, 2006
    #7
  8. Nick Spacek

    Nick Spacek Guest

    Haha, yes I'm using an admin account here. Very strange then. I'll
    tell you one thing though, I'm not sure if it's related but I think it
    probably is. A while back there was a post on Digg about a privelege
    escalation flaw that would get you logged in as SYSTEM. After testing
    that on my machine (and suceeding) I noticed that the Thinkpad display
    manager wouldn't switch resolutions properly

    But anyways, there was no scientific process here, I just can't think
    of what else might have changed to make that stop working, and I'm
    thinking it might have made some other funky changes here (another
    thing is that instead of a black background when logging on I get the
    default background that accounts get when they're created, the one that
    the SYSTEM account had.

    So I might try disabling the SYSTEM account, or deleting the profile
    settings. I know that deleting it is probably not a very good idea.
    So I may refresh and see what happens, I'm not too worried or anything
    about refreshing, I keep my documents and stuff separated from my apps.

    Thanks for your suggestions,
    Nick
     
    Nick Spacek, Sep 7, 2006
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.