Leopard Permissions Bizarreness

Discussion in 'Apple' started by Zable, Nov 11, 2007.

  1. Zable

    Zable Guest

    I'm running a G4, silver front, 1.0 mhz, 2 gig RAM.

    I installed Leopard over 10.3.9 and everything was going fine for a a
    few days. Then, things began to slow down, with the spinning beachball
    going on for about 30 seconds every time I tried to do anything.

    I booted from another internal HD and used Disk Utility to repair the
    directory. The primary HD came up as "Okay". Then I repaired the
    permissions, and a bunch needed and received repair, except for the
    first item in the list. The report came out like this:

    Warning: SUID file "System/Library/CoreServices/RemoteManagement/
    ARDAgent.app/Contents/MacOS/ARDAgent" has been modified and will not
    be repaired.

    I located this ARDAgent file, and sure enough it's there, but I have
    no idea what it does, or how it got "modified." I decided to try
    reinstalling Leopard. The install crashed in the middle of
    installation. I'm working now from a duplicate copy of my internal HD
    that I backed up with Retrospect to an external HD, thankfully.

    Anyone have any idea what's going on and what to do about it?

    Thanks!
     
    Zable, Nov 11, 2007
    #1
    1. Advertisements

  2. Zable

    David Empson Guest

    What method did you use to do the installation? Was it an "Upgrade" (the
    default) or did you choose "Archive and Install"?
    As far as I know, that message is appearing for everyone when they
    repair permissions under Leopard. It is certainly common.

    I expect it will be fixed in 10.5.1. As far as I know this is just a
    misleading warning and it doesn't convey any useful information.
    There was an Apple Remote Desktop 3.2.1 update that was offered by
    Software Update immediately after Leopard was installed. I expect it
    installed a modified version of that file and there is a conflict
    between Leopard and that update which is causing Repair Permissions to
    display an error message.

    It is highly unlikely that this has anything to do with the slow down
    effect you observed.
    Probably overkill.
    What method did you pick to do the reinstall? Was it "Archive and
    Install" or "Erase and Install"? (You probably couldn't use an Upgrade
    or Full Install at this point.)
    At this point and assuming you have at least one full backup (I'd be
    happier with two, in case the backup drive failed), I suggest doing an
    "Erase and Install" on your main drive, then use the migration option to
    transfer all your data and applications over from the backup.

    The problem with the slowdowns could be:

    (a) Some third-party software installed deep in your original 10.3.9
    system is not compatible with Leopard. Trying to retain it by doing an
    "Upgrade" install may have resulted in an unstable Leopard system. This
    can be avoided by using "Archive and Install".

    (b) Most third-party software (not buried deep in the system) will be
    retained even over an "Archive and Install" or a migration. Leopard
    compatibility issues with this software might result in overall system
    performance problems.

    (c) Bugs in Leopard.

    (d) Insufficient memory. Not likely if you have a Mirrored Drive Doors
    G4 with 2 GB, unless you are running very memory-hungry applications and
    the added memory requirements of Leopard compared to Panther are now
    pushing you over the limit.

    (e) Computer is too slow. Possible if you are running anything
    particularly processor intensive.

    Once you get back up and running again, if the slowdown problems
    persist, you might be able to learn more about them by running Activity
    Monitor and watching for heavy CPU usage and/or heavy memory usage (page
    outs are the most likely explanation given your description of the
    symptoms).
     
    David Empson, Nov 11, 2007
    #2
    1. Advertisements

  3. Alsoft, publishers of DiskWarrior, warn against repairing permissions on
    a Leopard system unless you are booted in Leopard.

    <http://www.alsoft.com/DiskWarrior/support.html>
     
    Neill Massello, Nov 11, 2007
    #3
  4. That has to do with running DiskWarrior, not with repairing permissions.
    My reference to DiskWarrior was meant only to identify Alsoft for those
    who might not recognize the name. The following appears in the second
    section under Support News on the web page I cited, Alsoft states.
    In the context of the entire post, the OP's statement that he "booted
    from another internal HD" and repaired permissions strongly implied that
    he had done so from a pre-Leopard system, which is what Alsoft warns
    against in the parapgraphs quoted above.
     
    Neill Massello, Nov 11, 2007
    #4
  5. Zable

    David Empson Guest

    I only did a permission repair after installing the Apple Remote Desktop
    3.2.1 and Login and Keychain 1.0 updates. It might be triggered by
    either of those.
     
    David Empson, Nov 11, 2007
    #5
  6. I tried repairing permissions from Leopard's Disk Utility and it hung my
    mac.

    I booted from the install DVD and tried again. It hung my mac.

    Lawson
     
    Lawson English, Nov 12, 2007
    #6
  7. Zable

    Kir?ly Guest

    Your whole Mac? Or just Disk Utility?
     
    Kir?ly, Nov 12, 2007
    #7
  8.  
    Leonard Blaisdell, Nov 12, 2007
    #8
  9. Zable

    Zable Guest

    The whole mac. I've since completely erased the hd, zeroed it out, and
    reinstalled the entire contents from a duplicate backup. Things seem
    to be working fine now, but I still wonder what happened in the first
    place.
     
    Zable, Nov 12, 2007
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.