login window empty after initial login window hang

Discussion in 'Apple' started by ronald.rood, Feb 23, 2005.

  1. ronald.rood

    ronald.rood Guest

    Hi,
    I have this little problem, my system 10.3.8 is ill (the flu is all
    around us..)
    First a fresh burned cd would not eject. I forced a boot and at that
    time the boot process hung in 'starting login window'.
    I used disk utility to repair the boot disk and all problems found were
    fixed. (There were quite a few orphaned inodes) After the fix (?) the
    hang was gone so that was solved. Only this time the accounts were
    gone... Manually entering the account info was not accepted. :-(
    So I booted single user to try to check the account info.
    nicl . -list /
    does not work, I guess it's because the required netinfo daemons are
    not running in single user mode. How can I bring the mac to a higher
    run-level (multi user mode) without being thrown from the root prompt ?
    Or how else could I fix this ?
    I don't want to re install the system if not absolutely needed. If I do
    need to do so, would a preserve account and network setting be of any
    use ?

    thanks for any usefull hint/tip,
    Ronald.
     
    ronald.rood, Feb 23, 2005
    #1
    1. Advertisements

  2. ronald.rood

    ronald.rood Guest

    In the meantime I found http://www.drmac.net/tips/unix/single-user.html
    When trying to local.nidb I get 'Invalid Datastore'
    The network.nidb is readable and looks ok to me.
    on su - my_account I get 'unknown login'.

    What could I do next ? (copy network.nidb over local.nidb ?)

    regards,
    Ronald.
     
    ronald.rood, Feb 23, 2005
    #2
    1. Advertisements

  3. ronald.rood

    matt neuburg Guest

    Gone in what sense? Are you saying that a directory /Users/someone was
    mysteriously deleted? Or is the data there, but the users are "gone" in
    some other sense? What sense?
    I'm not following what the problem is. You don't need to be in
    single-user mode to use nicl:

    gromit:~ matt2$ nicl . -list /
    1 users
    2 groups
    3 machines
    4 networks
    5 protocols
    6 rpcs
    7 services
    8 aliases
    9 mounts
    10 printers
    68 afpuser_aliases
    72 config

    m.
     
    matt neuburg, Feb 23, 2005
    #3
  4. ronald.rood

    ronald.rood Guest

    Thanks for you response Matt,
    I know, I used nicl a lot. On my system while in single user mode it
    did not return. Single user mode was the only way to connect. It looks
    like the netinfo database is corrupt. In the meantime I decided to
    re-install the system, after making a backup of the data.
    The root filesystem has journaling. How can that netinfo database get
    corrupted ? I run X since the first available pre release and never had
    any problem, until now :-(

    Ronald.
     
    ronald.rood, Feb 24, 2005
    #4
  5. ronald.rood

    Tom Stiller Guest

    Disk journaling only attempts to keep the filesystem consistent; it is
    not responsible for the contents of the files themselves.

    If a rogue program writes incorrect data, the journal, knowing nothing
    about the significance of the data, will make sure the data gets written
    back to the filesystem.
     
    Tom Stiller, Feb 24, 2005
    #5
  6. ronald.rood

    ronald.rood Guest

    Yes, that is true and I understand that. What surprized me was the
    number of files that had orphaned inodes.
    BTW: completed backups.
     
    ronald.rood, Feb 24, 2005
    #6
  7. ronald.rood

    matt neuburg Guest

    I just want to add that I find the general reluctance to re-install the
    system ("I don't want to re install the system if not absolutely
    needed") quite mystifying. It's easy and fast. Simply use Disk Warrior
    to repair the disk regularly, and reinstall the system (does not require
    erasing old system) when there is trouble. m.
     
    matt neuburg, Feb 24, 2005
    #7
  8. ronald.rood

    ronald.rood Guest

    In the end it would have been the fastes way to get it all up and
    running, like it is now. Most things are working now (not Stuffit
    Expander) and a few customizations have to be done now. Not to hard.
    Oracle will be running tonight.

    regards,
    Ronald.
     
    ronald.rood, Feb 25, 2005
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.