1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Looking for Creative EMU10K1 SB! Live Audio Processor sound drivers

Discussion in 'Soundblaster Live' started by Jake, Feb 18, 2005.

  1. Jake

    Jake Guest

    Hello,

    I upgraded the OS on my PC and now I can't seem to get the sound to
    work, even though I installed Windows XP, which you'd think would have
    the standard sound drivers.

    I downloaded a utility that tells me I have the following sound card:

    Creative EMU10K1 SB! Live Audio Processor

    Does that mean the card is onboard and am I looking for EMU10K1 SB Live
    sound drivers or just the standard SB! live sound drivers? I tried the
    standard SB! live sound drivers and nothing! It was working fine before
    I formatted and reinstalled the OS.. In hindsight, I should have checked
    the sound drivers before I formatted but it's too late now..

    Can anyone help? I tried driverguide.com but the file on there doesn't
    download. Can anyone tell me where I'd be able to download sound drivers
    for the above sound card?

    Thank you in advance.

    J.
     
    Jake, Feb 18, 2005
    #1
    1. Advertisements

  2. Jake

    Lenny Guest

    EMU10K1 is the sound chip used in the soundblaster live, so that it
    identifies as such is quite normal and expected. :) You should be able to
    grab these drivers the normal way from Creative, you could try the
    auto-updater available from the support page (you must use IE as your
    browser as it's an activex plugin).
     
    Lenny, Feb 19, 2005
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.