LPT1 "can not be opened" with Win98SE/ MicroStar MS-6167 motherboard

Discussion in 'MSI' started by Dave Matthews, Dec 15, 2003.

  1. Hi folks,

    I've got a rather bizarre problem with a client's machine at the
    moment...

    Essentially I can print (to a Canon BJ-200 inkjet) absolutely fine when
    running DOS applications but when in Win98SE, printing from any application
    (eg Word, Excel or even just the "Print Test Page" facility in the printer's
    driver software) produces an error along the lines of "LPT1 can not be
    opened". Here are the steps I've taken so far and the findings:

    I tried deleting and reinstalling the printer's drivers twice (using
    those provided on the Win98SE installation CD and Canon's own drivers
    respectively). This produced no difference.

    I tried changing the parallel port mode from SPP to EPP, ECP and EPP+ECP
    but none of these made any difference.

    The printer works absolutely fine when attached to other PCs running
    Win98SE

    The printer cable (standard parallel) works fine with other PCs

    Setting up a different model of printer (Panasonic KX-P6300) on the
    client's PC produces the same problem.

    Booting the PC straight into DOS allows me to run basic printer commands
    like "DIR >LPT1" absolutely fine, so the PC is certainly "talking" to the
    printer. However if I boot up Win98SE as normal then "Restart in MS-DOS
    mode", I can't print from DOS this way (presumably because Win98SE is,
    essentially, still running "in the background"...?.)

    I have reinstalled Win98SE from a freshly-formatted hard disk but still
    no joy.

    I have reset the motherboard's (MicroStar MS-6167) CMOS (via on-board
    jumper) but this didn't help, either.

    In Win98 there is at least some form of communication going on between
    the PC and printer. During Win98 startup or when I clear down a print job
    from the print queue, the printer goes through its expected "reset" cycle.
    The printer also "parks" as expected when I close Win98 down.

    Until three days ago, the PC was working quite happily with the printer
    and this problem has just sprung up out of the blue.

    I can only come to the conclusion that there is some sort of hardware
    problem with the motherboard that is not being picked up during Power-On
    Self-Test. So my next move is to try a replacement motherboard, though
    finding one might be difficult for a four-year-old CPU (Athlon 500) and
    memory. Unless anyone else has any other ideas...? Or does anyone know if
    the MS-6167 is prone to this fault?

    Many thanks in advance!

    --
    Cheers,


    Dave Matthews

    'New Avengers' and 'Professionals' sites at:
    http://www.mark-1.co.uk
     
    Dave Matthews, Dec 15, 2003
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.