M3A and ATAPI

Discussion in 'Asus' started by Rhino, Jun 19, 2011.

  1. Rhino

    Rhino Guest

    I'm trying to install the latest IDE drivers for an M3A motherboard but I'm
    not finding them on the ASUS site. Can anyone point me in the right
    direction?

    --

    Here's some background.

    I'm having a strange issue with regards to the ATAPI settings in my
    computer. I'm running a 2.5 year old ASUS M3A and Windows XP SP2.

    My basic issue is that I can't turn on the DMA on my LiteOn DVD burner
    (model DH20A4H). I've never been able to get the DMA to work since my friend
    built the computer for me. It works fine except for the DMA issue but I
    thought I'd finally see if I could resolve the problem so that my DVDs could
    be burned more quickly.

    I've been working with the LiteOn folks and, following some instructions
    they gave me, discovered that Device Manager is showing TWO Primary IDE
    Controllers and TWO Secondary IDE Controllers; the settings on the two
    Primary Controllers differ which may be why I'm having the problem with the
    DMA. The LiteOn people recommend updating the IDE drivers to see if that
    helps.

    I found the M3A downloads page easily enough -
    http://ca.asus.com/en/Motherboards/AMD_AM2Plus/M3A/#download -
    but I'm darned if I can find IDE drivers there. I've looked in all of the
    categories. I'm not seeing IDE mentioned in any of the descriptions but they
    are very brief. I'm guessing that IDE drivers are included in at least one
    of the different downloads; I'm just not sure which one....
     
    Rhino, Jun 19, 2011
    #1
    1. Advertisements

  2. Rhino

    Paul Guest

    Not to spoil your fun or anything.

    I tried downloading the AMD chipset drivers from the M3A support.asus.com
    download page.

    http://dlcdnet.asus.com/pub/ASUS/misc/utils/AMD_Chipset_V51010007.zip

    Next, I use 7ZIP to open the ZIP and navigate around.

    I look at atihdc.inf and it says:

    [ati_pciide_Inst]
    Include=mshdc.inf

    What that means, is the installer calls the standard Microsoft driver.
    It's just a wrapper for the standard Microsoft installer.

    It does do a few more things. For example, I see a "TransferModeTiming"
    registry entry, but haven't a clue what it does.

    So the driver isn't exactly "brimming with custom goodness". It
    doesn't seem to be installing code for IDE.

    *******

    What happens if you use an 80 wire cable, between the optical drive and
    the motherboard IDE connector ? Do things change for you ?

    I tried a few utilities I have here, and so far, haven't succeeded in
    verifying my own IDE optical drive transfer rate. So I can't help you there.
    Maybe someone else has a solution for that. I'd prefer to see a separate
    utility, verify the transfer mode.

    In Device Manager (on my quite different motherboard), I have one
    Primary IDE Channel entry in the IDE/ATA/ATAPI controllers section.
    There is room for "Device 0" and "Device 1", but I only have
    one IDE device on the ribbon cable, and that is Device 0.
    Transfer mode status says "DMA if available" and the
    Current Transfer Mode says "Ultra DMA Mode 2". I presume
    that is a 33MB/sec UDMA mode. I'm using an 80 wire cable.

    http://en.wikipedia.org/wiki/UDMA

    Paul
     
    Paul, Jun 20, 2011
    #2
    1. Advertisements

  3. Rhino

    Rhino Guest

    According to Device Manager, the driver on the both instances of the Primary
    IDE Controller and both instances of the Secondary IDE Controller have a
    date of 2001-07-01 (Version 5.1.2600.2180). Is it just me or does that seem
    really old? That's just days shy of 10 years old. I would have thought these
    drivers would change periodically....

    For what it's worth, the ATI IDE Controller has an ATI driver dated
    2006-01-22 (Version 5.0.0.3).
    Updating that seems pointless then....
    Sorry, I'm a software guy, not a hardware guy. I literally haven't had the
    case open since I got the computer and reinstalled the cooler.

    Is an 80 wire cable what I should have had from the beginning?

    If multiple cables are possible here, could you possibly point me to
    pictures of what each of those cables looks like, especially the ends. Then
    I can open the case and see what I've actually got and compare it to what I
    should have.
    Each of my four instances (2 Primary IDE and 2 Secondary IDE) has a Device 0
    and a Device 1 in the Advanced Settings but I'm not 100% sure how to tell if
    there are actually 2 devices visible to the system in each instance. I've
    done screen caps of the Advanced Settings for each of the four instances
    which I'd be happy to share but I'm not sure where I can put them so that
    you can see them. I've never seen anyone put attachments on a newsgroup post
    ;-)

    Hmm, maybe I'll just describe them and hope that my description is as clear
    as a picture would be....

    Primary IDE Controller (1st Instance):
    Device 0 Device Type: greyed out but set to Auto Detection
    Device 0 Transfer Mode: DMA if available
    Device 0 Current Transfer Mode: PIO Mode
    Device 1 Device Type: Auto Detection
    Device 1 Transfer Mode: DMA if available
    Device 1 Current Transfer Mode: Not applicable

    Primary IDE Controller (2nd Instance):
    Device 0 Device Type: greyed out but set to Auto Detection
    Device 0 Transfer Mode: DMA if available
    Device 0 Current Transfer Mode: Ultra DMA Mode 6
    Device 1 Device Type: Auto Detection
    Device 1 Transfer Mode: DMA if available
    Device 1 Current Transfer Mode: Not applicable

    Secondary IDE Controller (1st Instance):
    Device 0 Device Type: Auto Detection
    Device 0 Transfer Mode: DMA if available
    Device 0 Current Transfer Mode: Not applicable
    Device 1 Device Type: Auto Detection
    Device 1 Transfer Mode: DMA if available
    Device 1 Current Transfer Mode: Not applicable

    Secondary IDE Controller (2nd Instance):
    Device 0 Device Type: greyed out but set to Auto Detection
    Device 0 Transfer Mode: DMA if available
    Device 0 Current Transfer Mode: Ultra DMA Mode 6
    Device 1 Device Type: Auto Detection
    Device 1 Transfer Mode: DMA if available
    Device 1 Current Transfer Mode: Not applicable

    Why do I have two instances of each the Primary IDE Controller and the
    Secondary IDE Controller? I'm really not clear if that is a problem or if it
    is perfectly fine.

    I should point out that I have two hard drives. Does that explain the extra
    instances of Primary and Secondary IDE Controllers?
     
    Rhino, Jun 20, 2011
    #3
  4. Rhino

    Paul Guest

    The wire question is a pretty simple one. There are two flavors of IDE ribbon
    cable. The original kind, has 40 pin connectors and 40 wires. You simply count
    the wires across the width of the cable.

    Later, they invented the 80 wire cable. The wires are thinner and there are
    twice as many across the width of the cable. Some motherboard boxes bundled
    a 40 wire and an 80 wire cable, with the intention the 40 wire be used
    with optical drives, the 80 wire on hard drives. But I see no reason to
    use anything other than 80 wire cables. (The 80 wire cable still has 40 pin
    connectors, and is compatible at the connector level.)

    The thing is, the 80 wire cable has every second wire grounded. This improves
    the transmission line qualities of the cable, allowing up to UDMA133. The
    driver is supposed to be able to detect cable type (according to the t13.org
    standard "most of the time"). If you change cables, the driver should
    automatically see the improvement, from a status bit point of view.

    The Windows driver can get "stuck in PIO mode". This happens if too many CRC
    errors are detected. So there is a situation where slow storage device performance
    is due to the cranking down of the speed, by the driver. The driver needs to be
    beaten with a stick, to get back the full rate. (See workaround section)

    "IDE ATA and ATAPI disks use PIO mode after multiple time-out or CRC errors occur"

    http://support.microsoft.com/default.aspx?scid=kb;en-us;817472

    So PIO mode can come from driver crankdown. Driver crankdown to PIO speeds,
    is an "innovation" copied from Unix boxes (I had to battle this on a Sun box,
    on SCSI bus).

    *******

    You can share images, if you use a photo hosting site.

    On my motherboard, I'll confess that I can't explain the number of entries
    I've got. I should have six SATA and two entries for my single IDE ribbon
    cable. This is what mine looks like.

    http://img707.imageshack.us/img707/6797/sataandide.gif

    I think your two "Ultra DMA Mode 6", could be SATA hard drives, but there
    is nothing in the text to confirm that. It's just a guess. SATA drives
    aren't actually limited to that speed, and that is just a placeholder. On
    Intel chipsets, typically that bogus string says "Ultra DMA Mode 5",
    as it is an Intel tradition, to limit their disk interfaces to
    100MB/sec, to separate themselves from the "133MB/sec crowd". Other
    brands use the "Mode 6" in theirs, but the actual SATA cable speed
    can be higher than that, and is not tied to "multiples of 33". SATA
    rates come in 150/300/600 minus overhead.

    Your PIO is the suspicious one. It could be a ribbon cable thing, which
    might improve with a different (80 wire) cable. Or, it could be
    the driver cranked it down, and you need to follow the Microsoft
    workaround suggestion in the KB article above. Fixing the PIO
    issue won't last, if there are still CRC transmission errors present.
    But if the cable is good, and you use the workaround, the improvement
    should "stick".

    Paul
     
    Paul, Jun 20, 2011
    #4
  5. Rhino

    Rhino Guest

    I spent some time this afternoon looking around inside the computer. I did
    my best to determine if I had a 40 or 80 wire cable and I _think_ I have an
    80 wire cable.

    I wish I could say that with certainty but counting the wires was harder
    than you might think: I have cataracts in both eyes that aren't operable yet
    and I had a _heck_ of a time getting enough light on the cable - and holding
    a magnifier over it so that I had some hope of seeing well enough - to count
    the wires. The connectors had 40 square holes at each end (well, one
    connector was actually 39 since the middle one on one row was blocked off);
    I'm quite certain of that. The cable seemed to be exactly 2 inches wide and
    I measured a quarter of an inch with an accurate ruler. As best I could
    tell, there were 10 wires in that quarter of an inch, not 5, so that makes
    80 wires in two inches.

    Still, just as a precaution, I took some photos - subject to the same
    limitations - and put them in a public area of my Flickr account. Here's the
    URL: http://www.flickr.com/photos/56885811@N08/sets/72157627007235956/

    There are several pictures of the same wire; hopefully they will help you
    satisfy yourself that it is an 80-wire cable. If it isn't, please tell me
    so! As you can tell by now, my eyesight is not very good. Also, I have
    several lenses for my camera but none of them seems to let me get really
    close and zoom in on that wire to make it really big.

    I've also put the screen caps from Device Manager in that set of photos.

    While I had the case apart, I removed the burner from its position and
    disconnected all of the cables. I took a couple of pictures of the back of
    the burner to show its exact layout as well as to show that the only jumper
    is set to Master.

    I also had a look at the hard drives and found that there are absolutely no
    jumpers on them but I didn't take any pictures of the hard drives.

    By the way, on the off chance that disconnecting and reconnecting the cable
    to the burner fixed something, I checked Device Manager after I'd put
    everything back together again and found that everything was exactly the
    same. I also started Nero and it again complained that the burner was not in
    DMA mode.

    I tried the workaround and it worked!! At least I think it did. The Primary
    IDE controller that was set to PIO mode now says "Ultra DMA mode 4". Also,
    Nero no longer complains that I'm not in DMA mode. I haven't actually tried
    burning a CD or DVD but I'm cautiously optimistic that it will be faster
    than it used to be, which is all I really wanted. I'm not sure if I'll get
    the maximum possible speed or if I'll be running in some kind of reduced
    speed but I'll probably be able to live with whatever I get; it's bound to
    be better than the previous speed, right?

    I've added a screen cap of the new version of the first instance of the
    Primary IDE Controller to the Flickr photos.
    My two hard drives are model Seagate ST3750630AS; the Seagate website says
    they use the SATA 3 Gb/s interface. (I have an ancient copy of Everest Home
    Edition, Version 2.2.405, which says the drives are ATA but I'm guessing
    that's because SATA wasn't fully formalized when that version of Everest was
    written.)
    I've got my fingers crossed that this workaround solved the problem or at
    least improved things dramatically. Let's see how long it lasts....

    Thank you VERY much for your assistance Paul! I think I've given you way too
    much information in this email so forgive me for that. I'm just trying to
    explain myself clearly so that you can catch any errors I've made through my
    own inexperience with hardware issues.
     
    Rhino, Jun 21, 2011
    #5
  6. Rhino

    Paul Guest

    I used the first photo in your Flickr, and counted 10 wires, then estimated
    how many groups of 10 I could fit, and I got 80. So the first picture
    is of an 80 wire cable. I could kinda tell, from the tiny gauge of each
    wire that it was an 80, but I used the guesstimate method to verify wire
    count.

    If you're visually impaired, you have the option of using a blunt object
    (don't poke holes in the cable) to "ride" over the ridges of each wire and
    count the ridges.

    As long as the Microsoft workaround "sticks", you're done. If the cabling
    continues to cause CRC errors, you could be back in PIO mode a week from now.
    So time will tell whether this is good enough. I've run into people, who
    have done the workaround over and over again.

    If cabling a single drive to an IDE cable, the first drive goes on the end.

    Mobo ------------X------X IDE ribbon cabling
    |
    First
    Drive

    Doing so, gives excellent signal integrity and no CRC errors.

    If you do a single drive like this, this is *not* good. The portion
    of cable to the right, is termed a "stub" and causes reflections.
    If you cable this way, be prepared for "PIO Mode" as your reward.
    And the PIO mode will keep coming back.

    Mobo ------------X------X IDE ribbon cabling
    |
    Unhappy
    Drive

    Obviously, this configuration also works. There wouldn't be two
    connectors if it didn't work :)

    Mobo ------------X------X IDE ribbon cabling
    | |
    Second First
    Drive Drive

    So if you've wired your optical drive, like in the "Unhappy Drive"
    picture, that would explain your CRC errors.

    You can do UDMA133 with two drives like in the last diagram.
    You can mix a UDMA33 optical drive, on the same cable as a UDMA133
    hard drive, and it should all work. Long long ago, there may have
    been interaction issues, but with modern hardware, they seem to
    behave independently and don't interfere with one another.
    Each can use a different rate when operating.

    Paul
     
    Paul, Jun 21, 2011
    #6
  7. Rhino

    Rhino Guest

    Just to confirm, the diagram above should have the "First Drive" at the X
    that is farther from the Mobo, right? I think this part of the note is being
    rendered by a proportional font so the vertical bar coming from the First
    Drive may be out of position....
    I'll have to double check but I _think_ this is how my cable went. I'm going
    to have to go back in there and put the burner on the second connector so
    that I stop the reflections. That sounds like it may be my problem right
    there!

    Should I do the workaround again after changing the cabling? Or is the DMA
    mode likely to go to its optimum value immediately (or after the next
    reboot) without having to do that?

    I was going to open the case up again tomorrow anyway after my hand vac is
    fully recharged; I was going to try to suck up some of the dust with it
    today but there was only a tiny amount of charge left in it. I'll deal with
    the cable then.
    The drives you are taking about here are burners and not hard drives, right?
    That's good to know ;-)
     
    Rhino, Jun 21, 2011
    #7
  8. Rhino

    Paul Guest

    You should be able to copy the posting into Notepad, apply Courier
    font, and the figure should line up. As far as I know, my postings
    are text only and there should be no "font hints" in them.

    I use a fixed font when I type the posts, to make it easier for
    me to make tables or draw stick figures.

    With a single drive, the drive goes on the *end* of the cable for
    best results.

    When I say drive, it can be a hard drive or an optical drive. For
    electrical reflections and corrupted data, the drive type doesn't
    matter. They both can get corrupted, they both can be subject
    to CRC errors.

    Whether the workaround is necessary again, depends on whether your transfer
    rate has dropped. If it is still at 33MB/sec UDMA mode, then no need to
    panic. If it has dropped to some other, inferior rate, then apply the
    workaround again. As I understand it, the speed drops in steps,
    so doesn't instantly go to the lowest PIO speed when errors are
    detected on the cable.

    I don't actually know how many CRC errors it takes.

    Paul
     
    Paul, Jun 21, 2011
    #8
  9. Rhino

    Rhino Guest

    As soon as I put that section of your email into Notepad, the vertical bars
    moved to where they were consistent with what you were describing in words.
    As I suspected, the first diagram showed the "First Drive" right at the far
    end (farthest from the mobo) and the second diagram showed the "Unhappy
    Drive" at the connector closer to the mobo.
    I'm not sure from that whether you're suggesting I do something different in
    the way my hard drives are connected. They don't use ribbon cable so I'm not
    sure what I could or should do about them.

    For what it's worth, I burned a DVD this morning and the process was much
    faster than it had been before. It started out somewhat more slowly than I
    was used to in the sense that it seemed to linger at 1%, then 3% for longer
    than it had in the past but the burn of the disk was over much sooner than
    it ever was in the past.

    I put nearly 4 GB on this particular DVD-R and I doubt it took more than 10
    minutes, although I didn't really watch the time very closely. Previously,
    that disk would have taken a good half hour or 40 minutes. (I've never
    actually timed burns so this is just a ballpark estimate.)

    I'm already very pleased with the improvement. If that improves further when
    I move the cable this afternoon, that will be terrific.
    How can I measure my real transfer rate (as opposed to determining my
    theoretical maximum transfer rate) and count CRC errors? I assume that there
    are some freeware utilities out there that will do that - or maybe even some
    native Windows utilities - but I'm not familiar with any offhand. If you can
    suggest some, I'll take some measurements and see how I'm doing just to make
    sure everything is as good as I can make it.
     
    Rhino, Jun 21, 2011
    #9
  10. Rhino

    Paul Guest

    On the software utility front, I've got nothing to offer.
    I've had poor luck, getting access to the more useful counters.
    You can try the Performance plugin, and look at the list of
    counters there, but I don't think CRC is there.

    The Performance plugin can measure disk read and disk write
    rates. I use that all the time for benchmarking. I also add
    a couple extra columns to Task Manager, with "read bytes" and
    "write bytes", as that allows me to predict when a command
    that produces a lot of data, is going to finish. (For example,
    if a backup is going to produce a 76GB backup image, I
    can watch the backup command produce data until it hits
    76GB total. So I can look at the number as a progress
    indicator, for commands that lack good visual feedback.)

    For SATA cables, those are point to point, and there is no
    signal integrity issue with those. (If you pinch the cable,
    you can ruin it.) SATA is the thin, typically red colored cable.
    It operates at 1.5/3.0/6.0 Gbit/sec and is terminated differentially
    at the receiving device. It constitutes about as close to "electrically perfect"
    as you can get. The cabling is a bit lossy (but that's to be expected
    at such a high frequency), which is why SATA is limited to 3 to 6 feet
    of cable. If a SATA hard drive had an issue, all you could do is
    try another cable.

    The IDE cable on the other hand, is a far from perfect interconnect.
    The bus has signal reflections on it. If there were oscilloscope pictures
    from it, it would look scary. You'd be saying "that's my data ???".
    If the cable was made longer, the reflections would look even worse,
    or wouldn't settle in time before the clocking of the data value
    occurs.

    Optical burners have features such as "Burn Proof", which can compensate
    for less than perfect cable transfer rates. For example, by accident,
    I started a burn on a USB optical drive, when the drive was running
    in USB 1.1 data rate (instead of USB 2.0). The transfer rate in that
    case is 1 MB/sec (lower than is needed for a typical burn). The LED
    on the burner wouldn't stay constantly lit during the burn, due to
    the optical drive "under-running" from data starvation. But due to
    Burn Proof, the disc was still good. That's pretty amazing, when they
    used to claim a burn had to occur as a continuous spiral to work, and
    underrunning would produce a coaster. Somehow, they've got some way
    of "splicing" the write so it all works (I don't know the details
    on that). It turned out my USB2 driver had gone missing and I
    didn't clue in, until I saw the flashing optical drive light
    (and Nero said my burn would take several hours to complete :) ).
    The disc was a DVD-9 dual layer.

    Paul
     
    Paul, Jun 21, 2011
    #10
  11. Rhino

    Rhino Guest

    [snip]
    What's "the Performance plugin" and where can I find it?
    So I don't really need to worry about that then. I'll simply replace the
    cable if I get symptoms that the cable is pinched. What symptoms would I
    expect then? Writes to the hard drive taking much longer than usual? Or
    actual error messages popping up? Or the Blue Screen of Death itself?
    Sounds like optical burners need to start using the SATA approach ;-)
    I'm glad it gave you some clues about why it was misbehaving. Sometimes,
    these computers don't give you very obvious clues at all about what's going
    wrong on them.

    I remember a work computer I had once that kept crashing, probably a couple
    of times a week at its worst. It was running OS/2 and when I'd call Help
    Desk, they'd advise me to reinstall OS/2. After doing that several times, I
    spoke to a technical guy I knew and described my symptoms. He said it
    sounded like an I/O Controller issue - this was almost 20 years back so I
    may be misremembering the name of the component - and he helped me arrange a
    replacement of that component, which completely solved the problem. I was
    still just transitioning to PCs at the time so I remember being very
    surprised that PCs even had hardware issues; on mainframes, the issues were
    almost always software. But it was a handy experience. Not too much later, I
    started having some similar symptoms on my home computer and it turned out
    to be a problem with the same component as the work computer; replacing that
    component fixed my home PC too. But I'm darned if I can remember any obvious
    symptoms on either computer that suggested that the I/O Controller had a
    problem!
     
    Rhino, Jun 21, 2011
    #11
  12. Rhino

    Paul Guest

    If you look in Control Panels under Administrative Tools, there is
    an option there called Performance. If you right click in the
    graph pane, you can select Add Counters. I think the Delete key
    can be used to delete the existing graphs. You'll also need
    to scale the graphs, because the graph thing really isn't
    all that smart. On my machine, setting the graph scale to
    10000 gives 100MB/sec full scale on the graph. Since new
    disks can hit 125MB/sec, I set the graph scale to 20000 so
    the full scale is 200MB/sec. (The first time, I calibrated
    against HDTune, so I could be sure of what it was measuring!)

    Other graph types have different scaling requirements.
    That's part of the fun of using it I guess.

    If you go to Start : Run, you can type perfmon.msc and
    run the plugin directly that way. That is a second way to
    reach it.

    The Add Counters thing has the counters in groups. The ones
    for the disks are under "PhysicalDisk". I use things
    like read bytes per second and write bytes per second and
    select "total" as I'm too lazy to be more specific. Usually
    during benchmarking, only one disk is doing the reading,
    one disk the writing, and a total count is good enough.

    The counter only detects certain kinds of operations. Some
    operations "slide under the radar", so not every operation
    gets counted. And yes, that can be a nuisance.

    To give an example of things that slide under the radar, I
    set up a RAMDisk on a computer, the RAMDisk claimed to be
    offering "hard drive emulation", and yet reads and writes to
    the disk didn't show in the Performance plugin at all. It's
    possible that things like Paging operations aren't counted,
    Some software paths don't seem to be hooked. So YMMV.
    If you got a "Delayed Write" error, you might suspect something.
    If the I/O rate had slipped into PIO mode, that might be
    a sign as well. If you run HDTune and the graph is a flat line
    at around 4MB/sec to 8MB/sec (when it should be 125MB/sec and
    a curve), then you'd suspect PIO (and you got there, via CRC errors).

    I don't have a recipe, like a checklist or anything.

    Another note about SATA versus IDE. When you push the reset button
    on the computer, the IDE disk should always be reset. There are
    plenty of wires on the cable, so on the IDE ribbon, they had
    a way to signal the reset condition. On SATA, I've actually had
    a SATA drive stop communicating, and pressing the reset button
    didn't bring it back. This is a violation of a basic hardware
    design principle (in hardware design reviews at work, this is
    one of the first items the reviewers ask about - does your reset
    work).

    I had to turn off computer power, to get the SATA disk to
    re-initialize. So if you ever find yourself in a situation
    where the SATA drive "stops talking", the reset button might
    not help. But power cycling fixed it.
    You can get SATA interface burners. I'm pretty slow at buying new
    hardware, and I have a grand total of one SATA burner now. All the
    rest I have are IDE. IDE is perfectly good, and I have no complaints.
    I wasn't paying attention at first. I just started a burn like usual.
    And then noticed Nero was claiming completion would be "some time
    in the next century", and that's when I glanced at the drive LED and
    noticed the strange pattern on the LED. Flipping open Device Manager,
    I noticed the "Enhanced" USB entry was missing (USB2, 30MB/sec),
    so then I had a possible answer. Benchmarking with one of the Nero
    tools (InfoTool?) can show whether the transfer rate is "normal" or not,
    like doing a read test on an existing burned disc.

    The very fastest optical devices, like a Blu Ray burner running
    at top speed (with non-existent top speed media), can approach 30MB/sec,
    so even USB2 is getting close to being a limiting factor. But
    I won't be burning Blu Ray any time soon, and in any case,
    the quality of media I can buy at the store here, the chances
    of finding a "top speed" kind of media are pretty slim. All I
    get here for blanks, is junk. So the chances of me owning a USB
    optical burner that runs flat out at 30MB/sec are pretty slim.
    I watched a tech working on the university mainframe, looking for a memory
    problem, and it wasn't pretty. Going from cabinet to cabinet, flipping
    doors open, probing stuff. The hardware in there looked like Spaghettios.
    I think that machine may have had core memory.

    Practically any DIMM I have in the house, would have a higher capacity
    than all those cabinets holding cores. Think how easy it is, snapping
    in a new DIMM, versus all those cabinets :) On the plus side, if the power
    went off, core memory saves state, so in that respect it is better than DRAM
    in personal computers.

    http://en.wikipedia.org/wiki/Core_memory

    I don't think they ever relied on the "saving state" property though for
    that university mainframe. It's possible the machine was checkpointed on
    its disk drives, and could roll back to the last checkpoint.

    I have run into one other computing device, which relied on core memory,
    and you could unplug it and it could pick up where it left off. And that
    was before EEPROMs or Flash memory. Very convenient, but not very scalable
    to large quantities of memory. The computing device in question, was
    like a large scientific programmable calculator.

    Paul
     
    Paul, Jun 22, 2011
    #12
  13. Rhino

    Rhino Guest

    Thanks for clearing up what you meant about the Performance plugin. I
    thought you were talking about something I had to download. I didn't realize
    you meant a built-in Windows facility.

    I found the Performance option and set it up as close to what you described
    as I could but I'm getting a couple of issues.

    I couldn't set the scale to 20,000; I had to choose between 10,000 and
    100,000. I was going to ask how to set the scale to 20,000 but that is a
    moot point since the Disk Write Bytes/Sec is a straight horizontal line at
    the very top of the scale for _all_ values of scale from 10,000 on up!
    (Average is 1.3 million, minimum is 262,000, and maximum is 4 million.) Disk
    Read Bytes/Sec has a more normal graph but it's average is around 45,000
    with a minimum of 0 and a maximum of 663,598. These numbers are a _lot_
    higher than the ones you cited for your computer but I can't believe my
    computer would be that much faster than yours. Something doesn't make sense
    here....

    By the way, I tracked down HD Tune and ran it on my C: drive. I got a
    transfer rate minimum of 7.0 MB/sec; maximum of 96.1, average of 67.4.
    Access time was 16.6 ms. Burst rate is 146.8 MB/sec. CPU usage is 7.5%. I
    noticed that in the Health tab, the last benchmark given, C7, is Ultra DMA
    CRC Error Count. I got a current value of 200, a worst of 200, threshold of
    0, data of 0, and status of ok. 200 errors seems like a lot to me but
    apparently isn't for HD Tune. Apparently, UDMA Mode 6 (Ultra ATA/133) is
    both supported and active for the drive.

    I also ran HD Tune of my D: drive. I got a transfer rate minimum of 52.1
    MB/sec; maximum of 108.0, average of 84.5.4. Access time was 12.3 ms. Burst
    rate is 157.2 MB/sec. CPU usage is 8.0%. For Ultra DMA CRC Error, I got a
    current value of 200, a worst of 200, threshold of 0, data of 0, and status
    of ok. I was surprised that the performance on the D: was significantly
    better than the C: given that they are identical drives; I expected the
    numbers to be much closer.
    Okay, fair enough.
    The challenge is going to be remembering that when (and if) the time comes
    ;-) I'll probably remember that I once read something about a simple fix for
    SATA drives but I won't remember the details and I won't remember to find
    them....
    I'm not going to rush out and buy the latest and greatest of everything
    either ;-)
    I expect that hardware issues _did_ affect mainframes from time to time.
    After all, the term "bug" refers to actual insects that were found in some
    of the earliest mainframes! But I don't remember ever encountering them in
    my job. The programs we wrote would inevitably have errors and sometimes
    there would be issues in the operating system. I still remember the system
    dump I encountered the very first time I had to support a program on our
    system. I was brand new and soon had to call for help from our lead
    programmer. He looked it over for a while and finally called down to one of
    the system programmers and confirmed that they'd put some kind of patch on
    the night before; he persuaded the system programmer that it had messed up
    our system. The patch was backed out and everything started working
    correctly again. He'd seen a similar problem once before, 14 years
    previously, and that was all he needed to get to the bottom of the problem.
    But we never saw memory failures or drive crashes, although I expect they
    happened occasionally and were handled by the operators.
    Your wristwatch probably has more capacity than an old mainframe ;-)
    When I was in my first job, the old-timers told us about a piece of hardware
    they'd had in the 50s that was so big you could actually walk through it!
    They'd give people tours and let them walk INSIDE that component. I can't
    recall what the component was - a printer maybe or some form of storage
    device - but there was a maintenance tunnel through the darned thing that
    they'd let people walk through. Try to find any computer component made
    since the 60s that you can walk through....
     
    Rhino, Jun 22, 2011
    #13
  14. Rhino

    Paul Guest

    When I fire up the Performance plugin here, the default "Vertical Scale"
    is listed as 0 to 100. The scale needed, may vary depending on what
    counter you're using.

    The SMART stats, I still don't understand them. I take a display like this

    200 200 0 0

    to mean the CRC error count was actually zero. Not all of the
    statistics in SMART are raw counters. Some are processed numbers
    and not "events".

    UDMA6 Ultra133 is just a placeholder. You can see from your 146.8MB/sec
    burst rate, that 133 cannot support 146. So the actual rate is faster
    than the bogus labeling scheme. About the only thing consistent, is
    Intel SATA ports wear a bogus label of UDMA5 (a tradition), while
    other chipsets may bear a bogus label of UDMA6. But if you had SATA III
    ports, they could do over 300MB/sec, well above UDMA6.

    As a rough estimate, if your max was 96MB/sec (at the beginning of the disk),
    then without measuring it, I'd expect the end of the disk to be around 48MB/sec.
    About a 2:1 ratio. There is some room for variation. The disk could be
    "short-stroked" for example, and the heads might not approach as close
    to the hub of the spindle. The min value would then not have the 2:1
    relationship.

    When you see a spike downwards, that can be caused by a problem with the
    program (execution priority), but it can also be caused by spared-out
    sectors. To reach a spare sector, potentially takes head movement. Or,
    to read a bad sector, might require retries. That can lead to spiking.
    If you use HDTune when a disk is brand new, you might notice a difference
    in the amount and number of downward spikes, after a year of using
    the disk.

    I've also had the opposite happen. A pretty crappy disk chart. Then,
    I use the bad block scan option in HDTune, forcing some reads from
    one end of the disk to the other. For some reason, subsequent disk
    benchmark runs, weren't as spiky. That really shouldn't do anything,
    because sparing is supposed to happen on writes, not on reads. Doing
    a read scan shouldn't change things as far as I know.

    These are some of my results, for comparison. I bought a couple
    new ones of these, and they're more "spiky" than this. When I
    compare to older disks (like the Maxtor I revived yesterday),
    the old disks showed a nice, zoned curve, with very little spiking.
    That could be a controller issue, making some of the noise evident,
    or the actual number of spared out sectors is much larger
    on the newer disks (more garbage to ride over).

    http://img829.imageshack.us/img829/842/500gb3500418ascomposite.gif

    I've had some results that looked dreadful, and it was an issue
    with how the internal buses in the chipset were tuned. And whatever
    setting was involved, I couldn't find a utility to check it. Fortunately,
    only one motherboard does that, and the other ones I've got are OK.

    Paul
     
    Paul, Jun 22, 2011
    #14
  15. Rhino

    Rhino Guest

    I played with the Performance graph a little and it seems that you can make
    the range of values on the vertical axis anything you like but it doesn't
    actually change the line that's drawn, just the labelling of the vertical
    axis.

    I right-clicked on the graph, chose Properties, went to the Graph tab and
    changed the Vertical Scale so that Maximum was a million (instead of 100)
    and Minimum stayed 0, applied, then cleared the graph and let it run for a
    bit. The graph was completely unchanged in terms of the height of the spikes
    and the low values were still at 0. Only the labels on the vertical axis
    were different.

    If I want the height of the spikes to be different, I need to change the
    scale of the _counter_ by selecting a specific counter, right-clicking,
    choosing Properties, and then choosing a different value for scale. When I
    did that and lowered the scale value from 10000000 to 1, the height of the
    spikes was suddenly much lower. The numbers in the Last, Average, Minimum,
    Maximum, and Duration boxes still had the same magnitude as they had before
    I touched the scales of the individual counters.

    Well, I'm not going to flog this to death. As far as I can tell, my hard
    drives are working just fine so I'm going to follow the First Rule of Tech
    Support: "If it works, don't fix it."

    I appreciate all the help and information, Paul. I hope I run into you or
    someone like you when and if I have a real problem somewhere down the road!
     
    Rhino, Jun 22, 2011
    #15
  16. Sounds like the old USAF Air Defense Command's SAGE system
    (Semi-Automatic Ground Environment).

    It was all tubes, with aisles between racks so the maintenance crews
    could do mass retubes. Some of them had big enough cross-aisles that you
    could drive a pickup thru.

    They were still in use up thru 1972 or so.


    --
    "Shit this is it, all the pieces do fit.
    We're like that crazy old man jumping
    out of the alleyway with a baseball bat,
    saying, "Remember me motherfucker?"
    Jim “Dandy” Mangrum
     
    Nobody > (Revisited), Jun 23, 2011
    #16
  17. Rhino

    Rhino Guest

    You haven't said what SAGE actually did but I doubt that was what the device
    our oldtimers were talking about; I was working for an insurance company at
    the time. The device they told me about might have been a printer or a
    storage device of some kind but nothing in the way of a defensive or
    offensive weapon system ;-)

    But SAGE may have been made by the same people who made the device I was
    told about and utilized the same style of maintenance access for all I
    know....
     
    Rhino, Jun 24, 2011
    #17
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.