M4A88TD-V EVO/USB3 -- AHCI problem, and 32-bit Win7 SATA driverswon't update

Discussion in 'Asus' started by Percival P. Cassidy, Jun 6, 2010.

  1. I installed Win7Pro on this machine with the SATA Controller in IDE mode
    and have been trying to get it going in AHCI mode: I've tried the
    official Microsoft method -- change msahci Start to 0, reboot and change
    BIOS setting from IDE to AHCI -- but it does not work. I get the colored
    "blobs," but then the machine reboots almost immediately and just keeps
    repeating that cycle until I change the BIOS setting again.

    I wondered whether updating the drivers would help, but I can't get them
    to update. The drivers on the CD that came with the mobo are later than
    ones the Windows installer installed, and I have downloaded later ones
    still from Asus, but Device Manager insists that I have the latest ones.

    Any suggestions?

    Perce
     
    Percival P. Cassidy, Jun 6, 2010
    #1
    1. Advertisements

  2. Percival P. Cassidy

    andy Guest

    Set SATA1-4 to AHCI.
    Set SATA5-6 to IDE.
    Connect disk to SATA5.
    Boot to Windows.
    Install AHCI driver.
    Connect disk to SATA1.
    Boot to Windows.
     
    andy, Jun 6, 2010
    #2
    1. Advertisements

  3. Worked like a charm. Thanks.

    However, I'm still wondering why it won't update the drivers.

    Perce
     
    Percival P. Cassidy, Jun 6, 2010
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.