Mail.app and MS Exchange server 2010 = memory leak?

Discussion in 'Apple' started by kaushik.ghose, Mar 25, 2012.

  1. Hi,

    I recently migrated over to Mail.app from Thunderbrid. Everything works very smoothly. I have gmail through IMAP and some other IMAP accounts and those owrk fine.

    I have an email account running on MS Exchange 2010 and that server has been giving me a strange problem.

    When I run Mail.app with that account active Mail.app's memory usage rise steadily over time till its taking up 1.3 GB actual and about the same virtual memory.

    I don't have this problem when I deactivate the account.

    Has anybody else had this problem?

    What is the solution?

    Best
     
    kaushik.ghose, Mar 25, 2012
    #1
    1. Advertisements

  2. My guess is something is being kept in memory when you authenticate with
    the Exchange server. You can adjust the frequency you connect and get
    mail from servers (for all mailboxes rather than just the Exchange
    server) and that may help. But really, how much of a problem is this?
    I gave up worrying about a badly coded app's memory usage back in the
    1980s.

    If you're really tweaked by this, submit a bug report to Apple. If
    you're really really tweaked about it, continue to use Thunderbird.
     
    Michael Vilain, Mar 25, 2012
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.