Mail.app: Messages follow rules, but still present (but grey) in inbox?

Discussion in 'Apple' started by Wendell III, Jul 10, 2005.

  1. Wendell III

    Wendell III Guest

    Hey all,

    Apologies to those of you getting tired of my endless questions. ;-) It
    seems that my machine is behaving erratically in all ways lately... Ah,
    so it is.

    So what's happening is basically this:

    Previously, when I would get a mail which had a rule established (say,
    to move certain messages to a "mailing lists" folder I had created), it
    would move there and leave no trace of itself in my inbox. Now what
    happen is that it does in fact move there, but it leaves behind a gray
    "shadow" of itself in the inbox, which usually goes away after a
    restart of the app.

    Any ideas? This is driving me crazy, because I've got tons of junk now
    cluttering my inbox.

    Thanks for any help!
    -Wendell
     
    Wendell III, Jul 10, 2005
    #1
    1. Advertisements

  2. Do these messages remain until you restart the application, or would
    they eventually disappear anyway? I've had a similar thing occur
    sometimes when cleaning out my junk folder-- deleted messages stay in
    the list, grayed out, after I've clicked the "delete" button. But it's
    just a delay, they eventually clear out if I leave them alone.
     
    Tom Harrington, Jul 11, 2005
    #2
    1. Advertisements

  3. Wendell III

    Wendell III Guest

    Yes, I don't know why I didn't include these obvious details. :)

    Mac OS X 10.3.9 (PowerBook G4 1.33GHz/768MB RAM)

    I've tried turning off my junk mail folder + turning it back on,
    erasing my rules and re-creating them. Nothing works except for
    quitting mail.app and re-loading it.

    -Wendell
     
    Wendell III, Jul 11, 2005
    #3
  4. Wendell III

    Wendell III Guest

    I can't rebuild the mailbox. It is also greyed out (yes, I selected the
    actual mailbox, not the generic "In" box with all of my boxes combined).
     
    Wendell III, Jul 12, 2005
    #4
  5. Wendell III

    Wendell III Guest

    Actually, is there a "rebuilt upon startup" command-key option as there
    was in Entourage?
     
    Wendell III, Jul 13, 2005
    #5
  6. Wendell III

    Wendell III Guest

    Done, but it's an IMAP box so the messages automatically re-propagate
    into the mailbox. Anyway, "rebuild" finally became available, so I did
    it -- and it just downloaded all of the messages again.

    So I'm still having the problem of these "ghost" messages in the
    inbox...

    Any other ideas, guys? This is really driving me bonkers.
     
    Wendell III, Jul 16, 2005
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.