Missing NTLDR, etc on Win XP Pro,Tried everything, HELP!

Discussion in 'Dell' started by James, Jan 12, 2005.

  1. James

    James Guest

    The machine is a Dell Dimension 8200. Windows XP Pro, Service Pack 1, NTFS
    Hard Drive.

    Here is the story, Folks.

    1. I installed several Microsoft security patches from Windows Update.

    2. Rebooted.

    3. Upon reboot, I was greeted with the error "Ntoskrnl.exe" Missing or
    damaged, replace file. Windows would not boot.

    4. Inserted Windows XP Install CD, used recovery console, tried to do a
    bootcfg /rebuild. Had to do a chkdsk first, which gave me a message saying
    that there were unfixable errors. I was unable to do the bootcfg / rebuild
    because of the errors.

    5. Removed CD, turned pc off, tried another reboot.

    6. Now have the error message "NTLDR is missing".


    At this point, I have tried EVERYTHING that I can think of. I have copied
    both NTLDR and NTDETECT from the Windows XP Install CD using the recovery
    console. I have also done a FIXMBR and FIXBOOT from the recovery console.

    Regardless of what I try, I still end up with the same NTLDR error.

    I even removed the actual hard drive from the PC and installed it in another
    Windows XP PC. I was hoping to be able to at least copy the files off of the
    drive, but I get the message "F:\ not accessible. The file or directory is
    corrupted and unreadable".


    Any ideas guys? This pc has a lot of critical information on it that I need
    access to ASAP. Please email me directly at if possible.

    Thank you,
    James
     
    James, Jan 12, 2005
    #1
    1. Advertisements

  2. James

    NuTCrAcKeR Guest

    I think that your IDE controller driver was updated by the patch, and that
    is your problem. Try booting with the Last Known Good profile.

    If that fails, boot from the recovery console, and troll the SP uninstall
    folders for the .sys file that was overwritten. Then, copy that file back to
    windows\system32\drivers and try to boot again.

    - NuiTs
     
    NuTCrAcKeR, Jan 12, 2005
    #2
    1. Advertisements

  3. James

    NuTCrAcKeR Guest

    Oh .. NTLDR missing is something else entirely
     
    NuTCrAcKeR, Jan 12, 2005
    #3
  4. James

    NuTCrAcKeR Guest

    You have lost your bootsector

     
    NuTCrAcKeR, Jan 12, 2005
    #4
  5. James

    James Guest

    Hi,
    Thanks for the suggestion.
    What do your recommend as the best way to fix the bootsector?

    Thanks,
    James
     
    James, Jan 12, 2005
    #5
  6. James

    NuTCrAcKeR Guest

    NuTCrAcKeR, Jan 12, 2005
    #6
  7. Hi!

    Chances are very good that your drive's write cache was enabled. (Why this
    is done by default is beyond me, because it usually leads to this exact kind
    of disaster...)

    The system shut down or rebooted too quickly for the data in the volatile
    write cache to be commited to disk. This has left the file system on the
    disk in an incomplete state, with corrupted files and all that.

    I think the best you can hope for now is to get the volume to be readable.
    CHKDSK <drive letter> /F on another computer might get you at least that
    much. Save what you want from the drive.

    Format, reinstall, and turn off the write caching at the earliest
    opportunity you get. It's in Device Manager > <hard disk name> > Disk
    Properties tab IIRC. Then you won't have this problem again.

    William
     
    William R. Walsh, Jan 12, 2005
    #7
  8. James

    NuTCrAcKeR Guest

    every disk I have ever seen (that supports it) has write caching turned off
    by default.

    The the OP's first post, and you will see the error in your thinking.

    - NuTs
     
    NuTCrAcKeR, Jan 13, 2005
    #8
  9. Hi!
    Do a fresh install of Win2000 or XP on a "standard" IDE controller and take
    a look at the hard disk in Device Manager. Some chipsets/controllers disable
    the write caching option and leave you no choice in the matter. Some boards
    based on nVidia chipsets seem to do this once the right INF files are loaded
    for chipset support. For certain, most Intel chipsets/onboard IDE do allow
    the setting to be enabled...and it will be enabled right out of the box for
    at least these two operating systems.

    In the "Gold" (RTM) release and at least one of the Service Packs issued for
    Windows 2000, the write caching could *not* be disabled reliably or at all
    by unchecking that box if your disk controller supported it.
    I'm not sure what you want to me to do here. (Double check what you wrote.)
    I reread the post and studied it again though. Everything I see there is
    what I've seen almost any other time this has happened and I stand by what I
    said the first time.

    William
     
    William R. Walsh, Jan 13, 2005
    #9
  10. NutCracker,
    I looked at my 8400 and it has write cache on. The are two choices,
    Optimize for removal (no write cache), and Optimize for performance
    (write cache on). Both choices are grayed out. Where else can this be
    changed?
     
    Paul Schilter, Jan 13, 2005
    #10
  11. Hi!

    If the setting is greyed out, you may be unable to change it, and I don't
    know of any good way to determine if, in fact the write cache is actually
    on. I do believe that even when greyed out that Windows generally displays
    the actual setting. (I have, however, found that there are times when this
    is not the case.)

    Here's what my Dimension 8300 (P4 3.4GHz, 1GB RAM, Windows 2000 Pro SP4)
    presents for options on its write caching. I have the Intel Chipset INF
    files installed.
    http://greyghost.dyndns.org/write-cache-off.jpg (81KB)

    Oddly enough I cannot disable the write cache on my Zip drive, but I don't
    think it makes a difference there. No matter how I try the setting just pops
    right back on.

    Underneath the two "radio button" options is there a checkbox for "Enable
    write caching on the disk". Is it greyed out as well?

    William
     
    William R. Walsh, Jan 14, 2005
    #11
  12. Chuckles The Scary Clown, Jan 15, 2005
    #12
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.