Modem Problem - Accessing BIOS

Discussion in 'IBM' started by Tim R., Aug 27, 2003.

  1. Tim R.

    Tim R. Guest

    I have a Compaq DeskPro computer, not sure of the model # because I
    could find none anywhere inside or outside of the cabinet.

    Anyhow, I'm having a problem with the modem. The computer does not
    seem to recognise it's there. When I go to the Diagnostics thing on
    Modem Properties, I get a message saying OpenComm: Port already open.
    When I remove COM2, the port the modem uses, and reinstall it, the
    modem will work until I restart the computer. Then I get the OpenComm
    message. I did a ton of troubleshooting, looking for resource
    conflicts and such, and found nothing out of the ordinary. I was
    messing around with the registry and got to the part about the BIOS.
    Apparently, COM2 is not listed in the BIOS and that's most likely why
    the modem and the port are acting up. My attempts to access the BIOS
    have been unsuccessful; pushing any combination of keys at the red and
    white COMPAQ screen with the hourglass at the bottom left does nothing
    except majke the computer say "keyboard error', . I have Win 98 SE on
    this computer, and to my knowledge is the original OS.


    Please help!

    Thanks!
     
    Tim R., Aug 27, 2003
    #1
    1. Advertisements

  2. Tim R.

    Pen Guest

    Have you tried F10 or DEL immediately after turn on?
     
    Pen, Aug 27, 2003
    #2
    1. Advertisements

  3. Anyhow, I'm having a problem with the modem. The computer does not
    If internal modem is using com2 then com2 should be disabled in BIOS,
    otherwise you will have TWO com2 ports. If you still want to get into BIOS
    push F10 when cursor is at TOP RIGHT. Try removing modem from device manager
    and let windows find it at next restart. If not detected, it may have died,
    they are very cheap now.

    Mike.
     
    Michael Hawes, Aug 27, 2003
    #3
  4. Tim R.

    Tim R. Guest

    If internal modem is using com2 then com2 should be disabled in BIOS,
    There is no cursor, just a hourglass at the bottom left.

    BTW, I discovered the computer was a Compaq DeskPro 2000.
    I've done that, and Widows doesn't detect it. However, the modem seems
    to respond in DOS, and, as I mentioned earlier, after uninstalling and
    reinstalling COM2.
    I'm very cheap, also. The computer was given to me for free when a
    company upgraded to Windows XP. A friend then installed a new CD rom,
    sound card, FM tuner, S3 display adapter, and removed the now-useless
    networking card (all of the former I got for free, either pulled from
    another computer or from someone who gave it to the Goodwill), and
    wiped off all traces of the previous owner.

    I believe the modem is new, as it still retains its $69 price tag and
    looks to have been never used.


    As you can see, I'm trying not to invest more than $10 into this
    computer...
     
    Tim R., Aug 28, 2003
    #4
  5. Tim R.

    Pen Guest

    If it's really a 2000, of whatever model, then when the hourglass
    appears
    at the lower right push F10. Try varying times.
    You can also go to the HP/Compaq web site and download the service
    manual.
     
    Pen, Aug 28, 2003
    #5
  6. Tim R.

    Pen Guest

    My point was that there are a dozen different
    Deskpro 2000 models. Hopefully all use F10.
     
    Pen, Aug 28, 2003
    #6
  7. This is an IRQ problem. You probably have com1 and com2 on your
    motherboard and the modem wants to use com2 also. Try the following
    proceedure it works with Micron systems that I setup a few years back. Make
    sure you note changes between this setup and your Compaq.

    This error generally indicates an IRQ conflict between your modem and
    another device in your computer, typically one of the on-board
    communications ports. Follow these steps to isolate the source of the
    problem



    1. [Click] Start, then Settings, then Control Panel.

    2. [Double-Click] the System icon, then [Click] on the Device Manager tab.

    3. In Device Manager, [Click] on the + to the left of modems, [Double Click]
    on the entry for the modem and then [Click] the Resources tab.

    4. Make sure the modem is set to Basic Configuration 0001 (I/O range of
    02f8-02ff and IRQ of 03).

    5. If it is not, remove the check mark from Use Automatic Settings, then
    change the Basic Configuration to Basic Configuration 0001, then [Click] OK.

    6. Next, [Click] on the + to the left of Ports (COM and LPT). [Click] once
    on the 2nd COM port (either Communications Port COM 2 or COM 4) then [Click]
    the Remove button. Answer Yes to confirm device removal.

    7. Close the Device Manager screen, then [Click] Start, then Shut Down, then
    select the option to Restart the Computer and [Click] Yes.

    8. As the computer reboots, go into the bios setup.

    9. If you pressed the F2 key, press the right arrow key once to get to the
    advanced screen. If you do not see references to either COM or Serial ports
    on this screen, highlight Integrated peripherals then press Enter.
    COM/Serial Port A must be set to COM 1. COM/Serial Port B must be set to COM
    4. Use the arrow keys and the + key to highlight and change any setting that
    does not match. Once these settings have been verified, press [Esc] twice
    then [Enter] twice to save your changes and exit the BIOS setup utility.

    10. If you had to press F1 to Enter the BIOS setup utility, press the right
    arrow key once to get to the advanced screen, then use the arrow keys to
    highlight peripheral configuration and press Enter. Highlight Serial Port 2
    Address, then press Enter. Select COM 4 from the list of options, then press
    [Enter]. Press the [F10] key to save your changes and exit the BIOS setup
    utility.

    11. Let the computer reboot into Windows 9x. [Click] Start, then Settings,
    then Control Panel. [Double Click] the System icon, then [Click] on the
    Device Manager tab.

    12. In Device Manager, [Click] on the + to the left of Ports (COM and LPT).
    [Double-Click] on Communications Port, COM 4, then [Click] on the check mark
    next to Original Configuration, Current to remove that check. [Click] the OK
    button to return to Device Manager, where you will find a red X on
    Communications Port, COM 4, indicating that it is disabled. By disabling the
    second onboard communications port, you will make available resources
    necessary to properly configure your modem, preventing any possible
    conflicts between the modem and the onboard communications ports.

    13. Next, [Click] on the + to the left of modems, [Double Click] on the
    entry for the Supra 28.8i PnP (if you have a SupraExpress modem), or Supra
    288i SP (if you have a Supra 28.8 modem with telephony features), or Supra
    33.6I ASVD (if you have a Supra 33.6 modem with telephony features, then
    [Click] the Resources tab.

    14. Make sure the modem is set to Basic Configuration 0001 (I/O range of
    02f8-02ff and IRQ of 03).

    15. If it is not, remove the check mark from Use Automatic Settings, then
    change the Basic Configuration to Basic Configuration 0001, then [Click] OK.

    16. Close Device Manager, then [Double-Click] on the Modems icon in Control
    Panel. [Click] on the Diagnostics tab, [Click] on the icon for COM 2, then
    [Click] the More Info. button.

    17. This should now return a screen with port information and a series of AT
    commands and responses, indicating that your modem has been properly
    configured to use COM 2, IRQ 3, settings compatible with all communications
    programs.

    18. [Click] OK twice. Make sure all of your communications programs are
    reconfigured to look for the modem at COM 2 if you made any changes to the
    configuration of your modem

    Good luck



    in message news:...
     
    Allan V. Lazzareschi, Aug 29, 2003
    #7
  8. Tim R.

    NuT CrAcKeR Guest

    deskpro 2000 eh?

    f10 only works if you have the system partion (eisa utilities) installed.
    press f10 after you hear 2 beeps.

    Plus.. XP on a sub-200Mhz machine? good luck.

    There are some overdrive/updrades available for the socket 5 or socket 7
    motherboards... might get up to 500Mhz...

    NuTs (LC)
     
    NuT CrAcKeR, Aug 30, 2003
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.