motherboard USB 2.0 pin header not working correctly

Discussion in 'MSI' started by John Richards, Feb 6, 2008.

  1. I recently installed a USB 2.0 front bay hub and connected it to a USB 2.0
    pin header on the mother board (MSI KT3 Ultra2). When I plug a High-Speed
    USB 2.0 flash drive into one of the connectors on the front bay hub, a
    notice on the screen suggests that I connect the device to a High Speed USB
    2.0 Port and then offers a list of 6 available unused ports under the
    Enhanced Host Controller (USB 2.0) heading. When I look at Device Manager,
    it shows that the flash drive appears on a universal port. If I move the
    flash drive to one of the original USB connectors on the back of the PC, the
    flash drive appears on one of the 6 ports under the Enhanced Host
    Controller, yet when a USB 1.1 device is plugged into the same connector on
    the back, the device shows up on a universal port.

    While doing some research, I came across a FAQ
    http://www.everythingusb.com/usb2/faq.htm , which states; "The USB
    controller routes signals to the correct controller chip depending on how a
    device is recognized. Where a device is physically plugged in has no bearing
    on how it is routed. All ports on a USB 2.0 motherboard can host any USB
    devices at all as long as the system and devices are healthy." This
    statement seems to agree with what happens when a USB 1.1 or USB 2.0 device
    is plugged into the original rear connectors (they are "routed" to the
    appropriate "port").

    My problem, then, is that although the flash drive is correctly recognized
    as a USB 2.0 device, why isn't it just routed to one of the available USB
    2.0 ports (according to the notice on the screen) like it is when plugged
    into one of the rear connectors.

    Incidentally, the PC is running Windows XP SP2.

    Any ideas?

    John
     
    John Richards, Feb 6, 2008
    #1
    1. Advertisements

  2. John Richards stelde de volgende uitleg voor :
    This sounds like a USB driver issue.
    Have a look at your device manager and install the proper VIA USB
    driver.
    There should be a 'VIA USB Enhanced host-controller' in the device
    table.
    Also it might help to reinstall Windows XP and directly after this
    install the chipset drivers first, and than the other drivers.

    I have had this issue also with my MSI KT6 Delta FSIR board, and was
    solved with the written above.

    good luck,

    André
     
    André, PE1PQX, Feb 6, 2008
    #2
    1. Advertisements

  3. Already tried updating the driver and it (Windows) said that it could not
    find a better driver. I'm inclined to think that this driver is OK since
    USB 2.0 devices plugged into the rear connectors seem to be routed properly
    to the enhanced ports.
    May try that but was hoping for a simpler solution as well as an
    understanding of why this is happening.
    Thanks for the reply,

    John
     
    John Richards, Feb 6, 2008
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.