Mounted drive not shown in the Finder

Discussion in 'Apple' started by Lewis, Jan 29, 2013.

  1. Lewis

    Lewis Guest

    I mount my 8TB raid from my mini on both my iMac and my MacBookPro, as I
    have done for the better part of a year.

    The trouble is, the drive does not show up in the Finder. If I got to
    the top level of the computer, I see all the local drives and other
    mounted drives, but not the raid.

    Where it gets odd is that if I hit command-shift G and type in
    /Volumes/Zero I get a finder window for the drive and I can access all
    the files. I cannot drag the drive's icon to the sidebar. I can access
    the drive just fine via the shell, but I can't put the drive in the
    sidebar and I can't see it in the Top level of the computer, nor if I go
    to /Volumes/ in the finder.

    It only happens with this drive.
     
    Lewis, Jan 29, 2013
    #1
    1. Advertisements

  2. Salut Lewis

    that is how exactly?

    Sorry, i could not find any technical specs for "my 8TB raid" when
    searching the internet.

    How is the RAID connected to your Macs?

    Do your Macs run an operating system?
    Do you expect helpful answers without providing information?

    Cheers
    Andreas
     
    Andreas Rutishauser, Jan 29, 2013
    #2
    1. Advertisements

  3. Lewis

    Lewis Guest

     
    Lewis, Jan 29, 2013
    #3
  4. Lewis

    Molon Labe Guest

    Sometimes a cold restart works wonders.
     
    Molon Labe, Jan 29, 2013
    #4
  5. Try opening /Volumes in Finder then doing "Get Info" on the drive.
    Finder might think it's mounted by another user. Also unmount the drive
    and type (be very sure it's unmounted) 'sudo mv /Volumes/Zero* .Trash'.
    This will remove any junk file paths that applications may have created
    after the drive was ejected.

    If all else fails, try rebooting. Pre-10.6 systems used to get ghost
    mounts that behaved like this. 10.8 seems to be buggy and it could be
    doing it too.
     
    Kevin McMurtrie, Jan 29, 2013
    #5
  6. Lewis

    Bread Guest

    Did you check Finder Preferences? There are checkboxes under
    General for "show these items on the desktop" and one of them
    is "connected servers". There's also a similar checkbox under
    Sidebar for "show these items in the sidebar" and, again, there
    is "connected servers".

    Have you tried a Finder alternative such as Pathfinder?
     
    Bread, Jan 29, 2013
    #6
  7. Lewis

    Lewis Guest

    Yes, as I said, other mount points show up just fine, and the issue was
    not that I couldn't see the drive on the Desktop, but that I could not
    see the drive *at all* in the finder unless I navigated directly to it.
    It was, effectively, invisible.

    I did fix it.

    logged in to the server and typed

    sudo chflags nohidden /Volumes/Zero

    problem solved.

    The only question now is how that flag got changed in the first place.
     
    Lewis, Jan 30, 2013
    #7
  8. Lewis

    Lewis Guest

     
    Lewis, Jan 31, 2013
    #8
  9. Lewis

    MartinC Guest

    I just realized that you never (?) posted you OS-X version.

    In the (very unlikely) case that it is 10.5, is it possible that you
    recently added a comment to the volume icon by "get info"?

    10.5. suffered from a very odd Spotlight bug that did just this: making the
    volume invisible by frequently changing the "hidden" flag, and if I remember
    it right then the only workaround has been:
    - make it visible (once again) through the terminal
    - delete the comment by deleting the .ds file on the root folder
    - rebuild the entire Spotlight index for that volume
    - never add a comment to the icon again...

    Again, I don't think that this is the case here, but your decription sounds
    exactly like the bug reports back then.
     
    MartinC, Jan 31, 2013
    #9
  10. Lewis

    Lewis Guest

    No, and I did posted in a follow-up that all my machines are on 10.8.2
    It does. Deleting the .DS file can't hurt.
     
    Lewis, Feb 1, 2013
    #10
  11. Lewis

    Lewis Guest

     
    Lewis, Feb 1, 2013
    #11
  12. Lewis

    Lewis Guest

     
    Lewis, Feb 1, 2013
    #12
  13. Ah, multiple machines. The way Finder preferences is implemented is
    brain-dead and it can not work correctly with multiple user IDs. One
    machine will create metadata and .DS_Store files that another machine,
    with different user IDs, can not access. Simply looking at the volume
    in Finder will alter it.

    MacOS file sharing can hack around this but it sounds like you're
    directly attaching the drive to different computers. You must disable
    permissions for the drive. Get Info on the volume and check the box.
     
    Kevin McMurtrie, Feb 2, 2013
    #13
  14. Lewis

    Lewis Guest

     
    Lewis, Feb 3, 2013
    #14
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.