1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Mouse wheel doesnt work when mouse connected through ps2

Discussion in 'Laptops' started by Ant, Mar 7, 2005.

  1. Ant

    Ant Guest

    I'm using a port replicator with my Vaio FX804 laptop. I wanted to
    free up a usb port so I used a usb-ps2 adaptor to plug my Logitech
    Wheel Mouse into the ps2 socket on the port replicator.

    However when I do this the mouse wheel gets disabled.

    Does anyone know why?

    The mouse scroll feature of the touchpad works fine at all times.

    I'm running Windows XP SP1.

    I do not have the Logitech Mouseware software installed and was really
    hoping to avoid doing this. The default Windows drivers have always
    worked fine with my laptop/PCs in the past and I dont need the extra
    features of Mouseware nor want the risk of it interfering with the
    system, such as with the Vaio's touchpad.

    Looking at Device Manager, the logitech mouse is shown under "Mice and
    other-pointing devices" section as "Alps Pointing device". I tried
    playing with the Advanced Settings to no avail. Tried unticking "Fast
    Initialization" and the mouse went loopy and had a mind of its own.
    Also tried changing the "Wheel Detection" from "Assume wheel is
    present" to "Look for wheel". Still no luck. The General page confirms
    that the mouse is "plugged into ps/2 mouse port" and says "This device
    is working properly". Also, there's no resource conflicts.

    Thanks for any tips.

    Thanks, Ant
     
    Ant, Mar 7, 2005
    #1
    1. Advertisements

  2. Ant

    Quaoar Guest

    This applies to Intellipoint, but you might find the fix works for your
    mouse: http://support.microsoft.com/?scid=kb;en-us;327808

    Q
     
    Quaoar, Mar 7, 2005
    #2
    1. Advertisements

  3. Hi Ant,
    You may have to install the software that came with the mouse for
    it to work properly with the touchpad enabled while using the mouse on
    the port replicator. If you have one, you should try the mouse on the
    standard PS2 port on the laptop and isolate the port replicator as the
    problem area.
    After that, you should also check whether you need to disable the
    touchpad for the mouse to work properly in either instance. This is
    common on many laptops with or without the mouse software installed.
    Sometimes the touchpad interferes with the mouse instead of the other
    way around. The laptop should have come with software pre-installed to
    control the functions of the laptop where you can disable the touchpad.

    You shouldn't need to use both the touchpad and the mouse at the
    same time but if you don't want the hassle of disabling the touchpad
    for the mouse to work properly (if this does work) every time you want
    to use the mouse on the port replicator, you should install the mouse
    software and make sure that you update it with the latest version. Also
    refer to the manufacturer's website for known issues and any fixes
    available before installing it. It is unlikely that the software will
    cause your system any problems if installed correctly. If it does
    interfere with your system or touchpad, you always have the choice of
    removing it or reverting your system to a safe point before the
    installation.

    Hope this helps.
    Silicon Alley Computers
    www.siliconalleycomputers.com
     
    Silicon Alley Computers, Mar 7, 2005
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.