1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

My monitor went black in Linux/Debian (X) and text mode earlier today...

Discussion in 'Nvidia' started by ANTant, May 22, 2006.

  1. ANTant

    ANTant Guest

    About over an hour ago, I was watching a long video (FLV file; not fullscreen) for about 30 minutes in GMPlayer on
    my Linux/Debian box (Linux foobar 2.6.14-2-k7 #1 Wed Dec 28 19:14:46 UTC 2005 i686 GNU/Linux) while my
    gaming/Windows box was doing SpinRite stuff (so far no errors, but I will resume overnight since it has 8 hours to
    go). Then, all the sudden my monitor's picture went black. Monitor said the video signal was still there (not
    blinking). Audio from my cheap Sony speakers stopped too. I thought my computer crashed hard, but it wasn't since
    I could still ssh into my box from another computer. I even tried ctrl-alt-backsapce to get out of X, but it
    didn't work(?). I didn't see any text console (I set to boot to text mode so I have to type startx command). Also,
    ps didn't show X and KDE running anymore so either I killed it or it died by itself.

    My Windows XP Pro. SP2 (all updates) machine was still showing video and my desktop on the screen since it was
    hooked up to an old 4-ports (since the end of 2001) OmniCube KVM switch (VGA and PS/2 ports) with the Linux box. I
    looked, checked, and fiddled with the cables for KVM switch and connections to the Linux box. I rebooted the box
    via SSH (love text modes!), HDD light was stuck/hung forever (not doing anything like loading or stopping), no
    beeps, nothing on screen, etc. No go.

    I decided to shut down (via SSH) the machine and power off for a few minutes (shut off power supply unit too).
    Again, I looked around for any weirdness like moved my case, unplug, replug, etc. Then, I powered back on, heard a
    beep (normal one), saw the bootup on screen, hit a key to stop at GRUB loader before loading Debian, ... and la la
    it works again!

    Any ideas on what the heck happened or had this problem before? Dang it, I lost my 142 days of uptime. Still did
    not beat my 227 days from a few years ago! :( I hope this weirdness doesn't happen again.

    Thank you in advance. :)
    --
    "Be thine enemy an ant, see in him an elephant." --Turkish Proverb
    /\___/\
    / /\ /\ \ Phillip (Ant) @ http://antfarm.ma.cx (Personal Web Site)
    | |o o| | Ant's Quality Foraged Links (AQFL): http://aqfl.net
    \ _ / Please remove ANT if replying by e-mail.
    ( )
     
    ANTant, May 22, 2006
    #1
    1. Advertisements

  2. ANTant

    deimos Guest

    If you couldn't see the BIOS screen, then it absolutely has to be low
    level hardware failure. Having experienced a similar failure on an XP
    system, my theory is it's voltage related. Some component (whether on
    your video card or motherboard) may have "blown" (for whatever that
    means) and killed the display temporarily or corrupted the video BIOS to
    an extent (pullin' that last one outta' my crack...)

    I have had this happen with blown capacitors on a motherboard. It
    killed the video, caused hard drives to stall on spin up, and gave a
    beep code error for video, and required several reboots to come up. It
    recovered, but became unstable and unable to stay powered on for very
    long (progressively got worse). I at first mis-diagnosed it as hard
    drive failure and did everything but replacing the mobo (PSU, check the
    HD's, drivers, etc).

    I have also had video cards killed by brownouts and static electricity.
    In the case of a brownout, a temporary dip in voltage destroyed the
    card completely. The fan would turn, but nothing would display. I've
    since how important regular voltage can be to certain sensitive components.
     
    deimos, May 22, 2006
    #2
    1. Advertisements

  3. ANTant

    ANTant Guest

    About over an hour ago, I was watching a long video (FLV file; not fullscreen) for about 30 minutes in GMPlayer on
    Ack. that's not good. So far, I haven't seen worse yet since the incident
    so far.

    That's great. :( Last year, I had one of my computers do that to me when my Enlight UPS stopped working (I heard
    it spin down and my system power off) and a horrible odor (no smokes). My friend found out the brown areas on my
    old ASUS A7V333 motherboard. It killed my old Quantum 30(?) GB HDD's controller too. I hope this is not happening
    again. The problem was that PSU was on the borderline with amount of power (240 watts). See 4/24/2005 and 6/5/2005
    on http://alpha.zimage.com/~ant/antfarm/about/toys.html for the details.

    Weird thing is that I have these boxes connected to APC UPS' (one was old) and then got a new one to replace it
    due to old age (5 years and turning off by itself even if there were no power outages). I thought UPS' were
    supopsed to protect these things.

    I do hear beeps once in a while due to power hiccups. See my log:
    # cat /var/log/apcupsd.events
    Tue Oct 04 18:09:48 PDT 2005 apcupsd 3.10.18 (21 July 2005) debian startup succeeded
    Tue Oct 04 18:19:20 PDT 2005 apcupsd 3.10.18 (21 July 2005) debian startup succeeded
    Wed Oct 05 15:19:57 PDT 2005 Power failure.
    Wed Oct 05 15:20:00 PDT 2005 Power is back. UPS running on mains.
    Wed Oct 05 15:20:18 PDT 2005 Power failure.
    Wed Oct 05 15:20:24 PDT 2005 Running on UPS batteries. <-- I think I was testing this one.
    Wed Oct 05 15:20:24 PDT 2005 Mains returned. No longer on UPS batteries.
    Wed Oct 05 15:20:24 PDT 2005 Power is back. UPS running on mains.
    Mon Oct 17 00:54:46 PDT 2005 Power failure.
    Mon Oct 17 00:54:52 PDT 2005 Power is back. UPS running on mains.
    Mon Oct 17 03:36:30 PDT 2005 Power failure.
    Mon Oct 17 03:36:36 PDT 2005 Power is back. UPS running on mains.
    Mon Oct 17 11:48:24 PDT 2005 Power failure.
    Mon Oct 17 11:48:30 PDT 2005 Power is back. UPS running on mains.
    Thu Nov 03 22:55:42 PST 2005 Power failure.
    Thu Nov 03 22:55:48 PST 2005 Power is back. UPS running on mains.
    Sun Nov 27 13:45:11 PST 2005 Power failure.
    Sun Nov 27 13:45:17 PST 2005 Power is back. UPS running on mains.
    Mon Nov 28 06:25:27 PST 2005 apcupsd exiting, signal 15
    Mon Nov 28 06:25:28 PST 2005 apcupsd shutdown succeeded
    Mon Nov 28 06:35:16 PST 2005 apcupsd 3.10.18 (21 July 2005) debian startup succeeded
    Tue Nov 29 02:16:15 PST 2005 Power failure.
    Tue Nov 29 02:16:21 PST 2005 Power is back. UPS running on mains.
    Tue Nov 29 02:16:31 PST 2005 Power failure.
    Tue Nov 29 02:16:37 PST 2005 Power is back. UPS running on mains.
    Tue Nov 29 02:17:11 PST 2005 Power failure.
    Tue Nov 29 02:17:17 PST 2005 Power is back. UPS running on mains.
    Sun Dec 11 07:30:59 PST 2005 apcupsd exiting, signal 15
    Sun Dec 11 07:30:59 PST 2005 apcupsd shutdown succeeded
    Sun Dec 11 17:13:24 PST 2005 apcupsd 3.10.18 (21 July 2005) debian startup succeeded
    Sat Dec 17 13:49:27 PST 2005 Power failure.
    Sat Dec 17 13:49:33 PST 2005 Power is back. UPS running on mains.
    Sat Dec 17 13:49:43 PST 2005 Power failure.
    Sat Dec 17 13:49:49 PST 2005 Power is back. UPS running on mains.
    Sun Dec 18 16:31:07 PST 2005 apcupsd exiting, signal 15
    Sun Dec 18 16:31:07 PST 2005 apcupsd shutdown succeeded
    Mon Dec 19 20:42:13 PST 2005 apcupsd 3.10.18 (21 July 2005) debian startup succeeded
    Mon Dec 19 21:02:14 PST 2005 apcupsd exiting, signal 15
    Mon Dec 19 21:02:14 PST 2005 apcupsd shutdown succeeded
    Mon Dec 19 21:15:29 PST 2005 apcupsd 3.10.18 (21 July 2005) debian startup succeeded
    Mon Dec 19 21:18:13 PST 2005 apcupsd exiting, signal 15
    Mon Dec 19 21:18:13 PST 2005 apcupsd shutdown succeeded
    Mon Dec 19 13:25:01 PST 2005 apcupsd 3.10.18 (21 July 2005) debian startup succeeded
    Mon Dec 19 13:25:28 PST 2005 apcupsd exiting, signal 15
    Mon Dec 19 13:25:28 PST 2005 apcupsd shutdown succeeded
    Mon Dec 19 06:43:56 PST 2005 apcupsd 3.10.18 (21 July 2005) debian startup succeeded
    Mon Dec 19 06:44:22 PST 2005 apcupsd exiting, signal 15
    Mon Dec 19 06:44:22 PST 2005 apcupsd shutdown succeeded
    Mon Dec 19 22:49:27 PST 2005 apcupsd 3.10.18 (21 July 2005) debian startup succeeded
    Mon Dec 19 23:04:00 PST 2005 apcupsd exiting, signal 15
    Mon Dec 19 23:04:00 PST 2005 apcupsd shutdown succeeded
    Mon Dec 19 23:06:42 PST 2005 apcupsd 3.10.18 (21 July 2005) debian startup succeeded
    Mon Dec 19 23:08:05 PST 2005 apcupsd exiting, signal 15
    Mon Dec 19 23:08:05 PST 2005 apcupsd shutdown succeeded
    Mon Dec 19 23:09:05 PST 2005 apcupsd 3.10.18 (21 July 2005) debian startup succeeded
    Mon Dec 19 23:19:54 PST 2005 apcupsd exiting, signal 15
    Mon Dec 19 23:19:54 PST 2005 apcupsd shutdown succeeded
    Mon Dec 19 23:21:01 PST 2005 apcupsd 3.10.18 (21 July 2005) debian startup succeeded
    Mon Dec 19 23:25:02 PST 2005 apcupsd exiting, signal 15
    Mon Dec 19 23:25:02 PST 2005 apcupsd shutdown succeeded
    Mon Dec 19 23:59:38 PST 2005 apcupsd 3.10.18 (21 July 2005) debian startup succeeded
    Tue Dec 20 00:23:22 PST 2005 apcupsd exiting, signal 15
    Tue Dec 20 00:23:22 PST 2005 apcupsd shutdown succeeded
    Tue Dec 20 00:24:15 PST 2005 apcupsd 3.10.18 (21 July 2005) debian startup succeeded
    Tue Dec 20 15:52:34 PST 2005 apcupsd exiting, signal 15
    Tue Dec 20 15:52:34 PST 2005 apcupsd shutdown succeeded
    Tue Dec 20 15:53:40 PST 2005 apcupsd 3.10.18 (21 July 2005) debian startup succeeded
    Wed Dec 21 21:30:27 PST 2005 apcupsd exiting, signal 15
    Wed Dec 21 21:30:27 PST 2005 apcupsd shutdown succeeded
    Wed Dec 21 21:31:26 PST 2005 apcupsd 3.10.18 (21 July 2005) debian startup succeeded
    Tue Dec 27 16:20:49 PST 2005 apcupsd exiting, signal 15
    Tue Dec 27 16:20:49 PST 2005 apcupsd shutdown succeeded
    Tue Dec 27 16:20:53 PST 2005 apcupsd 3.10.18 (21 July 2005) debian startup succeeded
    Thu Dec 29 20:13:24 PST 2005 apcupsd exiting, signal 15
    Thu Dec 29 20:13:24 PST 2005 apcupsd shutdown succeeded
    Thu Dec 29 20:14:22 PST 2005 apcupsd 3.10.18 (21 July 2005) debian startup succeeded
    Mon Jan 02 08:15:41 PST 2006 Power failure.
    Mon Jan 02 08:15:47 PST 2006 Power is back. UPS running on mains.
    Mon Jan 02 08:45:00 PST 2006 Power failure.
    Mon Jan 02 08:45:06 PST 2006 Power is back. UPS running on mains.
    Mon Jan 02 08:45:31 PST 2006 Power failure.
    Mon Jan 02 08:45:37 PST 2006 Power is back. UPS running on mains.
    Tue Jan 03 21:31:27 PST 2006 Power failure.
    Tue Jan 03 21:31:33 PST 2006 Power is back. UPS running on mains.
    Mon Jan 09 15:10:48 PST 2006 apcupsd exiting, signal 15
    Mon Jan 09 15:10:48 PST 2006 apcupsd shutdown succeeded
    Mon Jan 09 15:13:52 PST 2006 apcupsd 3.12.1 (06 January 2006) debian startup succeeded
    Wed Jan 11 07:33:05 PST 2006 Power failure.
    Wed Jan 11 07:33:08 PST 2006 Power is back. UPS running on mains.
    Fri Jan 27 07:09:01 PST 2006 Power failure.
    Fri Jan 27 07:09:04 PST 2006 Power is back. UPS running on mains.
    Sun Feb 12 22:54:03 PST 2006 Power failure.
    Sun Feb 12 22:54:06 PST 2006 Power is back. UPS running on mains.
    Mon Feb 13 15:11:54 PST 2006 apcupsd exiting, signal 15
    Mon Feb 13 15:11:54 PST 2006 apcupsd shutdown succeeded
    Mon Feb 13 15:12:09 PST 2006 apcupsd 3.12.1 (06 January 2006) debian startup succeeded
    Thu Feb 16 00:08:22 PST 2006 Power failure.
    Thu Feb 16 00:08:25 PST 2006 Power is back. UPS running on mains.
    Thu May 11 22:33:50 PDT 2006 Power failure.
    Thu May 11 22:33:53 PDT 2006 Power is back. UPS running on mains.
    Tue May 16 15:12:27 PDT 2006 Power failure.
    Tue May 16 15:12:30 PDT 2006 Power is back. UPS running on mains.
    Tue May 16 15:12:56 PDT 2006 Power failure.
    Tue May 16 15:12:59 PDT 2006 Power is back. UPS running on mains.
    Wed May 17 15:01:42 PDT 2006 apcupsd exiting, signal 15
    Wed May 17 15:01:43 PDT 2006 apcupsd shutdown succeeded
    Wed May 17 15:04:08 PDT 2006 apcupsd 3.12.3 (26 April 2006) debian startup succeeded
    Sun May 21 15:20:52 PDT 2006 apcupsd exiting, signal 15
    Sun May 21 15:20:52 PDT 2006 apcupsd shutdown succeeded

    [then had to shut down my system via SSH due to weird problems with my blank screen computer]
    --
    "Be thine enemy an ant, see in him an elephant." --Turkish Proverb
    /\___/\
    / /\ /\ \ Phillip (Ant) @ http://antfarm.ma.cx (Personal Web Site)
    | |o o| | Ant's Quality Foraged Links (AQFL): http://aqfl.net
    \ _ / Please remove ANT if replying by e-mail.
    ( )
     
    ANTant, May 22, 2006
    #3
  4. ANTant

    Whoever Guest

    I suggest you read this:
    http://www.grcsucks.com/spinrite.htm

    and then think about how productive those hours spent doing "Spinrite
    stuff" are.
     
    Whoever, May 22, 2006
    #4
  5. ANTant

    deimos Guest

    I can't say if that's normal (I don't run any power utilities on my
    Ubuntu box), but a simple Windows utility like SpeedFan can show you
    realtime voltages. You should probably find an equivalent and see if
    you're getting clean voltage on the rails, 1.75 to the core or whatever,
    and your negative rails aren't going whack (like 4v to 12v fluctuations,
    usually a dead PSU). Either way, I always start at the power cord and
    work my way up.
     
    deimos, May 22, 2006
    #5
  6. ANTant

    ANTant Guest

    Interesting. Then, what do you suggest using? I already tried chkdsk.exe, Norton Disk Doctor, and SeaTools
    Desktop so far. Nothing unusual. I had to stop SpinRite since it said it would be about 8 hours, on my 95 GB
    partition/drive so I decided to save it for tonight.
    --
    "Be thine enemy an ant, see in him an elephant." --Turkish Proverb
    /\___/\
    / /\ /\ \ Phillip (Ant) @ http://antfarm.ma.cx (Personal Web Site)
    | |o o| | Ant's Quality Foraged Links (AQFL): http://aqfl.net
    \ _ / Please remove ANT if replying by e-mail.
    ( )
     
    ANTant, May 22, 2006
    #6
  7. ANTant

    Whoever Guest

    Maybe I'm being dense tonight, but I don't see the connection between your
    monitor going black on your Linux machine and running SPinRite on your
    Windows machine?

    But anyway, modern disks have the capability to self diagnose and
    fix problems. If you look at the S.M.A.R.T. data, you will see quite a lot
    of information about the disk's performance. If you start seeing a lot of
    CRC errors, or if you start seeing increasing numbers of re-mapped
    sectors, then you need to buy a new disk. Really, today there is little
    need today for surface analysis tools since the disks do it automatically.

    I guess the question is: what problem are you trying to fix?

    As for your Linux machine -- well, I assume you are using the
    closed-source nVidia driver? Perhaps it caused the video problem?
     
    Whoever, May 22, 2006
    #7
  8. ANTant

    ANTant Guest

    About over an hour ago, I was watching a long video (FLV file; not fullscreen) for about 30 minutes in GMPlayer on
    Oh, that was a side story. I was doing something else. But I doubt that can cause the probelms I had on my Linux
    box.

    Well, I wished I could read the SMART info, but I think this Seagate Barracuda 7200.7 Plus ST3120026A 120 GB (8 MB
    cache; 7200 RPM) HDD, that SpinRite was working on, has limitations. It is connected via VIA SATA Controller
    (onboard Promise controller just won't boot up Windows XP 100%). So, no SMART information, temperature readings,
    etc. Even SpinRite said that too. Just remember, I have three internal HDDs and two CD/DVD drives. Anyways, this
    is another subject and off-topic.

    It was only a side story and off-topic. So ignore it. :)

    Maybe, but I never had that problem before with all NVIDIA driver releases. It still doesn't explain why I
    couldn't see anything in text mode and after reboots until I powered down the machine for a few minutes.
    --
    "Be thine enemy an ant, see in him an elephant." --Turkish Proverb
    /\___/\
    / /\ /\ \ Phillip (Ant) @ http://antfarm.ma.cx (Personal Web Site)
    | |o o| | Ant's Quality Foraged Links (AQFL): http://aqfl.net
    \ _ / Please remove ANT if replying by e-mail.
    ( )
     
    ANTant, May 22, 2006
    #8
  9. A 22-05-2006 00:29, escreveu:
    This happened to me few times (2 or 3 IIRC) on my Intel Pentium II 334Mhz.

    When this happened, I was able to ssh my computer (using my deskop
    Pentium). But I was not able to switch to vc1 nor to shutdown/restart X.

    I think that when this happens it's a X-Windows System crash. All the
    applications you started inside of X GUI are terminated because the
    father process (X) dies. What I don't understand is why isn't it
    possible to switch to vc1 (or to any other vc) using
    <CTRL>+<ALT>+<F1-F6> or <ALT>+<F1-F6> when this happens. Maybe it's
    because the X process locks the input devices and they are not unlocked
    when X crashes.

    My video card is a `S3 Inc. ViRGE/DX or /GX' (lspci).

    --
    Nuno J. Silva (aka NJSG)
    Lisbon, Portugal
    Homepage: <http://njsg.no.sapo.pt/>
    Registered Linux User #402207 - http://counter.li.org

    Using Mozilla Thunderbird 1.0.7
    Gentoo Linux -- Linux 2.6.15-gentoo-r1 i686 Mobile Pentium II
    Intel Pentium II (80686) Deschutes - 334Mhz -- 256 Mbs SDRAM
    Intel Mobile Pentium II (80686) - 300 Mhz -- 64 Mbs SDRAM
    Intel Pentium (80586) - 166 Mhz -- 32 Mbs RAM

    -=-=-
    ``Somewhere on this globe, every ten seconds, there is a woman giving
    birth to a child. She must be found and stopped.''
    -- Sam Levenson

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.2.4 (GNU/Linux)
    Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

    iD8DBQFEguSK8uhttueYbMMRAmWfAKCHt/Q9Jhjbc94xxIW/S94NvuxuGQCfQ7DL
    kBMuhjBIg1Kz/p0w47lntEI=
    =89T/
    -----END PGP SIGNATURE-----
     
    Nuno J. Silva (aka NJSG), Jun 4, 2006
    #9
  10. ANTant

    ANTant Guest

    Interesting. So far, it only happened once.
    --
    "... Our world is not an ant farm!" --Duncan MacLeod (Highlander Season 3 Finale Part II)
    /\___/\
    / /\ /\ \ Phillip (Ant) @ http://antfarm.ma.cx (Personal Web Site)
    | |o o| | Ant's Quality Foraged Links (AQFL): http://aqfl.net
    \ _ / Please remove ANT if replying by e-mail.
    ( )
     
    ANTant, Jun 15, 2006
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.