My new A8N-SLI Premium: IDE detection problems, DMA failure. Hardware fault?

Discussion in 'Asus' started by Chris Metzler, Jan 18, 2006.

  1. Hi. I'm posting this to a forum at my vendor's website, but I've obtained
    a lot of very good help here so figured I'd try here too. I just got my
    parts this past week, assembled the machine this weekend after months of
    anticipation, and now I'm sitting here hoping like hell I'm not going to
    have to return my mobo.

    ASUS A8N-SLI Premium, Athlon 64 3800 (Venice), 2x1GB Corsair 3200
    (DDR400).

    Initially, this machine was set up with a DVD-ROM as Master on the 1st IDE
    channel, a WD1200JB 120GB as master on the 2nd IDE channel, and a WD2500KS
    250GB on the first SATA port. Upon attempting to boot this configuration,
    it took a very long time to recognize IDE devices; when it finished, the
    WD1200JB 120GB as the 2nd Master was not detected.

    I knew this drive was OK because I had just taken it out of a machine in
    which it was working fine. So, I changed its jumper from "master" to
    "slave", moved it onto the first IDE channel as slave behind the DVD-ROM
    master, and rebooted. It was recognized and the BIOS initialization/IDE
    detection stuff took place quickly. However, it was incorrectly
    identified as being addressed by CHS, when in fact it should have been LBA.

    So, I got another WD1200JB 120GB drive (I have a bunch), jumpered it as
    "master", and put it in as master on the 2nd IDE channel. Result: once
    again, it took forever to recognize IDE devices; when it finished doing
    so, the drive in that position was not detected.

    On the chance that the problem with the second IDE channel was a cable
    issue, I swapped in another 80-pin cable for that IDE channel. No change:
    IDE detection took forever and the master on the second IDE channel was
    not detected (but both DVD-ROM master and HD slave on the first channel
    were detected OK). I swapped cables yet again, this time using the cable
    that had just come with the motherboard. Still no change.

    Next, I rebooted the machine several times, trying to see if it would find
    the drive one of those times. Finally, after three attempts, each of
    which included a very long wait to detect IDE devices, it did detect the
    drive sitting on the master on the second IDE channel. Problems persist,
    however: all IDE disk accesses -- not just the IDE device detection at
    boot-time -- take forever, for both IDE channels. For instance, during OS
    install, I put a bootloader in the MBR of the HD sitting as slave on the
    first IDE channel; on boot, it takes over a half-minute to load that code
    and run it. Once the OS is up, I have no DMA on any drives, and can't
    turn DMA on even though it's explicitly enabled in the BIOS. (and here
    again, not being able to get DMA, despite the BIOS telling me that DMA is
    enabled and OS-level diagnostics querying the drive and reporting that the
    drive can do UDMA5 would suggest a cable issue; but since I'm experiencing
    problems with both channels, that'd be *four* bad cables, including the
    new one that came with the mobo? Very doubtful.)

    Any advice on this would be greatly appreciated. I put most of a day into
    assembling this box -- I'm always slow doing this, out of caution -- and
    don't wanna have to disassemble, ship, wait, and reassemble if I don't
    have to.

    Thanks.
     
    Chris Metzler, Jan 18, 2006
    #1
    1. Advertisements

  2. Chris Metzler

    RonK Guest

    Try setting your hd and cd to Cable Select.
    WD jumper setting for Master by itself on a cable is - No Jumper.
     
    RonK, Jan 18, 2006
    #2
    1. Advertisements

  3. Chris Metzler

    Natéag Guest

    Seems that the jumpers on the back of the HD are not set
    correctly. One Master, One slaveé (Or both
    Cable Sekect,
     
    Natéag, Jan 18, 2006
    #3
  4. Chris Metzler

    CoCo Guest

    RonK skrev:
    hi

    wd hd's must be jumpered to "single" state, not master if it is alone. (as ronk said)
    some model's have a special jumper possition for this! (not ok jumperless)

    coco
     
    CoCo, Jan 18, 2006
    #4
  5. Chris Metzler

    John Lewis Guest

    Simplify. Take ALL drives off. Jumper one of your WD as master-only
    ( remove all links!). Connect to IDE Controller Port 1. Boot and
    check recognition in BIOS. If timely and OK, work on from there,
    paying very careful attention to the correct jumper positions, as per
    the WD jumper information . When confused, do NOT use cable select.
    Positively allocate the drives with the jumpers. BTW, the DVD-Rom
    should never be master on Controller 1. Best as master on controller
    port 2 with no hard disk on that port. You are using an 80-wire cable
    on the IDE drives and plugging the blue connector into the MB ??

    John Lewis
     
    John Lewis, Jan 18, 2006
    #5
  6. Bingo -- this was it. The drive alone on the second IDE channel shouldn't
    have been jumpered master -- as is clearly stated in the drive
    documentation, which I last looked at three years ago.

    What's embarassing is that I apparently *did* know this way back then.
    If you had asked me yesterday, I would have sworn that a drive on its
    own on the channel should be jumpered "master." But after reading these
    posts, I went and looked at the drive docs, which say "no jumper at all."
    I then went and looked at an A7V333-based machine I built three years
    ago, with one of these drives by itself on an IDE channel; and sure
    enough, I'd put no jumper at all there. So apparently I knew this once
    upon a time, but forgot it since. I'm getting old, dammit.

    Anyway, thanks much. Disk accesses are snappy and DMA is available.

    -c
     
    Chris Metzler, Jan 19, 2006
    #6
  7. Hi, thanks for your reply. The jumper settings on the two devices
    on the first IDE channel (DVD-ROM and HD) were OK; it was the one
    which was by itself on the second IDE channel that was problematic
    (should have been no jumper at all rather than master).

    Thanks!

    -c
     
    Chris Metzler, Jan 19, 2006
    #7
  8. Hi. Thanks for your reply. As noted in another post, the problem
    ended up being between keyboard and chair -- the drive that was by
    itself on the second channel should have been jumperless, rather than
    jumpered "master".

    I'm curious about your comment about it not being good for the DVD-ROM
    to be master on the first channel. Why is that a bad idea? I know
    it throttles down the speed of any HD on the same channel; is there
    some other effect if it's on the first channel? (I can't get away with
    giving it its own channel -- with no slave -- right now, as I have
    drives I need to attach to this new system and so I need that slave
    port)

    -c
     
    Chris Metzler, Jan 19, 2006
    #8
  9. Chris Metzler

    John Lewis Guest

    Why not put it as slave on the secondary port ? Its a pretty slow
    device and that is where it do least damage in pulling the system
    down speed down. Get a longer cable if there is a distance problem.
    Always put your system drive as master on the primary port.

    John Lewis

    John Lewis
     
    John Lewis, Jan 19, 2006
    #9
  10. Chris Metzler

    RonK Guest

    You're Welcome Chris [email protected]

     
    RonK, Jan 19, 2006
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.