MyLogo won't accept GIF or compressed BMP. Messes up colours in JPG. Ideas?

Discussion in 'Asus' started by Noozer, Jan 8, 2004.

  1. Noozer

    Noozer Guest

    Hey all!

    Trying to put a new boot logo for the wifes PC. It's using a P4C800 Deluxe
    mainboard.

    Asus includes a program called "MyLogo" to import a new image into the BIOS,
    but it doesn't seem to like any GIF I choose. It won't accept a compressed
    BMP. JPG seems to be accepted, but it messes up the colour palette pretty
    badly. What I'm left with is uncompressed BMP files, which are pretty big
    (300K+) and won't fit into the BIOS.

    Does anyone know any reasons for this or any tricks to get it to work?
     
    Noozer, Jan 8, 2004
    #1
    1. Advertisements

  2. Noozer

    Paul Guest

    This post and some similar ones, recommend 640x480 by 16 colors. This
    will cut the file size in half (instead of a byte per pixel, you end
    up with a nibble per pixel). This has something to do with the default
    screen resolution/palette during POST.

    http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&selm=8r2f0t$527$

    search terms = bios logo "16 colors" mylogo

    HTH,
    Paul
     
    Paul, Jan 9, 2004
    #2
    1. Advertisements

  3. Noozer

    Noozer Guest

    Trying to put a new boot logo for the wifes PC. It's using a P4C800
    Deluxe
    The software says 256 colour (8 bit) color images... This is actually
    "MyLogo2". The default BIOS logo definately contains more that 16 colours.

    Thanks!
     
    Noozer, Jan 9, 2004
    #3
  4. Noozer

    Paul Guest

    I tried to pull the OEMLOGO file out of the BIOS, using AMIBCP75, the
    BIOS "editor", and the file doesn seem to be 8 bit color, but for
    me at least, the file is truncated, so the original logo doesn't display
    properly. And yet, it doesn't look compressed either, it is just a
    short file.

    This is a short explanation about mylogo versus mylogo2. Apparently,
    mylogo2 support 8 bit color, so you are right.

    http://usa.asus.com/mb/mylogo.htm

    When you tried GIF, was you GIF type 87 or 89? I would try the original
    format for GIFs, on the off chance mylogo2 doesn't have a full GIF
    parser.

    I'm surprised the program isn't trying to compress the image somehow.
    Since you have succeeded in getting _something_ to work with the
    program, maybe you should get a copy of AMIBCP75 and extract the
    resulting logo from the BIOS file, so you can reverse engineer the
    thing.

    AMIBCP75 can be found on the crazyape site (direct links to
    BIOS tools are frowned upon, sorry). Using altavista.com and
    that site as a search time, it is the third link down. Once on
    the site, go to "downloads", then scroll to the bottom. The AMIBCP
    program is a DOS program that takes over the screen, so don't be
    shocked when your monitor goes to 640x480 mode after you double
    click on it :) Since Asus AMI BIOS files are stripped or something,
    you cannot do much with that program except have a look around, or
    extract a file.

    When you extract the logo you've managed to store, it would be
    interesting to see if it is always stored as a BMP or is just a
    direct copy of the file you fed to mylogo2. If it is a recognizable
    format, maybe you could change your original image to that format
    to begin with.

    If you get tempted to manually install the logo using AMIBCP75, I
    don't recommend that, unless you can find evidence that someone
    has succeeded doing that already. The CBROM program couldn't work
    properly with the Asus Award BIOS (at least it didn't for me, and
    I tried several versions), so what are the odds that Asus's idea
    of an AMI BIOS is standard enough to work with AMIBCP ?

    HTH,
    Paul
     
    Paul, Jan 10, 2004
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.