need to get rid of french characters on login screen

Discussion in 'Apple' started by canajien, Jun 5, 2007.

  1. canajien

    canajien Guest

    the user of a macbook got to their new system before i could and chose
    the canadian (french) language setting as default (when they just
    wanted plain canadian) without looking which meant some of the keys
    were transposed with the french characters (pressing the "\" key below
    the "delete" button resulted in a small letter a with an accent above
    it)

    i have corrected the keyboard and language problems when the user is
    logged in, you now get the slash when the "\" key is pressed, but on
    the login screen at startup it is still inserting the small letter a
    with and accent instead of the slash

    i have checked all the setting i could think of in the system
    preferences but it still won't put the correct characters in at the
    login screen

    we need to use the slash, as we are unfortunately tied to an active
    directory network which requires the user to login as "domainname
    \username"

    a couple of hours of searching has proved to be useless and i would
    rather not have to resort to re-installing the entire os to resolve
    this if possible, however that would mean i could keep the macbook
    away from the user for quite some time and hope to teach them a
    lesson ;)

    any ideas on how i can solve this problem?

    thanks
     
    canajien, Jun 5, 2007
    #1
    1. Advertisements

  2. canajien

    Jon Guest

    Activate the root user and change its settings. Worked for me.
     
    Jon, Jun 5, 2007
    #2
    1. Advertisements

  3. canajien

    canajien Guest

    i figured it out, i deleted the setup file in /preferences/var/db and
    rebooted, it then ran the setup assistant from scratch and i was able
    to redo the default language settings
     
    canajien, Jun 5, 2007
    #3
  4. canajien

    Wes Groleau Guest

    I created a keyboard layout that allowed me to easily do pinyin.
    I intentionally called it Roman so that some of the stupider apps
    wouldn't "unselect it." But that allowed the system to keep it
    selected when logging out, making logging in difficult.

    So I selected the setting you just mentioned.
    It did not work--login window is unchanged, no
    additional menu or other control. OS 10.3.9

    --
    Wes Groleau

    You're all individuals!
    Yes, we're all individuals!
    You're all different!
    Yes, we are all different!
    I'm not!

    ("Life of Brian")
     
    Wes Groleau, Jun 6, 2007
    #4
  5. canajien

    Ymir Guest

    It's definitely a new feature in 10.4.x It wasn't present in 10.3.

    Andre
     
    Ymir, Jun 6, 2007
    #5
  6. canajien

    Wes Groleau Guest

    Hmmm. I don't see it on the Login options nor on the
    International prefPane. Yet I'm certain I did something
    to try to set it. Maybe I just edited it into a plist.

    --
    Wes Groleau

    Trying to be happy is like trying to build a machine for which
    the only specification is that it should run noiselessly.
    -- unknown
     
    Wes Groleau, Jun 6, 2007
    #6
  7. canajien

    Simon Slavin Guest

    Accounts
    Login Options
    Show Input menu in login window

    Simon.
     
    Simon Slavin, Jun 8, 2007
    #7
  8. canajien

    Wes Groleau Guest

    Like I said, I don't see it on the Login options ....
     
    Wes Groleau, Jun 9, 2007
    #8
  9. canajien

    Wes Groleau Guest

    Well, I also said I'm on 10.3.9

    The odd thing is that I _know_ I made an attempt to set it,
    but I don't remember how. Doesn't matter, since it didn't work.
     
    Wes Groleau, Jun 9, 2007
    #9
  10. Ouch. Yeah, I've dealt with this before. I'm assuming you're using
    10.3...

    It's been a long time, but if I recall correctly the login screen uses
    the root user's keyboard layout.

    1. Enable the root user with NetInfo Manger.
    2. Log out, and log back in using the root user.
    3. Change the keyboard layout of the root user.
    4. Log out.

    At this point, you should be getting the new keyboard layout on the
    login screen. Log back in to your usual account and disable the root
    user.

    As others have noted, this has been fixed in a more sane way in 10.4.
     
    Steven Fisher, Jun 11, 2007
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.