New BIOS released forGA-8KNXP v2.0

Discussion in 'Gigabyte' started by Kilgore Trout Jr, Nov 17, 2003.

  1. Gigabyte has released the first updated BIOS for the 8KNXP v2.00 (Version
    "FD")

    This board was initially shipped with v.FB. I don't know what happened to
    FC!

    New features include:
    1.. Support for Intel Prescott and P4Extreme family CPU's.

    2.. Fixed CD-ROM can't boot issue.

    This new version seems to have improved the stability of my system. I was
    experiencing random start-up and shut-down problems with Win XP. Also
    noticed random occurrences of high CPU usage and high CPU temperatures for
    no apparent reason when I had no applications running. I've been using FC
    for just a few days now, but so far these problems appear to have been
    fixed.

    There are also some subtle differences in the setup menus. Most obvious
    change is in the C.I.A. Function. (CPU Intelligent Acceleration) FB
    allowed you to
    choose between various percentages of over clocking. The new BIOS offers the
    colorful linguistic choices of Cruise, Sports, Racing, Turbo and Full
    Thrust!

    The SCSI/RAID Control Boot Order option is history. In its place is a Hard
    Disk Boot Priority menu in which you can choose which hard drive you want at
    the system to try to boot from first. It includes a choice of "Bootable
    Add-in Cards." On my system the two SATA HD's are listed as SCSI-0 & SCSI-1.
    What you will see in this menu no doubt depends on what hardware you are
    using.

    The best discovery for me was in the Advanced Chipset menu where there is an
    item called "Delayed Transaction" which by default is set to"Enabled." This
    item was also available in FD and according to the help blurb is supposed to
    enhance system performance
    so I never messed with it. What I found on my system is that things work
    MUCH better with this set to "Normal." With this item set to Enabled it was
    taking 15-20 seconds for a file to open after I double clicked on a shortcut
    in explorer or on the desktop. My applications ran fine but I couldn't
    figure out why it was taking so long to open a file. With this set to
    Normal, these files now snap open in 1-2 seconds. (You know, like they do on
    my old P III 750 running Win98SE !) "Delayed Transaction" should definitely
    not be "Enabled" as a FAIL-SAFE DEFAULT! I would advise everyone to at least
    try setting this to "Normal."

    One more little tip. If you have disabled "Full Screen Logo Show" thinking
    this will speed up the POST, you might not have noticed that it actually
    takes longer to boot. This is because when you turn off the Gigabyte Logo
    you also turn on a lengthy memory test. This probably depends on how much
    RAM you have but with a gig of DDR 400 my system definitely boots up faster
    with the colorful Gigabyte Logo enabled!

    By the way, does anyone know what "PSB Parking" is all about? It's listed as
    one of the advanced chipset features & defaults to disabled.

    You can download the new 8KNXP v2.0 BIOS here:

    http://www.giga-byte.com/Motherboard/Support/BIOS/BIOS_GA-8KNXP (Rev 2.0).htm
     
    Kilgore Trout Jr, Nov 17, 2003
    #1
    1. Advertisements

  2. Kilgore Trout Jr

    RC Guest

    Enabling PSB Parking significantly improved Memory Bandwidth on my 8KNXP
    v1.0.
     
    RC, Nov 17, 2003
    #2
    1. Advertisements

  3. Woger MKII , Nov 17, 2003
    #3
  4. Thanks RC. I did a google search for PSB Parking & drew a blank. Still don't
    know what it is but I took your advice and enabled it. Doing so improved my
    SiSoft Sandra memory bandwidth score by about 250 points!

    Please ignore my comments about Delayed Transaction. Disabling this item
    hasn't made any significant difference in system performance. Turning it on
    or off makes no measurable difference in memory bandwidth. I still can't
    figure out what's wrong with my system. Benchmarking utilities seem to
    indicate I have a high performance machine but it is taking up to 15 seconds
    to open a file after clicking on an icon on the desktop or in explorer. It
    takes a similar amount of time for the right click menu to appear. A second
    or third attempt to open the same file takes much less time, but this
    doesn't seem like normal behavior. I'm new to WinXP as well as a new board
    so I'm not really sure if this is a software or hardware problem.
     
    Kilgore Trout Jr, Nov 17, 2003
    #4
  5. Antivirus software?, startup items?, services?
     
    Richard Dower, Nov 17, 2003
    #5
  6. AV scans and Ad-Aware show system is clean. Shutting down everything in the
    task bar makes only a slight difference. I'm not yet familiar enough with XP
    Services to mess with them without doing a little more research.

    One curious thing I've noticed is that XP will not allow me to customize the
    size of my swap file. It boots up OK with no virtual memory at all, and if I
    set upper & lower limits pagefile.sys remains at the lower limit for the
    remainder of that session. But as soon as I re-boot, the custom settings are
    simply ignored and the swap file swells to the default 1 1/2 X RAM ..... A
    whopping 1535 MB! Task manager shows actual swap file usage running about
    10-15 MB.
     
    Kilgore Trout Jr, Nov 18, 2003
    #6
  7. Kilgore Trout Jr

    Jeff Tope Guest

    Have you tried cleaning your registry - Regclean (microsofts) although now
    long in the tooth still cleans out a lot of rubbish. Also try running
    sysinternals filemon and or regmon - may help show what is going on.
    I have noticed slow response on my XP recently - I wonder if Microsoft has
    dumped out another patch that slows everything down - again.
    Jeff
     
    Jeff Tope, Nov 20, 2003
    #7
  8. Kilgore Trout Jr

    Jeff Tope Guest

    Well egg on face time - my machine is now back up to speed!

    The slowdown appears to be KB811493 - the XP patch from April 2003.

    I have recently rebuilt my PC with a new hard disk and blindly applied the
    patches - including 811493 - removing that patch seems to make everything
    fly compared to 5 minutes ago :->
    Jeff
     
    Jeff Tope, Nov 20, 2003
    #8
  9. Hi Jeff. Thanks for the System Internals tip. I wasn't aware of that site
    and it does look like they have the tools to track down almost any problem.
    I will definitely try Filemon & Regmon as soon as I have a little spare
    time.

    I too just installed XP and applied all the windows updates but couldn't
    find the KB811493 patch you mentioned. My installation disk included SP1so
    if it was part of this cumulative patch I guess there isn't much I can do
    about it. All of the updates & hotfixes listed in Belarc Adviser are dated
    after April 2003. It's not listed in Add/Remove Programs either. I assume
    you're aware that MS recommends that you install the "fixed" version of
    811493.

    http://support.microsoft.com/default.aspx?kbid=819634

    Thanks again for your help!!
     
    Kilgore Trout Jr, Nov 20, 2003
    #9
  10. Kilgore Trout Jr, Nov 20, 2003
    #10
  11. Kilgore Trout Jr

    The Marshal Guest

    Anyone had any hassle with the FE updated bios ?? I put it in yesterday and
    all seemed well but This morning windows bluescreened 5 times on my wife in
    boot up (didnt see the error) then the backup FD bios kicked in and all was
    well ?? I reflashed the FE bios and its working fine but will see tomorrow
    if it does the same on a cold boot.
     
    The Marshal, Nov 22, 2003
    #11
  12. Kilgore Trout Jr

    The Marshal Guest

    Switched off the pc turned of the mains power fired it up again and i get an
    error with the FE bios about the intel sata chipset controller hardware not
    available/compatible "error (9)" then it tries to load up windows and
    reboots.

    Everything is fine with the FD bios so back to that me thinks.
     
    The Marshal, Nov 22, 2003
    #12
  13. I can't tell any difference between FD & FE. Both are a huge improvement
    over FB as far as I'm concerned.
    Both of them re-start and cold boot OK for me. I have two Western Digital
    SATA drives in a RAID 1 setup.
    Have you updated your SATA driver? I'm using v. 3.5.0.2568 which I
    downloaded from Intel.com.
     
    Kilgore Trout Jr, Nov 23, 2003
    #13
  14. FD fixed my Intel ICH5R BIOS initialization from FB. FE fixed the
    detection of my 2xWD1200JD's in the standard BIOS setup when connected
    to ICH5R from FD.

    Still getting text corruption when entering the Freqeuncy/Voltage
    Control menu without any tweaks.

    Later,

    CN.
     
    Captain Nobody, Nov 23, 2003
    #14
  15. Kilgore Trout Jr

    The Marshal Guest

    I am only running 1 Maxtor Sata drive atm with the raid function obviously
    disabled so maybe thats the single drive is the issue with the FE bios on my
    machine?? I have tried the FE bios again and the error on the intel sata
    controller comes up again and again during boot up. FD boots fine for me
     
    The Marshal, Nov 23, 2003
    #15
  16. Most people seem to have better results with SATA RAID Enabled even if they
    only have one drive. This puts the drive in a "RAID Ready" state. With two
    SATA drives on the ICH5R controller, WinXP will see and have access to both
    drives unless and until you set up a RAID volume. This is a little different
    from the SiI controller which requires you to enable it as BASE to access
    two non-raid HD's. Are you booting from an IDE drive? I found I had to
    enable RAID to make a SATA drive bootable.


    --
    GA-8KNXP v2.0 "FE"
    Pentium 4 2.8 w/800 MHz FSB
    1GB Kingston HyperX PC3500 (@ 2.7v)
    2 Western Digital 120 GB SATA
    RAID 1 on ICH5R (v3.5.0.2568)
    MSI FX5600 - VTDR 128 (Nvidia v.52.16)
    Plextor PX-708A DVD-RW
    Audigy II Platinum
    Win XP Pro SP-1 O.E.M.
     
    Kilgore Trout Jr, Nov 23, 2003
    #16
  17. You're seeing corrupt text on screen in the BIOS menu? Sounds like a bad
    file. I would download it again & see if the file size changes.
     
    Kilgore Trout Jr, Nov 23, 2003
    #17
  18. Kilgore Trout Jr

    The Marshal Guest

    I can now set up the single sata drive manually on sata port 0 with FD bios
    unlike in the FB bios where it would only allow me to remap through IDE port
    without crashing, but if i enable the raid function as you have suggested
    windows bluescreens during boot up. I cannot install the raid driver in
    windows because the device isn't enabled. So i suspect i will leave it as
    it is for now until i get a second drive and will be able to setup the full
    raid function during the xp installation.
     
    The Marshal, Nov 24, 2003
    #18
  19. Kilgore Trout Jr

    The Marshal Guest

    Well i worked out why i get the comaptibility issue with FE bios. For some
    reason after the cold boot it reads the drive as SCSI -0 and then errors
    that the drive is not compatible with the SATA controller which is no real
    suprise.
     
    The Marshal, Nov 25, 2003
    #19
  20. I can now set up the single sata drive manually on sata port 0 with FD
    bios
    Exaclty the same problem i'm having with the new F8 bios on my 8KNXP rev 1.

    The ICH5R RAID decides to enable itself after a cold reboot, even though it
    is set to disabled in the BIOS, because of that Windows won't boot because
    it doesn't have the driver for the RAID, and you can't install the driver
    cause you can't get in to Windows with it enabled.

    Only way arround this for me is going back to F6 BIOS, where i have to map
    my SATA drives over Primary Master and Slave and therefore loose 2 IDE
    channels, or reinstall Windows with the ICH5R RAID enabled, but no RAID
    defined (no point with a 80GB and 120GB SATA) so as to get the driver
    installed, then change to F8. Pain in the arse.

    Steve
     
    Stephen Williams, Nov 25, 2003
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.