NF-7S BIOS updated to D21

Discussion in 'Abit' started by Chip, Dec 29, 2003.

  1. Chip

    Chip Guest

    Sorry for shouting, but I just installed this bios and it rendered my PC
    unbootable.

    It introduces another option under the Sata Controller settings to "Enable
    Sata Raid Rom" or something like that. But it doesn't work!

    You cannot boot a raid0 array with this bios installed!

    Even worse, it wouldn't allow me to copy files properly onto a floppy disk,
    so I couldn't build myself a flashing diskette to get back to my old bios.
    Luckily I have another PC to do this on, so I am now OK, having flashed back
    to d2.0.

    Be warned!!!!!!

    Chip.
     
    Chip, Dec 29, 2003
    #1
    1. Advertisements

  2. Chip

    Leadfoot Guest

    Leadfoot, Dec 29, 2003
    #2
    1. Advertisements

  3. Chip

    Leadfoot Guest

    I told you they were HOT ;-)

    Seriotsly they are working fine on my rig but I'm only using one sata
    drive.and I boot from an IDE drive
     
    Leadfoot, Dec 29, 2003
    #3
  4. Chip

    Anders E.D Guest

    I've seen several people on various motherboard forums, that have the same
    problem with the new BIOS. My advice is: If you have a SATA RAID-setup, stay
    away from this BIOS!
     
    Anders E.D, Dec 30, 2003
    #4



  5. Hi all,
    just tried them on my NF7-S which uses SATA-RAID 0 and sure enough it wont
    boot Windows?. Flashed back to BIOS#14 and all is well again. I used
    *Flashmenu* (for the first time) to upgrade the BIOS from windows (nice!),
    but of course I wasn't able to boot windows after flashing, so I simply
    *reflashed* back to old BIOS from a floppy.

    Any ideas why this doesn't work, or reports of any fix/workaround?
    --
    Wayne ][

    Barton (AQXEA) XP2500+ @ 2.2GHz (10x220) - 1.775vCore
    CoolerMaster Aero 7 Lite - 3,200rpm
    ABIT NF7-S (v2.0 - BIOS#14)
    512MB Dual TwiSTER PC3500 @ DDR440 1:1 (9,3,3,2.0 - 2.7v)
    Sapphire Atlantis 9800 - 3.3ns Samsung (325/290 Default)
    240GB (2x120GB) WD-SE SATA RAID-0 (NTFS - 16k Stripe)
    Antec SX630II Mini-Tower Case Inc 300w PSU
    2 x CoolerMaster 80mm Blue Neon Fans
    WinXP-PRO-SP1
    Cat 3.7 - DX9.0b
     
    Wayne Youngman, Jan 4, 2004
    #5
  6. Chip

    BigBadger Guest

    The only fix is to replace the SiliconImage bios insert with the previous
    version. Someone has already done this and you can get it here:
    http://www.freewebs.com/tmod/equitosbiosmods.htm
    However as the only significant change to the d21 bios was the new
    SiliconImage insert it's possibly not worth upgrading from d20.
     
    BigBadger, Jan 4, 2004
    #6

  7. Hi,
    thanks for reply. Since I made the post last night I spent a few hours
    *catching up* with all the posts @ABIT USA Forums
    http://forum.abit-usa.com/. I saw this new modified d21 BIOS from *equito*.
    It seems everyone is keen to get their SiliconImage BIOS updated from
    version 4.2.12 to version 4.2.27 as the very latest version 4.2.43 is
    causing problems with SATA-RAID-0 users. I think I will try it out along
    with the latest nVidia drivers and see if it makes a difference.

    From what I am reading people are saying they get *faster* RAID performance
    going from BIOS 4.2.12 to 4.2.27. . . lets see. . .!
     
    Wayne Youngman, Jan 4, 2004
    #7
  8. Chip

    Chip Guest

    I have been running 4.2.27 modded into bios d20 for a while. And I have
    tried going back to 4.2.12 a number of times too (to try to fix another
    unrelated problem). I couldn't detect any measurable speed difference
    between the two.

    Chip.
     
    Chip, Jan 5, 2004
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.