NFS, automount, etc.

Discussion in 'Apple' started by El Groló, Aug 28, 2005.

  1. El Groló

    El Groló Guest

    How do I let a user log in to a Mac or FreeBSD
    and have his/her home directory NFS mounted
    from the main Mac?

    Before I crashed and rebuilt my disk,
    I had the Mac mounting directories from
    a FreeBSD host. But I never succeeded
    in going the other way.

    To make it work, I had to turn off the
    $%^&%^& automounter, which seemed to take
    the attitude, "I don't care WHAT you put
    in fstab, the correct mount point is
    /Volumes/whatever, and I WILL make soft links
    with permissions errors in my directory,
    no matter what you say!"

    OK, rant over, bottom line is with the
    automounter OFF, it worked.

    Now, I set up exports and fstab the same as before,
    loaded them into NetInfo, and did mount -a

    Again got the stupid permission denied messages
    on /automount/servers/Users/userID

    So, again, I turn off the automounter and try again.

    Now, it's
    NFS Portmap: RPC: Port mapper failure - RPC: Timed out

    This is 10.3.9 I want all my users to have ONE
    home directory, not one on each Mac. So the smaller
    Mac has an empty directory for ech user (except Admin)
    and an fstab to mount the real dir on the other machine.

    Oh, and I put "mount -a" in one of the startup items.
    That gets them mounted _before_ anyone logs in.
    At least it did before the crash.

    The reason for that is the Finder is too stupid to
    recognize when an empty directory gets mounted.
     
    El Groló, Aug 28, 2005
    #1
    1. Advertisements

  2. El Groló

    El Groló Guest

    To put it another way, IF it were Solaris or
    FreeBSD or HPUX, etc. the following would work:

    Server> echo "/Developer -rw -alldirs -maproot=nobody
    -network=192.168.xx.0 -mask=255.255.255.0" > /etc/exports

    ssh -l admin Client

    Client> su -

    Client> echo "Server:/Users/username /Users/username nfs rw 0 0" \
    then cycle mountd and "mount -a" or reboot, etc.

    What to do in OS X? Some web pages I've read
    suggest I have to learn LDAP and do all sorts
    of weird stuff with that. Others say it can't
    be done in OS X (which I don't believe).
     
    El Groló, Aug 28, 2005
    #2
    1. Advertisements

  3. El Groló

    David Magda Guest

    Look at the "automount" software. "Amd" (automount daemon) is also
    available on OS X (and is used in FreeBSD, and available for just
    about any Unix), but I don't know how well it works.

    The web site for amd is:

    http://www.am-utils.org/
     
    David Magda, Aug 28, 2005
    #3
  4. El Groló

    El Groló Guest

    I'll look into 'amd' but unless someone can tell me
    EXACTLY what to do to make Apple's 'automount' work,
    AND I verify that it actually works, I will continue
    to believe that it is crap.

    ("work", by the way, means I can mount something on a path
    that does NOT start with "/Volumes/", NOT get errors
    that include paths starting with "automount" and ending
    with "permission denied", and NOT have network icons
    in Finder that say "original can't be found" when you
    click on them)

    When I turned off the automounter, all my FreeBSD
    directories were always available on the Mac. But
    with or without automount, I NEVER got the Mac to
    share the other way.

    (BTW, this is not an anti-Apple rant. I really
    like OS X. It's just that this one feature sucks.)
     
    El Groló, Aug 29, 2005
    #4
  5. El Groló

    El Groló Guest

    ipfw is somehow failing to read some of the rules in the
    firewall file. Specifically, the rules designed to
    exempt all machines on the local network from the later
    rles that keep out stuff from the rest of the internet.
    Nothing wrong with the file syntax--I can cut and paste
    the exact same rules at the command line and ipfw honors them.

    After reboot, ipfw list shows rule 0010, 0074, 0075, and on.

    Rules 0020, 0030, 0040, 0050, 0060, 0070, 0071, 0072, 0073
    are not there. "head /etc/firewall.conf" and cut/paste the
    rules, and then 'ipfw list' will show them--and NFS to FreeBSD
    disks works.

    ?!?!?!?

    Now to try the Mac-to-Mac shares.......
     
    El Groló, Aug 29, 2005
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.