non-functional parallel port on P4P800

Discussion in 'Asus' started by Jake Fisher, Jun 25, 2003.

  1. Jake Fisher

    Jake Fisher Guest

    Has anyone encounter this problem? I have a P4P800 Deluxe motherboard
    and the onboard parallel port does not appear to function. It shows
    up in the Device Manager and reports it is enabled and there are no
    conflicts. Whenever I connect a printer to the port and try to print,
    Win XP reports that the printer is not connected.

    Does anyone have any suggestions? I have tried numerous BIOS tweaks
    with no success.
     
    Jake Fisher, Jun 25, 2003
    #1
    1. Advertisements

  2. Jake Fisher

    Maximus Guest

    At first, there is no problem printing at all.

    But once I had this problem all of a sudden, when I update bios.
    You may need to install latest printer driver, delete the old printer and
    re-install printer.

    Maximus
     
    Maximus, Jun 25, 2003
    #2
    1. Advertisements

  3. Jake Fisher

    Jake Fisher Guest

    I don't think this is the problem. I have flashed the BIOS with the
    latest 1007 version and this is a fresh install of Win XP. I have
    tried the parallel port with two different printers (HP LJ 6MP and
    Epson Photo Stylus EX) with the same results. I have used the drivers
    I am using now with Win XP on my old system with no problem. Right
    now, as a work around, I have a Lava PCI Parallel port installed and
    both printers work fine from this port with the same drivers. I think
    there is something definitely wrong with the port or I have something
    miss set in either Win XP or the BIOS.
     
    Jake Fisher, Jun 25, 2003
    #3
  4. Jake Fisher

    Bob Knowlden Guest

    At the risk of giving insult,

    Have you turned on the parallel port in the BIOS settings? On my P4P800, the
    parallel port was off by default.

    It seems odd that it would be inactive in the BIOS but showing up OK in
    Device Manager. I haven't played with it, although I activated it (ECP) in
    case I need to run some software from work that uses a parallel port key. (I
    have two printers attached to the system, but they both are connected via
    USB.) I haven't tried the key yet, to see whether it's recognized.

    Good luck.

    Bob Knowlden

    Spam dodger may be in use. Replace nkbob with bobkn.
     
    Bob Knowlden, Jun 25, 2003
    #4
  5. Sounds like this old IBM I'm using here.
    None of the settings help.
    The computer still knows if the printer power is off, or if there's no paper.
    A dot-matrix printer still "jiggles" the head during the BIOS's init.
    Won't print from a DOS boot.
    Windows *thinks* it printed, but nothing comes out.
    Even an add-in card doesn't work, though the card & printer work on another machine.

    I'm pretty sure I killed mine by plugging in the data cable while everything was powered up.
    Didn't do anything bad the many times I did it before, but this time I'm in a different house,
    and I think the printer was on a different circuit, so there may have been a "ground potential"
    difference between it and the computer.

    Ran some tests where a voltmeter checks the various data lines, and they seem to toggle okay,
    but it doesn't say how to test the "strobe" line that actually sends the data.
     
    MasterBlaster, Jun 25, 2003
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.