1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

ntdll.dll tabtip.exe error after installing Sp2

Discussion in 'Tablet PC' started by Luca, Oct 31, 2004.

  1. Luca

    Luca Guest

    Hi to all,

    after installing Service Pack 2, when I click into Input Panel it appears a
    system error that says:

    AppName: Tabtip.exe AppVer: 1.7.200.2180 ModName: ntdll.dll
    ModVer: 5.1.2600.2180 Offset: 00010370

    I follow some suggestions on the net, in particular to set the proper
    keyboard language (italian), but nothing
    has changed and already have this error. I wouldn't uninstall Service Pack
    2, some of Tablet Users have solved this
    problem?

    Thank you,

    - Luca -
     
    Luca, Oct 31, 2004
    #1
    1. Advertisements

  2. Luca

    Chris H. Guest

    If your Details button on the Languages tab are correct, Luca, you should
    have Advanced Text Services which includes Tablet PC Correction, Tablet PC
    Correction for Windows Journal and Tablet PC Text Insertion. (If you have
    Office 2003 installed you will also have a fourth entry.)

    If that is all proper, try going to the Command Prompt (not Start/Run) and
    enter "regsvr32 inkobj.dll" without the quotation marks, then Enter and then
    "regsvr32 tpcps.dll" (without quotes) then Enter again. Restart your
    machine after finishing each of those two modifications to the Registry.
     
    Chris H., Oct 31, 2004
    #2
    1. Advertisements

  3. Luca

    Luca Guest

    Hi Chris,

    Nothing to do. I re-registered that two dlls, but nothing has changed. I saw
    details (in Advaced Text Services), and even if I have installed Office
    2003, I see only that three Services you described in your last message and
    not four. I don't understand what is wrong.

    "Chris H." <> ha scritto nel messaggio
     
    Luca, Nov 1, 2004
    #3
  4. Luca

    Chris H. Guest

    What version of .NET framework do you have installed? If you go to
    Start/Run and put in "mscorcfg.msc" without the quotes, are you able to
    access the .NET configuration tools. If you do have .NET installed and this
    doesn't work, if may be corrupt and need to be updated/reinstalled.

    If you have an early version installed, the .NET 1.1 Service Pack 1 is
    available here http://msdn.microsoft.com/netframework/ . Look under the
    Framework Downloads link.
     
    Chris H., Nov 1, 2004
    #4
  5. Luca

    Luca Guest

    Dear Chris,

    thank for you patience. I tried to start mscorcfg.msc from Start/Run but it
    didn't start.
    So I installed .Net 1.1 from Microsoft, and tried again to start .msc from
    Start/Run, but nothing.
    I made a search trought my HD and I found it in c:\windows\microsoft
    ..net\etc. After Start it directly from the .Net
    folder I find the version 1.1.4322.573.

    By the way, after installed the Framework the problem hasn't been solved. I
    de-installed the Service Pack 2 and Tablet
    Input appears again, after re-installing Service Pack 2 it disappeared.

    Really, I don't understand where it is the problem.
     
    Luca, Nov 1, 2004
    #5
  6. Luca

    Chris H. Guest

    We should go step-by-step on this. Are you getting any error messages when
    you attempt to start mscorcfg.msc from Start/Run, or is it just not
    responding? If you go to Start/Run and put in "msc" without the quotes,
    then tap the OK button, does that launch the Microsoft Management Console
    without error?

    If you go into Control Panel/Administrative Tools do you see the Microsoft
    ..NET Framework 1.1 Configuration shortcut in there? Does it launch properly
    from that location?

    When you say the Tablet Input Panel "disappeared" could you describe exactly
    what you're seeing? Are you saying there is no icon in the Taskbar area
    from which to launch the TIP? Are you saying it doesn't launch when you tap
    that icon?
     
    Chris H., Nov 1, 2004
    #6
  7. Luca

    Luca Guest

    Hi Chris,

    When I try to run mscorcfg.msc from Start/Run it simply says that it doesn't
    find any program with that name. So I must search it throught Hd and run it
    directly from
    its directory.

    I launch the Framework correctly from Administrative Tools.

    I make a mistake, I mean with appearing that the panel is displaying as a
    keyboard meanwhile now it's
    only a window without the keyboard. Empty.
     
    Luca, Nov 1, 2004
    #7
  8. Luca

    Chris H. Guest

    Luca, perhaps we should try this: Go to the Command Prompt (you can get
    there by doing "cmd" without the quotes from Start/Run), then would you
    enter "regsvr32 inkobj.dll" without the quotation marks, then Enter and then
    "regsvr32 tpcps.dll" (without quotes) then Enter again. Restart your
    machine after finishing each of those two modifications to the Registry.

    If this doesn't correct the situation, then I would suggest booting into
    Safe Mode (F8 or the appropriate Tablet button on boot-up) so no drivers are
    loaded, and no programs are running, then do a reinstall of Windows XP SP2
    and the Tablet PC Edition 2005 over the top of what you have.

    This will not uninstall or wipe out any of your programs, but make sure
    you've backed up your personal files just in case.
     
    Chris H., Nov 1, 2004
    #8
  9. Luca

    Luca Guest

    Don't be angry Chris, but it doesn't work.
    I don't realize what Service Pack 2 Install to not permit the correct
    functioning of Tablet Input.

    Let me know,

    - Luca -
     
    Luca, Nov 2, 2004
    #9
  10. Luca

    Chris H. Guest

    Luca, I'm only bothered that it isn't working correctly, and trying to help
    you figure out what's wrong. Not to worry.

    When you say it "doesn't work" could you give me the exact details of what
    happened? Did it fail with an error message? Did it not find the files I
    said to run the Registry fixes on?

    If I don't have details - (1) I followed your instructions and (2) this is
    what happened - I have no way of knowing which way to try what next. :cool:
     
    Chris H., Nov 2, 2004
    #10
  11. Luca

    Luca Guest

    Hi Chris (again),

    it means that it's as before, so the table input is empty when Windows Xp
    starts, and when I login
    to the system and when I try to run the table input from the icon it returns
    with a system error (ntdll.dll
    and tabtip.exe). So, nothing has changed.
     
    Luca, Nov 2, 2004
    #11
  12. Luca

    Chris H. Guest

    Okay, perhaps we should take a wild stab at a different direction. You're
    running anti-virus software, correct, with the latest definitions? If so,
    please use that to do a thorough check of your system.

    After you've done that, if you have parasite and Trojan detecting software
    available, please update the definitions and then run those. You may also
    be interested in the information on parasites and Trojans here:
    www.aumha.org/secure.

    With all that out of the way - and the main reason I'm asking you to do
    that - I would like you to go into Windows Explorer and locate and verify
    the inkobj.dll and tpcps.dll files are in the folder at C:\Program
    Files\Common Files\Microsoft Shared\Ink .

    When you find those files, please right-click each of them individually and
    select Properties. Then tap the Version tab and in the Item name: pane tap
    File Version. Right-click the result in the right pane and select "Copy."
    Then paste that information into your response post here for each of the
    files.
     
    Chris H., Nov 2, 2004
    #12
  13. Luca

    Luca Guest

    Well Chris,

    It's a clean installation of Windows Xp Tablet so it's very hard to find it
    some viruses or adware, by the way
    I did it and I find two files suspect to be adware (but it was a backup copy
    of a previous installation). I removed them.

    These are informations about two files:

    Inkobj.Dll

    File Version: 2.7.2600.2180

    File Version: 2.7.2600.2180 (xpsp_sp2_rtm.040803-2158)
    Language: English (United States)

    TcpPs.Dll

    File Version: 1.0.2201.0

    File Version: 1.0.2201.0 (xpsp1.020828-1920)
    Language: English (United States)
     
    Luca, Nov 2, 2004
    #13
  14. Luca

    Chris H. Guest

    Those are the correct files, according to my installation here. Did you run
    the regsrv32 portion we talked about previously at the Command Prompt within
    that directory?

    This was: At the Command Prompt (within the C:\Program Files\Common
    Files\Microsoft Shared\Ink enter "regsvr32 inkobj.dll" without the quotation
    marks, then Enter and then "regsvr32 tpcps.dll" (without quotes) then Enter
    again. Restart your machine after finishing each of those two modifications
    to the Registry.
     
    Chris H., Nov 2, 2004
    #14
  15. Luca

    Luca Guest

    Yes I did it. Probably I must tell you a thing. I installed a MSDN version
    of Tablet Xp overwriting
    a previous version of Tablet Xp (not MSDN). It could be the reason of this
    system error? I don't think as
    if I remove Service Pack 2 everything is going well.
     
    Luca, Nov 3, 2004
    #15
  16. Luca

    Chris H. Guest

    I'm going to go off in a small, dark cave and think, Luca. :cool:
     
    Chris H., Nov 3, 2004
    #16
  17. Luca

    Mark H. Guest

    Hi Luca,

    I ran into this exact same issue. It appears to be a .NET dependency issue
    which I was able to correct by changing the configuration of TCServer.exe.

    On your system go to the directory "Program Files\Common Files\Microsoft
    Shared\Ink" under your system drive. There will probably be a file called
    TCServer.exe.config. If you look at this file in notepad, it will probably
    look like this:

    "<configuration>
    <startup>
    <requiredRuntime version="v1.0.3705" safemode="true"/>
    </startup>
    <runtime>
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
    <publisherPolicy apply="no" />
    </assemblyBinding>
    </runtime>
    </configuration>"

    This is causing TCServer to reference version 1.0 of the .NET Framework when
    loaded. I am not sure if this is the desired behavior or not; however, by
    removing this dependency my TIP loads correctly now.

    The easiest way to remove the dependency is to just rename the file to
    something like TCServer.exe.config.old. You could also force it to reference
    version 1.1.4322 of the framework, but in the absence of a configuration file
    ..NET will use the default system configuration.

    Renaming the file resolved the crashing error for me.

    Unfortunately, I'm still trying to get my on-screen keyboard to come up
    correctly, but one problem at a time....

    Hope this helps,
    -Mark
     
    Mark H., Nov 14, 2004
    #17
  18. Luca

    lhooipg Guest

    Hi Luca,

    I had the same problem like you and I managed to solve it using Mark
    method but the only thing I do is to change the .net version instead of
    renaming the TCServer.exe.config.

    What I do is change the version to "v1.1.4322" and restart my laptop,
    then it's work...hurray...

    <configuration>
    <startup>
    <requiredRuntime version="*v1.1.4322*" safemode="true"/>
    </startup>
    <runtime>
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
    <publisherPolicy apply="no" />
    </assemblyBinding>
    </runtime>
    </configuration>

    And now need to solve the keyboard issue like Mark..
    "I'm still trying to get my on-screen keyboard to come up
    correctly, but one problem at a time..."

    Regards,
    Jeffrey
     
    lhooipg, May 17, 2009
    #18
  19. Luca

    lhooipg Guest

    Hi Mark,

    I managed to solve the on-screen keyboard problem....

    Try this:

    1. Press the Windows key and the U at the same time.
    2. This should bring up Utility Manager -- a little manager of
    accessibility tools. Narrator may or may not be automatically running.
    If it is, close it out (it's a nuisance unless you need it).
    3. Select On-Screen Keyboard in the listbox.
    4. The option Start Automatically When I Login should be checked.
    Uncheck it.
    5.Click OK.
    6. Log out and back in and see if that fixed the problem.

    Good luck...


    Regards,
    Jeffrey

    ---------------------------------------------------------------------
     
    lhooipg, May 17, 2009
    #19
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.