1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

nvidia opengl error - Counter Strike on Multi-mon.

Discussion in 'Nvidia' started by Bronney Hui, Feb 25, 2004.

  1. Bronney Hui

    Bronney Hui Guest

    Dear all,

    This is really weird. I used to play CS on 1 monitor setup with 41.09 on Ti
    200 64MB perfectly. Recently I installed a PCI radeon 9200SE 64MB for a
    second monitor. I did not use the ati control panel and used the rage3d
    tweak instead. But this should have nothing to do with my problem.

    The problem is, as soon as I had 2 monitors up and running, I can't start
    counter strike. I can go into the menu and browse games ok, but as soon as
    it tries to connect, it craps out. There're 2 ways it pops out:

    1. Both monitor enabled, with the original nvidia as primary, it does a
    windows alert sound, when i press the windows key, i see 2 task items,
    "counter strike", "nvidia openGL". I had to right click on that to close
    it.

    2. Disabled the second monitor in display properties, running CS on the
    nvidia, at the same stage, it pops back to the game browser, and says "the
    selected opengl video mode is not supported by your video card."

    This is really weird cuz all I did was installed a card, setup drivers,
    installed rage3d tweak. I even had this formatted and it still won't work.

    Could it be that the installation of ati drivers somehow fooled or overwrote
    the default openGL ICD? When I checked the display properties under nvidia,
    it does have the 41.09 ver. as the openGL ICD. It boggles my puny mind.
    Please help.


    -bron
     
    Bronney Hui, Feb 25, 2004
    #1
    1. Advertisements

  2. Bronney Hui

    John Lewis Guest

    Which PCI slot ?

    If PCI #1, move the PCI video card to another slot that has an
    interrupt not shared with a sound-card, or disk-controller.
    AGP and PCI #1 share physical interrupts. This may not be the root
    cause of your problem, but should be attempted anyway.

    John Lewis
     
    John Lewis, Feb 25, 2004
    #2
    1. Advertisements

  3. Bronney Hui

    Dark Avenger Guest

    Well ya know what it is, in your current setup you can't play games on
    dual monitors. Why, because ati cards and nvidia cards CAN work
    together fine in 2d, but once a game run only the primary card gets
    the videostream...

    The error you get seems to point at that an little program of
    nvidia,making it possible to game on multiple monitors..has problems
    with working with the ati card.

    Ya know, what I suggest..is 1 card with 2 outputs, then you get no
    conflicts and no problems with 3d.

    So either a nice nvidia card with 2 outputs or an ati card with 2
    outputs, ati and nvidia together might work under 2d but not under 3d!
     
    Dark Avenger, Feb 25, 2004
    #3
  4. Bronney Hui

    Bronney Hui Guest

    Thanks John,

    My ati is on slot 5, which according to the manual, shares IRQ with slot 1.
    Slot 1 is empty to accommodate the AGP fan. So I guess it's ok. There seem
    to be no conflict between the ati with other devices and the same for the
    nvidia on the irq table. I think the Ati's card is sharing irq with either
    my second nic, or the usb root hub. The agp nvidia is exclusive on 11.
    While the ati's on irq 10.

    But since #5 shares with #1 and you said #1 shares with AGP, it might be the
    root of another problem of experiencing hangs when dragging divx across
    monitors.

    Will try and let you know. Thanks.
     
    Bronney Hui, Feb 26, 2004
    #4
  5. Bronney Hui

    Bronney Hui Guest

    Thanks DA,

    I get your point. That's why I am not trying to run them together in 3d.
    nView isn't asking CS to run in both monitors btw and I disabled nView. And
    that's exactly why I stick with the old 41.09 driver. I saw peeps running
    CS in duals but I am not interested in that. Just not the right aspect
    ratio for me to shoot.

    Anyway, to prove that your hypothesis is *ahem* wrong.. I even try launching
    CS in windowed mode. So the stream's on the nvidia. It still fails, and
    also tried on the ati, and it fails. Tried all combos and they failed.
    Which is really really weird now, cuz I know the 9200se can play CS.

    Yeah.. well I got this 9200 for cheap. But yeah maybe in the future I'd get
    a dual head card. Are they any good though??
    ===
     
    Bronney Hui, Feb 26, 2004
    #5
  6. Bronney Hui

    Dark Avenger Guest

    Nowadays dual head cards are pretty good. And can be found pretty
    cheap to. Important though is that is has two ramdacs ( that it
    actually CAN use two outputs at the same time ) the rest doesn't
    matters to much.
     
    Dark Avenger, Feb 26, 2004
    #6
  7. Bronney Hui

    Bronney Hui Guest

    Thanks.

    Will get em when I finally upgrade my CPU. It's my CPU that's bottlenecking
    :)
     
    Bronney Hui, Feb 27, 2004
    #7
  8. Bronney Hui

    Bronney Hui Guest

    Case closed.

    Fixed it with installing the new 53.03 forceware. Though now rivatuner
    can't OC when boot. And I lost my nvidia display properties tab. It's
    confirmed 53.03 in rivatuner and I tweak settings with that anyway so I'm
    ok.
     
    Bronney Hui, Feb 28, 2004
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.