1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

OBP - POST endless loop

Discussion in 'Sun Hardware' started by Steven Klooster, Nov 27, 2011.

  1. Here's my story. I've stumbled through these tests a long time ago,
    managed to
    make it work but now have a problem, cockpit error.

    I have tried to make a summary of what happened. If you don't know this
    one, can
    you forward to someone or recommend a good place to post?

    Think the problem might be because I failed to do setenv auto-boot?
    false ( stop Solaris booting )
    Now test keeps rebooting.

    I also read where a CTL-D locks you out. No statement of what to do
    about it.

    ......

    I managed to lock myself out of my V880 doing a POST test via the OK
    prompt.
    by setting
    ok> setenv diag-switch? true
    ok> setenv diag-level max

    I don't think I changed setenv auto-boot? false but think it is true
    now. I think
    everything else was default?

    I have a dumb term VT510 emulating a VT100 and a PC-like keyboard hooked
    up to TTYA
    to view POST output during test. Now nothing comes up on the normal Sun
    Console
    and keyboard input does nothing. L1-A or Stop-A on that keyboard and
    console does nothing.

    When powered on, POST runs with output on the VT100 display.

    I managed to find the lowest memory DIMM was bad from the POST output I
    saw,
    I replaced the DIMM and reran and everything seems all right. I had to
    power down
    to get out of the diagnostics.

    Now I have created another problem for myself. I can't return to the OK
    prompt or
    get out of this test, it just keeps repeating. At the end of the POST
    it just starts again.

    Typing Break, Ctr-B, or pressing the space bar interrupts the test and
    says - "POST is
    running". This is on the dumb term, could be the wrong keyboard (PC).
    No response from
    the console and keyboard.

    I have checked connections with main keyboard and video, seems all right.

    Is there a jumper on the mother board to get the prom in the default
    state?

    If you have ever encountered this, can you tell me what might work or
    where would be
    a good place to post the same question?

    Thanks in advance,

    klue
     
    Steven Klooster, Nov 27, 2011
    #1
    1. Advertisements

  2. Steven Klooster

    YTC#1 Guest

    Does Solaris actually try and boot ?

    Do you have an RSC ?

    IIRC, you should be able to abort the test from there.

    http://www.sunshack.org/data/sh/2.1...a/syshbk/collections/INFODOC/1-9-45504-1.html

    You are better off using a PC to connect via the serial port.
    Take the key out of diag mode ?


    --
    Bruce Porter
    XJR1300SP, XJ900F, Pegaso 650 Trail (x2) one red one grey
    POTM#1(KoTL), WUSS#1 , YTC#1(bar), OSOS#2(KoTL) , DS#3 , IbW#18 ,Apostle#8
    "The internet is a huge and diverse community but mainly friendly"
    http://blog.maui.co.uk/index.php/ytc/
    There *is* an alternative! http://www.openoffice.org/
     
    YTC#1, Nov 29, 2011
    #2
    1. Advertisements

  3. I found a solaris spectum letter from sun that says on this machine
    you can push the power button twice, about a second apart to reset
    defaults. Missing it turns the machine off. It did not say how fast
    that blinking was and I was trying almost immediately. Never worked.
    Searching on the net says it may take 20-30 minutes to get to that stage.
    It only lasts for a few seconds. Think I got it reset but the bad news
    I power cycled it many times, perhaps creating another problem. It
    passed all the diagnostics with the lengthy or high report setting. I
    was not using the key position for diagnostics.

    It now gets to the boot stage after running diagnostics, passes and
    now fails which checking I-O with a fatal hardward error, then prints
    out register info for each cpu. Then it starts over. I now suspect the
    mother board which maybe didn't like all the power cycling on and off.
    This machine has been up most of its life.

    Any more ideas would be appreciated. Not sure this posted.
    Thanks,
    klue
     
    Steven Klooster, Dec 4, 2011
    #3
  4. Steven Klooster

    YTC#1 Guest

    It would help if you could be more specific about the IO error.

    It is still not clear if Solaris has booted and if that is a disk read
    error.

    Have you got CD/DVD you can b boot from ? Or a JumpStart server?

    You could try seeing if there is some here that could help

    https://forums.oracle.com/forums/category.jspa?categoryID=301
     
    YTC#1, Dec 5, 2011
    #4
  5. Steven Klooster

    ChrisQ Guest

    It's not clear if you are accessing the machine via the lom port, which is
    an rj45 connector on the back panel marked "serial management, or similar.
    This should be usable even with power off (but connected) and uses a
    separate
    hardware / processor from the main cpu(s).

    The lom port has two modes: lom management and obp console. Select lom
    by typing #. (hash dot) <return> at the terminal. To get back to obp
    console, type
    "console" <return>. This also assumes a normal keyboard is not plugged in.

    At the sc> / lom prompt type "help" to get all the commands, one of
    which is:

    "bootmode [normal:reset_nvram:diag...] etc

    select "reset_nvram", then power disconnect, connect, then hard reset at
    the sc>
    prompt. Once all the terminal messages subside, reset boot mode back to
    normal
    or diags as required and another power disconnect / connect. The machine
    should
    then hopefully be unbricked.

    I had a similar problem on a v240 recently. It took a couple of hours
    and google
    to work out how to fix it, but you should always be able to access the
    machine
    via lom, even if the main cpu subsystem is temporarily awol...

    Regards,

    Chris
     
    ChrisQ, Dec 6, 2011
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.