Odd Dell Advanced Port Replicator problem

Discussion in 'Dell' started by Bob Pownall, Oct 15, 2006.

  1. Bob Pownall

    Bob Pownall Guest

    Bottom line: I seem to have an IRQ problem, but only when docked, and I
    can't figure out how to solve it.

    System: Dell Inspiron 8500, Windows XP Pro, SP2

    Regular readers of this newsgroup may remember that I posted a few weeks
    ago about my experiences with a Kensington docking adapter after my Dell
    APR failed. I was dissatisfied with the Kensington, returned it to the
    vendor, and bought a new Dell APR on eBay. ("New" as in "still in
    unopened plastic bags in the Dell box".)

    The new APR came today, so I unpacked it and set it up.

    After doing so, I discovered an odd problem.

    While docked, my laptop's internal CD-ROM/DVD drive no longer shows up
    in "My Computer", nor does my legacy parallel port ZIP drive.

    Further investigation revealed that, when docked, my laptop's
    communication port and secondary IDE drive were sharing IRQ15.

    For now, I am assuming that this is the cause of the problem with my
    internal CD-ROM/DVD drive (wouldn't that be on the secondary IDE
    channel?) and ZIP drive (as a parallel port device, wouldn't it be on
    the communications port?)

    From what I've been able to Google, IRQ15 is correct for the secondary
    IDE port, while the com port should be IRQ4.

    I've tried manually changing the IRQ for the com port. When I check the
    properties for the COM port, and go into the Resources tab, it shows as
    IRQ4. However, in Device Manager, when I do "View Resources by Type",
    the com port shows as "(ISA) 15 Communications Port (COM5)", which would
    seem to imply that it's still IRQ15. WTF?!?!

    (As a side note, shouldn't that be COM1, not COM5? Not real sure how
    that happened, but I doubt it's related to the underlying problem.
    Probably something I did by accident or intentionally a while back, and
    forgot about. Never-the-less, if I'm correct and it should be COM1, I'd
    appreciate suggestions how to change the ID back.)

    The _really_ odd thing (IMHO) is that when I'm undocked,
    1) My parallel port ZIP drive and my internal CD-ROM/DVD drive _do_ show
    up in "My Computer".
    2) My secondary IDE channel is still at IRQ15, but my com port is now at
    IRQ4.

    I don't understand why the docking adapter would affect the IRQ
    assignments, and I don't understand why my manual setting of the com
    port to IRQ4 isn't "taking" when I'm docked.

    Note that my old, failed APR did _not_ have this problem. Both my
    internal CD-ROM/DVD drive and my external legacy parallel-port ZIP drive
    worked find.

    Any ideas or suggestions of things to try or to check?

    Bob Pownall
     
    Bob Pownall, Oct 15, 2006
    #1
    1. Advertisements

  2. Bob Pownall

    S.Lewis Guest


    Bob -

    So this Zip drive is external, connected to the LPT/Parallel port on the
    replicator - is that correct?

    If so, when you disconnect the Zip from the replicator, does the CD/DVD
    magically re-appear after reboot or re-dock?

    This sounds like a legacy hardware issue to me or even a BIOS setting that
    causes the replicator to see the Zip and mistakenly throw it on the
    secondary IDE IRQ.

    Is this a "C" or "D" port? (Seems I recall it was a "D" series?)

    My goal would be to get the laptop and optical drive seen and functional
    first, then deal with the Zip drive secondarily.

    Stew
     
    S.Lewis, Oct 15, 2006
    #2
    1. Advertisements

  3. Bob Pownall

    Tom Scales Guest

    <snip>

    A few thoughts

    1) Do you NEED the serial port? If not, disable it in the BIOS
    2) Ditch the Zip drive. They were never very reliable and are aging and have
    little capacity
    3) Are you sure the drives are just not getting drive letters? What does
    disk management say?

    Tom
     
    Tom Scales, Oct 15, 2006
    #3
  4. Bob Pownall

    Bob Pownall Guest

    Steve and Tom,

    Thanks for your responses and help.

    I tried disconnecting the Zip drive and rebooting, as Steve
    suggested, and found that the CD/DVD drive now appeared.

    When I checked the IRQ assignments, I found that the COM port was now
    on IRQ4, so there was no longer any conflicting the the secondary IDE
    port on IRQ15.

    At this point, I decided to shut down and connect my external
    parallel port Zip drive, just to see what happened.

    When I rebooted, everything was back to normal. All my drives,
    including the internal CD/DVD drive and the external parallel-port Zip
    drive, showed up under "My Computer".

    Not really sure I understand what's going on here, and just exactly
    what fixed the problem, but as long as things stay fixed, I'm not going
    to worry about it too much. (Maybe Windows just needed to see a boot
    without the Zip drive in order to assign the IRQs correctly?)

    Oh, one last thing. Getting rid of the Zip drive isn't an option,
    because of some equipment I use that moves files on Zip drives - they're
    too big to fit on a floppy. I've got some internal and external Zip
    drives I've scavenged, for the inevitable day when either the internal
    Zip drive in the tool breaks, or my external Zip drive breaks.

    Again, thanks for your help.

    Bob
     
    Bob Pownall, Oct 16, 2006
    #4
  5. Bob Pownall

    Bob Pownall Guest

    Oops, that should be "Stew and Tom", not "Steve and Tom".

    Again, thanks for your help.

    Bob Pownall
     
    Bob Pownall, Oct 16, 2006
    #5
  6. Bob Pownall

    BillW50 Guest

    Oh Bob... I think what Tom was getting at is ZIP drives are expensive
    nowadays. Are you still buying those expensive floppys for example? And
    if you are spending more money on them then it might be best to stop. As
    external HD, DVD-+RW, and flash drives have sort of made those ZIP
    drives obsolete. As there are much cheaper of methods of storage and
    file transfers. Although if you already bought everything you need years
    ago with regards to ZIP drives, then never mind. As I have one myself in
    a box somewhere. ;)
     
    BillW50, Oct 16, 2006
    #6
  7. Bob Pownall

    Tom Scales Guest

    More than anything, I was getting at the fact that Zip drives (and disks)
    are notoriously unreliable, particularly as they are aging. I wouldn't
    personally risk them.

    Tom
     
    Tom Scales, Oct 16, 2006
    #7
  8. Bob Pownall

    Bob Pownall Guest

    Understood, but it's what I have to work with, at least until the
    instrument dies (and has to be replaced), or until I can get funding to
    buy a new one, with modern I/O devices.

    Bob Pownall
     
    Bob Pownall, Oct 16, 2006
    #8
  9. Bob Pownall

    Tom Scales Guest

    There's always that :)

    Tom
     
    Tom Scales, Oct 17, 2006
    #9
  10. Bob Pownall

    paulmd Guest

    BIOS update on the computer somethimes helps. It has before for me on
    at least 1 occasion.
     
    paulmd, Oct 17, 2006
    #10
  11. Bob Pownall

    S.Lewis Guest

    What's a 250mb zip disk run nowdays anyway? $12 or more? $50 a
    gig......yeeeesh.

    click click click click click click...............
     
    S.Lewis, Oct 17, 2006
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.