ODD PROBLEM: "Shift-S" Doesn't work for upper case "S" Mac Mini

Discussion in 'Apple' started by papercut, Aug 13, 2007.

  1. papercut

    papercut Guest

    I was on my Mom's Mac Mini OSX 10.4.3 checking some email and found an
    odd problem. The only way to make an upper case "S" is to use the Caps
    Lock. "Shift S" Does nothing. Every other upper case letter works OK
    as normal.

    I thought it might be a hardware problem, so I tried a neighbor's Mac
    Keyboard, and the "Shift S" problem remained. Apparently, my Mom has
    been working around this problem with the Caps Lock key since she got
    the computer. I'm not much of a Mac person, did some snooping around
    for possible software problems, but came up short.

    My question is if anyone has any clue where to start fixing this
    problem. I'm guessing some kind of weird keyboard shortcut got set
    somewhere along the line. Perhaps this is just a simple thing, but it
    has me stumped.
     
    papercut, Aug 13, 2007
    #1
    1. Advertisements

  2. papercut

    A. Price Guest

    Your hunch about a weird keyboard shortcut sounds like a good one. Have you
    checked in System Preferences for all the places where shortcuts can be set?
    (type "Shortcut" in the search box)

    Have you installed any launcher utilities? (MenuMax, Butler, Quicksilver)

    -A
     
    A. Price, Aug 13, 2007
    #2
    1. Advertisements

  3. sS

    Mm. works fer me...
     
    The Natural Philosopher, Aug 13, 2007
    #3
  4. papercut

    A. Price Guest

    And does it happen in other accounts or in the login screen?
     
    A. Price, Aug 14, 2007
    #4
  5. papercut

    papercut Guest

    Lasts through restarts,however, problem doesn't occur in another
    account!

    At least that's a start!
     
    papercut, Aug 14, 2007
    #5
  6. papercut

    papercut Guest

    Very good leads so far. Thanks.

    Unfortunately, I cannot find any shortcut attributed to Shift-S on the
    Keyboard & Mouse Keyboard Shortcuts tab.

    However, I did notice some odd behaviors when pressing Shift-S.
    Sometimes (Not every time) when Shift-S is used, the "Edit" menu would
    flash, as if one of the commands under "Edit" were being used.
    Curious, I clicked on "Edit" once, making the menu drop and stick, and
    once again pressed "Shift-S". I did this several times. Interestingly,
    "Shift-S" seems to be activating the "Copy" command, but not every
    time! Very curious!

    I highlighted some text, pressed "Shift-S" until the "Edit" menu
    flashed, and behold, the highlighted text would in fact be copied.

    This quirk seems to work under several different applications. And
    again, only under this account.

    I can't seem to find any significant third party add-ons that might
    obviously cause this effect. And there were no unusual shortcuts
    listed under "Application Keyboard Shortcuts" in the Keyboard & Mouse
    System Preferences.

    That "Shift-S" works as a "Copy" shortcut globally, but not
    consistently, and NEVER as a upper case "S", is very odd to me. I'll
    try to dig around some more.
     
    papercut, Aug 15, 2007
    #6
  7. papercut

    Guest Guest

    Do both shift keys do this?
    Andy
     
    Guest, Aug 15, 2007
    #7
  8. This happens only one one computer, with any keyboard, but not on any
    other computer, with this keyboard, is that correct?

    Have you tried it using a different account on the computer it happens
    on? If so, what are the results?
     
    Michelle Steiner, Aug 15, 2007
    #8
  9. papercut

    papercut Guest

    You guys are awesome.

    I tried Cocktail. Deleted user cache files, restarted computer, and
    the problem persisted... but different. Deleted system cache files,
    restarted computer, and the problem persisted... but different.

    Now, pressing "S-Shift" with highlighted text no longer was activating
    the "copy" command. However, pressing "S-Shift" with highlighted text
    made the computer speak the highlighted text!

    So I went to the Speech preference panel, and found that the "Speak
    selected text when key is pressed" button was set to "S-Shift"! How
    this happened, I don't know. It never occurred to me to check the
    Speech controls for keyboard shortcuts. But this problem was easy to
    remedy.

    Now, "S-Shift" works as it's supposed to. Perhaps there were several
    simultaneous actions the Mac was trying to do when pressing "S-
    Shift", due to corrupted cache and stupidly set shortcut.

    All fixed. Thanks for all the hand holding.
     
    papercut, Aug 15, 2007
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.