Of Wacom tablets, terminals, serial ports, and adapters

Discussion in 'Apple' started by DaveC, Apr 25, 2010.

  1. DaveC

    DaveC Guest

    I have a USB-to-serial adapter on one of the USB ports connected to a serial
    port Wacom tablet. The Wacom is controlled via TabletMagic (opensource
    project) preference pane. The pane initiates a daemon when required (the user
    can enable & disable the daemon from within the pane).

    All was well until I tried installing a Wacom driver (there are no modern
    drivers for serial port tablets, but where's the fun in not experimenting?).

    Once I determined that the Wacom s/w didn't work I uninstalled everything I
    could find (a few files in Extensions and Application Support folders) that
    had names related to Wacom or Tablet. (There is nothing other than the pref
    pane associated with TabletMagic so there is no danger of getting too

    The tablet now doesn't work as it used to -- sometimes it is not recognized
    by the pref pane, sometimes it is but no data transfer takes place.

    I plugged a loop-back adapter to the USB-serial adapter and launched
    QuickTerm. (QT settings: 9600, 8/1/none & no handshaking.) The resulting text
    on the screen is good from between 160-250 characters. Then lock-up. Or
    outright crash.

    Any suggestion as to my next step would be greatly appreciated.


    Mac Intel Mini 1.83 GHz / 2 GB / 230 GB
    OS X 10.5.8
    TabletMagic 2.0b17d2
    Prolific-based PL2303 USB-serial adapter
    Source Forge PL2303 drivers 0.3.1
    DaveC, Apr 25, 2010
    1. Advertisements

  2. DaveC

    DaveC Guest

    I have 2 of the USB-serial adapters. Swapping the adapters doesn't change the

    DaveC, Apr 25, 2010
    1. Advertisements

  3. DaveC

    DaveC Guest

    Permissions repair and PRAM reset, no joy.

    DaveC, Apr 25, 2010
  4. Try another USB port? Spit on the connectors? Complete backup restore?
    Maybe not worth it......

    Anything serial port is ancient, and Wacoms aren't that expensive unless
    you're into the commercial sized ones.
    John McWilliams, Apr 25, 2010
  5. DaveC

    DaveC Guest

    I have a USB-to-serial adapter
    Problem solved.

    The solution proved to be much simpler than I thought: the Wacom (or the
    USB-serial adapter) doesn't like being plugged into a USB hub. Once plugged
    into one of the Mac Mini's ports, all is good.

    You might drag out that adapter from the closet. The drivers from Source
    Forge really are light years better than the ones by the chip manufacturer:


    Thanks to all,
    DaveC, Apr 26, 2010
  6. DaveC

    DaveC Guest

    If I ever find the time, there is actually one case where I'd like to
    The Keyspan has it's own drivers that -- according to Google ;-) -- seem to
    do just fine.

    Re. a comm utility, I found that CoolTerm does the best of the ones I've
    tried. Available at all the usual places.

    DaveC, Apr 27, 2010
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.