Older MB P4P800...is there a way to update bios without a floppy?

Discussion in 'Asus' started by dave, Jan 31, 2012.

  1. dave

    dave Guest

    I have no floppy drives anymore.
     
    dave, Jan 31, 2012
    #1
    1. Advertisements

  2. dave

    Paul Guest

    There are CDs you can use to boot DOS. For example, I think
    the Seatools for DOS package from Seagate, may use FreeDOS and a
    RAM based file system, to hold the tools they need. Not only
    does the Seagate CD image contain Seatools, it also includes
    FreeDOS to boot the computer with. The RAM based file system is
    used, as the application is compressed and needs to be extracted
    before it can be used. (Note - If using Seatools for DOS CD,
    disconnect your external USB hard drive enclosure. Mine has a
    Cypress chip and the Seatools CD managed to corrupt the
    Cypress chip config space info. That was easily fixed, using
    a recipe from the web, but it's better to just avoid that
    if possible. The Windows version of Seatools doesn't do that.)

    FreeDOS is a substitute for MSDOS.

    http://en.wikipedia.org/wiki/Freedos

    http://www.freedos.org/

    I've also seen references to DRDOS in the past.

    http://en.wikipedia.org/wiki/DR-DOS

    And this page gives an example of how you go about
    building an MSDOS boot CD. To give a better idea
    of the restrictions that the boot image maker is under.

    http://infocellar.com/CD/Boot-CD.htm

    Not every one of these things, works with every
    piece of hardware you can find. There can always be little
    issues to gum up the works. And re-mastering a CD image,
    isn't exactly that easy. On my Asrock motherboard, I spent
    the better part of a day, changing stuff on my MSDOS floppy,
    to work out the kinks. I'd hate to have to do that to a
    CD image.

    If your version of DOS is modern enough, it reads FAT32.
    Make sure there is a drive in the computer with at least
    one FAT32 partition, and put the BIOS flash file on that.
    I think I've done some flashing with the data file on
    C: in the root (where C: was FAT32). In the case of
    using some FreeDOS CD, you might also put the AFUDOS
    flasher program on your hard drive. In DOS, you can
    change drive letters, and then run the executable from the
    hard drive.

    There is even some software, that supports NTFS from DOS,
    but it is missing LFN (long file name support), which
    reduces its utility considerably.

    I'm sure you'll be able to cook up something :) There is
    plenty of junk available to play with.

    What I would do as a first step, is test your environment
    and see if you can back up the existing BIOS image. That
    would be a good first step when you get your boot CD running.

    *******

    Note that, the BIOS image is not a "constant". If you burn
    a new BIOS and the checksum is "abcd" and you boot the computer
    once, shut down and then make an archival copy of the BIOS from
    DOS, the checksum will have changed. The DMI/ESCD section
    gets overwritten by the BIOS during POST, with updated info.
    Only "sections" of the BIOS are immutable, not the whole thing.
    So if investigating your archived copy, and comparing it to
    an original file, be prepared for the DMI/ESCD section to be
    different. So when I suggest making an archival copy as a
    test, don't be surprised if the resulting file, doesn't
    match a copy on the Asus site. But the section that is the
    actual (read-only) BIOS code, should be the same.

    BIOS code (actually, a series of code modules, with names.
    Content is compressed and must be decompressed if you
    want to read it for some reason.)
    DMI
    ESCD
    Boot block

    *******

    Some of the Asus motherboards have three BIOS flashing options.
    But I suppose the issue in this case, is EZflash is looking for
    a floppy, and none is present.

    Always read any available warnings on the Asus download page,
    in the BIOS section. Some of the motherboards have pretty
    convoluted bugs, and workarounds. I don't know if the
    "release notes" section has survived the Asus web site
    redesign. The notes were helpful in avoiding the worst
    of the pitfalls.

    As an example of a crappy pitfall, some motherboards, if
    you use "CrashFree" BIOS recovery, and plug in the motherboard
    CD to install what you think is the "default" BIOS, the motherboard
    gets bricked :) And then you need to find some other means
    to flash the board (pull chip, hot flash or use an EPROM programmer).
    So when you see "Bad checksum", it isn't always safe to plug in
    the motherboard CD and allow the board to flash itself. Checking
    the release notes on the BIOS download page, may warn of stupid
    stuff like that, that they allowed to leave the plant.

    Even though they offer three BIOS flashing options, in some cases,
    two of the three methods are busted.

    HTH,
    Paul
     
    Paul, Jan 31, 2012
    #2
    1. Advertisements

  3. dave

    dave Guest





    Thanks for the detailed reply Paul.
    I made the Seagate bootable cd and it wouldn't boot, so I tried it
    in another machine....no problem! Obviously there are issues
    with the P4P800 machine. (I had been having problems and thought I
    would try to update the bios as it still had the original)
    Since that happened I started to swap out components and found a bad
    ram stick.
    So now I am still going to try to update the bios using your
    suggestions and will report back here if I can get it to work.
    Thanks again
     
    dave, Feb 1, 2012
    #3
  4. dave

    dave Guest

    I followed the instructions found here http://infocellar.com/CD/Boot-
    CD.htm and added the Aufdos.exe and the P4P1019.rom (new bios) to it.
    It boots just fine but there is no sign of those two files, just
    lists 24 files and 5 folders......looks like more work is needed!
     
    dave, Feb 4, 2012
    #4
  5. dave

    Paul Guest

    Could you install a hard drive with FAT32 partition on it ?

    Perhaps if Afudos.exe and P4P1019.rom were placed on a FAT32
    hard drive, you wouldn't need to remaster the Infocellar CD any more.

    When you get to the DOS prompt, just change drive letters, as in

    e:

    and then you'd be CD'ed into e: . Do a "dir" to see the contents.

    dir

    For more help with the ancient world of DOS, I like this page. This
    helped me a lot, when I was hacking my DOS floppy for the Asrock beast.
    On the Asrock, I had to "block off" some memory ranges, to prevent
    DOS from croaking.

    http://www.vfrazee.com/ms-dos/6.22/help/

    Paul
     
    Paul, Feb 4, 2012
    #5
  6. dave

    dave Guest

    Success!
    I put the aufdos and p4p1019 on a fat 32 partition created on my hdd.
    That partition label was "F". When I booted with the cd and tried to
    change to it, I got an invalid directory message. So I changed to "C"
    and there they were! I'm assuming it couldn't see the NTFS partition.
    From there I took your advice and ran aufdos to save a copy of the bios.
    It saved to the fat32 partition. At this point I stopped because I had
    already updated using the Asus Update utility that comes with the MB,
    (which I found by "reading the manual!!)
    So if I could run aufdos.exe to save a bios copy, I see no reason it
    would not update it too.
    Thanks for the help Paul.
     
    dave, Feb 6, 2012
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.