1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

OmniPass on MotionComputing LE1700 unable to "see" the fingerprint reader. Anyone seen the same?

Discussion in 'Tablet PC' started by Michael Moser, Feb 18, 2008.

  1. Hi all,
    I am struggling since a few weeks with the MotionComputing support, but
    they found no solution so far (other than suggesting a full system
    restore... ||-( ).

    For some reason too long to explain here, I had to de- and then
    re-install the OmniPass security SW that is supposed to control access
    to the tablet using the fingerprint reader.
    However, after the reinstallation, OmniPass doesn't "see" the built-in
    fingerprint reader any more. When - during the enrollment process - I
    try to select the fingerprint reader as authentication device to be used
    for logon, OmniPass tells me it couldn't find the device and that I
    should plug it in. :-(

    However, not only is the fingerprint reader plugged in and present (it's
    built-in!), it is also active and "working properly" (according to the
    Authentec device driver). In Control-Panel there is an applet, that
    allows to use the fingerprint reader as addintional cursor control or,
    alternatively, as scroll control device. Both modes work fine, i.e. I
    can control the cursor as well as do scrolling with the fingerprint
    reader, so the device obviously IS present and it is working fine.

    But for some strange reason, the OmniPass SW seems unable to locate
    and/or access the device. Anybody with similar problems? Or any hints or
    pointers?

    This is on an MotionComputing LE1700 running Vista Business. Could that
    be yet another Vista access rights problem?

    Michael
     
    Michael Moser, Feb 18, 2008
    #1
    1. Advertisements

  2. Michael Moser

    Chris H Guest

    Chris H, Feb 18, 2008
    #2
    1. Advertisements

  3. Michael,

    If you run the TruePrint application in Control Panel, does it report that
    the sensor is "Ready to Scan Finger"? If you swipe your finger at that
    point, does your finger print show up in the window?

    I'm also aware of a problem that can occur if OmniPass is removed without
    doing a complete uninstall and then re-installed. This can result in a
    corrupt installation. How did you originally uninstall OmniPass?

    I'll also pass this along to other developers and support people at Motion
    to see if there is a known issue and solution.

    -Reed Rinn
    MVP Desktop
     
    Reed Rinn - MVP Shell / User, Feb 18, 2008
    #3
  4. Michael Moser

    Chris H Guest

    Chris H, Feb 18, 2008
    #4

  5. Well, I *have* contacted the MotionComputing support before and they had
    escalated this to their supervisor but in the end the only suggestion
    was to do a recovery reload of the OS, which I find a a somewhat
    suboptimal solution, given that except for this Omnipass <==>
    fingerprint reader issue the system seems fine and stable. I rather
    suspect that there is some hickup in the Omnipass installer. If I could
    only find out, WHAT debris one needs to remove after an uninstall, then
    I could attempt another (re-)install...

    Michael
     
    Michael Moser, Feb 19, 2008
    #5
  6. Yes, it nicely shows my fingerlines, if I swipe my finger over the
    sensor. The applet also displays some sensor information, namely the
    chip version number and status: "Read to Scan Finger". And one can use
    it to enable cursor or scroll control. As mentioned, both modes work
    fine, if enabled. So - as mentioned - the fingerprint reader is
    definitely alive and kicking!
    Well, I have done, what I would call a "normal uninstall" (i.e. via the
    ControlPanel => Programs and Features => selecting OmniPass and hitting
    "uninstall").
    As already mentioned in my answer to Chris: I *have* contacted Motion's
    support but found the suggested solution a bit lacking. I am a person
    who tries to *fix* things rather than immediately reinstalling (I don't
    want to slash all the time that went into configuring the system the way
    I like it...).

    Michael
     
    Michael Moser, Feb 19, 2008
    #6
  7. Michael Moser

    Reed Guest

    Michael,

    Thanks for your responses. I work for Motion and will research this
    further. Please contact me at if you don't
    get this resolved.

    Thanks,
    -Reed Rinn
    MVP Desktop
     
    Reed, Feb 20, 2008
    #7
  8. Hi Reed,
    thanks a lot for taking this up! I really appreciate it.

    I strongly believe, that there must be some *detectable* reason, why the
    OmniPass SW is not "seeing" that device. And once we found out, why,
    then - I'm sure - it will be possible to fix this without need to
    re-install the entire machine...

    I mean: there are only a few possible reasons, why it is not seeing it:
    either it expects somethings that isn't there (some (registry-)entry, an
    API(-version), some description, or such) or it is there but it is
    already occupied or blocked by "something" (what could that possibly be?
    What other SW could hijack the fingerprint device???). The only other
    reason I can imagine is, that it is not *allowed* to see it (i.e. the OS
    blocks access for some reason or due to some policy). The latter is
    probably the fuzziest but IMHO also the most unlikely, since I haven't
    changed anything in that respect, since when it worked.

    If we only knew WHAT it is expecting to see, that would already be a
    large step forward...

    Michael
     
    Michael Moser, Feb 20, 2008
    #8
  9. Eureka - I did it! See, sometimes a friendly response is enough to
    stimulate new energies. ;-)

    I decided to give this another clean slate attempt but this time a
    REALLY CLEAN slate and to try again one more time:

    What I did was to de-install OmniPass again. Then I rebooted and then I
    started to repeatedly iterate through the entire registry and removed
    each and every entry that contained "Omnipass", "Softex",
    "Fingerprint(-Sensor)", "Authentec", "ATSwp" and "ATSC70".

    Only then - after a few more reboots and tests - I reinstalled OmniPass
    (which includes the Authentec stuff) and - voila - the beast is up and
    running again.

    That whole attempt was of course quite tedious (>2.5 hours) and required
    some care, but it was doable! So, if SW companies would provide
    de-installers that do a better job in cleaning up behind them and
    installers that are a bit more robust so they can fend off problems
    stemming from already existing stuff, the world would be a better
    place...

    Cheers,
    Michael
     
    Michael Moser, Feb 20, 2008
    #9
  10. Michael,

    Thanks for the update. I'm glad you were able to resolve your problem with
    OmniPass.

    I will report this back to Softex, our software vendor for OmniPass.

    -Reed Rinn
    MVP Desktop
     
    Reed Rinn - MVP Shell / User, Feb 21, 2008
    #10
  11. Michael Moser

    Paul Smith Guest

    I've been struggling with Omnipass for as long as I've had the machine.

    Installed it with the old version 5.xx.xx.53M or something. Everytime I've
    tried moving to the new version 67M, it would stop seeing the fingerprint
    reader, forcing me to go back, I've probably tried two or three moves,
    trying out different things to get it working with no success.

    Throughout the SP1 beta, and through System Restore operations I'd get
    duplicate logins on the Welcome screen - or worse, no login at all, forcing
    me to deal with deleting, importing and exporting registry keys to get
    around it.

    There's also the odd time where it won't wake up from sleep, forcing me to
    login the old fashioned way.

    Also today I narrowed down an issue I've been having with the system to
    Omnipass. IE7 and other applications hanging for up to a minute when
    requesting something over HTTPS, I assume this is the high-CPU usage issue
    mentioned in 67's release notes, so I decided to try again.

    After seeing this post I decided to do what Michael did and purge the
    registry of everything related to it, including the Authentec stuff which I
    hadn't tried before. But alas I must admit defeat as now Windows won't see
    the fingerprint reader at all.

    So I've got two options it seems. Re-image from a backup (if System Restore
    won't get me out of this), and live with the hanging IE7 issues, waking up
    problems etc. Or reinstall the system, and hope the new version does
    actually address these issues and I haven't wasted my time.

    I think Motion need to pressure Softex to do something about this, this is
    absolutely unacceptable for any non-technical person to deal with. I'd also
    like to see Motion offer a slimmed down solution, for people like me and I
    expect a great many other people who only want a fingerprint reader for
    login (I disable from running on the desktop). High quality, small
    application that only deals with the welcome screen.

    --
    Paul Smith,
    Yeovil, UK.
    Microsoft MVP Windows Shell/User.
    http://www.dasmirnov.net/blog/
    http://www.windowsresource.net/

    *Remove nospam. to reply by e-mail*
     
    Paul Smith, Feb 23, 2008
    #11
  12. Michael Moser

    Reed [MVP] Guest

    Paul,

    Thanks for this information. I'll take this up internally at Motion. Can
    we contact you directly about this?

    -Reed Rinn
    MVP Shell / User
    Motion Computing, Inc.
     
    Reed [MVP], Feb 25, 2008
    #12
  13. Michael Moser

    Paul Smith Guest

    Of course, presently Omnipass has been removed and it wakes directly to the
    desktop. Not as secure as I'd like. ;-)

    --
    Paul Smith,
    Yeovil, UK.
    Microsoft MVP Windows Shell/User.
    http://www.dasmirnov.net/blog/
    http://www.windowsresource.net/

    *Remove nospam. to reply by e-mail*
     
    Paul Smith, Feb 25, 2008
    #13
  14. Michael Moser

    zene

    Joined:
    Apr 11, 2011
    Messages:
    1
    Likes Received:
    0
    Hi.
    I'm new here, but i was just reading this, trying to find a solution for myself.
    I had the same problem.
    My fingerprint reader was just sometimes found, other times it wasn't.
    I finaly did resolve the problem, installed omnipass, and it installed the driver.
    Reebot, no driver found.
    I downloaded the similar driver from HP.
    Installed the HP driver, and voilá.
    Now i have fingerprint reading again.


     
    zene, Apr 11, 2011
    #14
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.