1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

OpenGL failed to initialize -- Problem Solved!!! well kind of solved.

Discussion in 'Nvidia' started by Jose Jiminez, Jan 12, 2004.

  1. Jose Jiminez

    Jose Jiminez Guest

    I posted the following info in mid December.
    I tried many things including repairing my Windows installation, using
    the original drivers for the video card (as well as others that I
    downloaded from the Nvidia driver archive), changing resolutions, etc.
    I DIDN'T FORMAT AND DO A FRESH INSTALL!!
    I do have the latest Nvidia drivers installed, now.

    Then I discovered something very interesting. Read ahead.

    I have 2 user accounts set up on my PC.
    My son and I each have our own desktop.

    When I boot up the computer and log onto either desktop, I have
    problems with Opengl. Apps that need Opengl won't run and SiSoftware
    Sandra OpenGL module says, "Opengl failed to initialise".

    Now then, if I simply log off the user account and log back onto it or
    onto the other user account, voila!

    Opengl works properly!!!

    I'm totally clueless as to why this happens. If I restart the
    computer, I have to do the "log on, log off" thing to get Opengl
    running right.

    It's a minor inconvenience to have to do this, but now we can run the
    games and apps that weren't working.

    I know that I saw some posts in this group regarding the same problem
    that I have. If any of the affected posters read this and try the
    solution that I am using, I'd be interested in hearing from you with
    your take on the problem and whether you were able to get the same
    results that I did.

    Anyone having an explanation why my solution works for me? I'd like to
    hear it.

    Peace.
    Jose
     
    Jose Jiminez, Jan 12, 2004
    #1
    1. Advertisements

  2. Jose Jiminez

    Kent_Diego Guest

    I had a funny problem fixed by log off log on. My SysTray icons would not
    all show up at startup. I had to disable UPnP service, Universal Plug and
    Play (not Plug and Play), to fix. It is not needed, see if this fixes your
    problem and post back. Run msconfig>services and uncheck.

    -Kent
     
    Kent_Diego, Jan 12, 2004
    #2
    1. Advertisements

  3. Jose Jiminez

    Jose Jiminez Guest

    I haven't tried your idea because I think I got to the crux of the
    matter.
    I restarted my computer and took note of all the running processes in
    Windows Task Manager.
    Then I logged off and logged on again (without restarting) and took
    note of all the running processes in Windows Task Manager.

    After comparing the 2 lists, I found an application (Matlab) running
    in the background that was only there when I did a restart. When I
    logged off and then on, the application was not running anymore. I'm
    not sure why it was running. Might have been a bad install.

    So I restarted the computer and looked at the Windows Task Manager
    again. The app was running again and Opengl failed to initialize. So I
    ended the process in the Task Manager and tested Opengl again and it
    works!!
    I've uninstalled the application and my system now functions normally.
    I'm going to reinstall the app just to see if the problem reappears.
    I'll post my results as soon as I can.

    Jose
     
    Jose Jiminez, Jan 12, 2004
    #3
  4. Jose Jiminez

    Kent_Diego Guest

    Just Start/Run msconfig to disable matlab at startup.

    -Kent
     
    Kent_Diego, Jan 13, 2004
    #4
  5. Jose Jiminez

    Jose Jiminez Guest

    I don't know why it loads at all. When I killed it from the Task
    Manager, then went to the Matlab folder and clicked the command line,
    the app opens up properly. And Opengl works, too. Matlab is not
    supposed to run in the background.
    Anyway, I uninstalled it and I'll try to reinstall just to see what
    happens.
    Thanks, Kent.
    Jose
     
    Jose Jiminez, Jan 13, 2004
    #5
  6. Jose Jiminez

    Rohan Parkes Guest

    I'd forgotten, but I used to have that problem too, and solved it the
    same way. It also used to prevent my screensaver, and stop my PC from
    going into standby.

    I seem to recall that Universal PnP was considered to be a huge security
    hole, and users were encouraged to disable it for that reason.
     
    Rohan Parkes, Jan 13, 2004
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.