OS X panther IP address keeps changing

Discussion in 'Apple' started by Mark, Jun 22, 2004.

  1. Mark

    Mark Guest

    Hi everyone I've just bought my first iMac (PC switcher :) ). And whilst
    every thing is ok now and then I can't get on the net. When I check the IP
    address it has changed to one other than that assigned by my routers DHCP.

    The only way it seems is to turn the router off and on again. Any ideas why
    this is ? My network setting are as follows:

    Config IPv4 = Using DHCP

    The ip address subnet mask and router IP are all correct initially as they
    are connecting with the DHCP on the router.

    DNS servers = blank Search Domains = blank

    Config IPv6 = automatic

    Eventually after a while I'll find I can't get online and notice that the IP
    address has be assigned one internally. I can't even ping the router.

    Can anyone help ?

    Mark

    Sent using the Microsoft Entourage 2004 for Mac Test Drive.
     
    Mark, Jun 22, 2004
    #1
    1. Advertisements

  2. Mark

    Bob Harris Guest

    What version of Mac OS X? There was a DHCP lease problem in Mac OS X
    10.2.something (forget which dot dot version). The solution was to
    upgrade to the latest and greatest I think, or use a fixed IP address.

    If you are using Panther (Mac OS X 10.3.*) I do not know of any issues
    with DHCP (but then again, I've mostly using fixed IP addresses at work
    and at home :)

    Since it is your own home network, you could setup your Mac to use DHCP
    with Manual IP address. This should allow the DHCP server to provide
    router and DNS information, while you just pick an unused IP address in
    your home networks range. You can look at your Router and see what
    range of addresses it is serving for DHCP and pick and address just
    outside the range.

    While having a fixed IP address allowed me to avoid the DHCP problem in
    10.2.*, it was not the reason I used a fixed IP address. I used a fixed
    IP address because it made it easier for me to do things like route
    incoming SSH (port 22) connections to a specific home Mac, it made it
    easier to make point to point connections between different Macs at home
    using things like ssh, ftp, etc... So my reasons were outside of the
    DHCP, it just happened to benefit me at the time. At work I run a
    company assigned fixed IP address because I currently host a personal
    web page on my office Mac, and earlier I got hit by a rouge Linksys
    router someone setup on the network that the network admins did not know
    aobut, and it was distributing 192.168.1.* DHCP addresses that my Mac
    grabbed instead of from corporate DHCP server. Having them give me a
    fixed IP address got me back on the air, while they chased down the
    source of rouge Linksys.

    Bob Harris
     
    Bob Harris, Jun 22, 2004
    #2
    1. Advertisements

  3. Mark

    Obfus Kataa Guest

    I have had this problem with new LinkSys routers. The solution was to
    upgrade the router's firmware. The problem would occasionally appear with a
    Windows PC connected to the router. I have also seen it where the Mac is on
    a network that has 10Mb devices. It looks as if the Mac is just impatient
    waiting for the slow DHCP to respond (assuming your machine has a Gb network
    card). The PC on the next desk would wait longer for its address--seconds
    longer. I have switched to hard-coded IP for my PowerBook, but that is
    mainly so I can keep the same IP on which ever network I use.
     
    Obfus Kataa, Jun 22, 2004
    #3
  4. Mark

    Mark Guest

    The OS is version 10.3.4. I have tried using a fixed ip but it still
    happened, I think. Or I tried inputing a fixed but still couldn't connect,
    and had to switch off the router.

    Would the console log files help ? If so what log file should I look at ?

    Mark

    Sent using the Microsoft Entourage 2004 for Mac Test Drive.
     
    Mark, Jun 22, 2004
    #4
  5. Mark

    Mark Guest


    I have a windows PC hooked up to the router and this seems un affected.

    If the router is only 10mb would this affect it ?

    Mark
    Sent using the Microsoft Entourage 2004 for Mac Test Drive.
     
    Mark, Jun 22, 2004
    #5
  6. Mark

    stan Guest

    Look at all the log files. What it help? Why would it hurt to look at
    the log files? When in doubt, the log files are the first place to look.
    If you see any errors, google them.
     
    stan, Jun 22, 2004
    #6
  7. Mark

    stan Guest

    No, but it sure can't hurt to check Linksys's web site to
    see if they have any trouble shooting tips.
     
    stan, Jun 22, 2004
    #7
  8. What number is it changing to?

    if its 169.254.xx.yy then there is a problem between the Mac and the
    DHCP server, wrong language, wrong duplex/speed settings for ethernet,...

    When the Mac times out a DHCP request it will assign itself a 169.254.x.y
    number, which normally won't go thru your routers, switches, etc.

    I always used fixed numbers. Sure it's a little more hassle to setup,
    but then it stays setup, until I change it...
     
    J.Random Luser, Jun 22, 2004
    #8
  9. Mark

    Marky B Guest


    Yes but if it's been assigned an address ie 10.0.xx.xx from the DHCP in the
    first place router why would it change ? As far as I know it's not a time
    limited lease.

    If the mac lost contact with the router for a certain period of time would
    the mac assign itself a new IP ?

    Mark
     
    Marky B, Jun 23, 2004
    #9
  10. Mark

    Clark Martin Guest

    All leases are time limited. Once it has the IP the computer will then
    (typically) try to renew the lease when half the lease time has passed.
    If at this point it has trouble connecting with the DHCP server you can
    get the 169.... address.

    Basically the 169 address is a feature of DHCP so that in the event no
    DHCP server is located a randomly selected IP address is setup. It's
    designed so that if there is no DHCP server as in an ad hoc wireless
    network the machines can still contact each other.

    Aside from the obvious such as a bad wireless connection this problem
    can be caused by a poorly designed DHCP server. Unfortunately it isn't
    rare.

    I'd definitely looking at updating the firmware on the router. Or if
    none is available consider replacing it, they are so cheap now.
     
    Clark Martin, Jun 24, 2004
    #10
  11. Mark

    Marky B Guest

    Well I managed locate the router update firmware, so I'll see what happens.
    My router is fairly old it's an Alcatel 510 v3.7. Although I've never had any
    probs with it on my win PC I also use my Xbox through it.

    Anyway many thanks.

    Mark
     
    Marky B, Jun 24, 2004
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.