P4B533-E / WinXPSP1 / USB 2.0 'non-hi-speed usb hub' problem - Please Help!

Discussion in 'Asus' started by Quixotic1, Jan 21, 2004.

  1. Quixotic1

    Quixotic1 Guest

    Hello:

    Here's the issue. I have P4B533-E. I have tried the 1014 Bios and the
    1015.003 beta bios. I have installed XP gold from scratch and used the
    original 2.0 driver sets; I have tried SP1 on top of that; I have
    tried clean install of SP1 slipstream. No matter what I do, I get the
    following problem:

    1) All 6 USB ports work, but in 1.1 only.
    2) When I plug in my external HDD which is 2.0, and tested OK on a
    different system, I get the following error, no matter which of the 6
    ports I plug into. "Hi-Speed USB Device Plugged into non-HI-Speed USB
    Hub"
    3) I do not get the reported problem of working/not working on the
    HDD. It works consistently, just only in 1.1, at 12Mbps.

    In my Device Manager, I see the following under the USB section:

    Intel(r) 82801DB/DBM USB 2.0 Enhanced Host Controller - 24CD
    Intel(R) 82801DB/DBM USB Universal Host Controller - 24C2
    Intel(R) 82801DB/DBM USB Universal Host Controller - 24C4
    Intel(R) 82801DB/DBM USB Universal Host Controller - 24C7
    USB 2.0 Root Hub
    USB Root Hub
    USB Root Hub
    USB Root Hub

    As far as I can tell, this is what I should be seeing. No bangs, no
    red X's. Looks fine.

    When I plug in my 2.0 HDD, it shows up as being listed in one of the
    standard USB Root Hubs, and when I look in the 2.0 Root Hub, it shows
    that all 6 ports are available...This is odd to me, because I do not
    have 12 ports available on my system...???

    In the BIOS: (by memory)

    USB Legacy - Enabled (supposedly, this setting makes the system turn
    on USB always, instead of looking for plugged in devices. Changing
    this setting doesn't change my problem)
    USB 1.1 Controller - 3 Controllers (if set to disabled, then 2.0 is
    also disabled, and I get no USB support at all in XP)
    USB 2.0 Controller - Enabled
    USB 2.0 Reference Voltage - Medium (changing it up or down doesn't
    matter)

    Rebooting the system with the 2.0 HDD plugged in already, doesn't make
    a difference.

    I've used Sandra to confirm that the USB device is indeed running at
    12Mbps, and not at 480.

    Please help me. This is driving me nuts.

    Thanks for your interest,

    Dave (Quixotic1)
     
    Quixotic1, Jan 21, 2004
    #1
    1. Advertisements

  2. Quixotic1

    Paul Guest

    This page talks about "refreshing the driver stack". Maybe deleting
    the USB entries in the Device Manager and rebooting, will let the
    OS rediscover and reload drivers:

    http://www.usbman.com/USB 2 News.htm

    Otherwise, your Device Manager entries look reasonable. As I understand
    it, there are effectively two sets of hardware macros in the chipset.
    For USB1.1, there are three controllers, each terminating two interfaces.
    So, two interfaces share the 12Mbit/sec max available on one USB1.1
    controller. A fourth controller is wired to all six interfaces at
    the same time, and it does USB2 at 480Mbit/sec. If six USB2.0 devices
    were to be plugged in, the total bandwidth provided cannot
    instantaneously exceed 480Mbit/sec over all six ports.

    At runtime, a decision is made whether a given plugged-in device
    should be "bound" to the respective USB1.1 controller or to the
    USB2 controller. So, the controllers work in parallel, and the best
    one for the job is used. Drivers are loaded to cover both cases,
    as hot plugging is supported.

    HTH,
    Paul
     
    Paul, Jan 21, 2004
    #2
    1. Advertisements

  3. Quixotic1

    Quixotic1 Guest

    On Wed, 21 Jan 2004 14:03:35 -0500, (Paul) wrote:

    snip ------------>

    Yes, I've been to this page. I have tried to do this, in all of the
    setup situations I've described. Still, no smiles.


    I think I finally came to this conclusion about the 'structure' of the
    two controller types, although your write-up really makes it quite
    clear to me.

    So, you can see that while I am convinced that everything looks like
    it's supposed to, I just can't get this extHDD to go into 2.0 on this
    system.

    I've tried to set this ext. drive up in my Win98SE partition, and
    while I didn't get this message, I wasn't able to see anything at all.
    So, I might go and spend a liitle more time fiddling in 98, just to
    see if this is a HW or XP driver issue. I'd really prefer not to go
    buy a 2.0 card.

    Any more suggestions out there?

    Thanks again,

    -Dave (Quixotic1)
     
    Quixotic1, Jan 22, 2004
    #3
  4. Quixotic1

    Paul Guest

    For Win98SE, you can use this driver for USB2.0:

    ftp://ftp.asus.com.tw/pub/ASUS/misc/usb20/owich4usb2v1_03.zip

    http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&selm=nospam-1708031106410001@192.168.1.177

    Paul
     
    Paul, Jan 22, 2004
    #4
  5. Quixotic1

    gb Guest

    You said that you installed the original 2.0 driver set. Did you install
    the USB 2.0 driver from ASUS? It is not needed with XPsp1. If you
    installed both, maybe that's something to look at -- a conflict or
    corruption?. I have a P4B533-E and XPsp1, recently enabled USB2.0, and
    it's working fine. Good luck.

    gb
     
    gb, Jan 22, 2004
    #5
  6. Quixotic1

    Quixotic1 Guest

    GB -

    Thanks for the info. Yes, I've tried XPSP1 freshly installed, and was
    not successful. So, I am quite confident that I haven't installed
    multiple drivers on top of each other. I've gone so far as to create
    images of XPgold and XPSP1slipped in their post-install states... No
    drivers installed. In other words, right after the 'first boot.' This
    way, I can quickly go back and forth for testing new ideas.

    I'm curious about several things you mentioned...

    1) Do you by any chance know what board revision you have? I have rev
    1.02.

    2) What BIOS version are you using?

    3) Are you successfully using 2.0 peripherals, or is 2.0 simply
    enabled on your system? In other words, have you actually successfully
    connected a 2.0 periph?

    When you were successful, what version, if any, of the Intel inf
    drivers were/are you using? I'm not even sure if they are necessary in
    SP1.


    Thanks,

    Dave (Quixotic1)
     
    Quixotic1, Jan 23, 2004
    #6
  7. Quixotic1

    Quixotic1 Guest

    Hello all:

    I've tried going into Win98SE, with the latest Orangeware drivers,
    installed, and all looking correct in DevMan. Unfortunately, transfers
    to the external HDD were frighteningly slow, and Sandra reported that
    transfers were running at 12Mbps.

    So, there seems to be something going on with hardware/bios
    setup/jumpers? Dunno. Anymore thoughts? This is killing me.

    -Dave (Quixotic1)
     
    Quixotic1, Jan 23, 2004
    #7
  8. Quixotic1

    gb Guest

    Dave,

    In response to your questions:
    1. I have the rev.1.02 also.
    2. BIOS is 1014.
    3. Yes I am able to connect 2.0 peripherals without problem.
    4. I am running ver 4.00.1009 of the Inf drivers (from the original CD). I
    hadn't realize there was a new version until I went to check in order to
    respond to you. While I'm not certain, I don't recall seeing anything that
    would suggest they should not be used with XPsp1.

    You may want to check out the following links:
    http://support.microsoft.com/default.aspx?scid=kb;en-us;Q312370
    http://support.microsoft.com/default.aspx?kbid=813926
    Apparently, the condition you describe was addressed in a hotfix or XP
    Service Pack 1a. Maybe your sp1 doesn't have the hotfix included.
    Interestingly when I follow the directions to check my version, I either
    find nothing or references of "SP2". Go figure.

    For what it might be worth: I originally installed XPsp1 with USB2.0
    disabled in the bios because, at the time, I had no 2.0 devices. It was
    later that I enabled 2.0 in the bios and XP properly dealt with it at that
    time.

    Good luck again.

    gb
     
    gb, Jan 24, 2004
    #8
  9. Quixotic1

    Creu Guest

    I had the exact same problem... All device manager info led me to
    believe that all was ok, but I was still getting the 'non hi-speed
    usb' error.
    I searched the newsgroups for three days & tried alot of things to no
    avail, until I simply re-installed the driver under usb controllers
    tab in device manager. Whoa-la!

    I hope I don't insult your intelligence by assuming you did not yet
    try this :eek:)
    Paul
     
    Creu, Jan 27, 2004
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.