P4P800 Deluxe ... the 4 back USB ports are not functioning ... Please HELP!!

Discussion in 'Asus' started by Victor, Dec 8, 2004.

  1. Victor

    Victor Guest

    Any insights?
    Victor, Dec 8, 2004
    1. Advertisements

  2. Victor

    Paul Guest


    I just did a test. Guess what ? Two of my ports on the back
    of my P4C800-E were "dead". I plugged a USB mouse into the ports,
    and the light on the mouse did not come on.

    How I fixed it:

    Go into Device Manager and check for USB entries.

    "Intel (R) 82801 USB Universal Host Controller - 24D2"
    "Intel (R) 82801 USB Universal Host Controller - 24D4"
    "Intel (R) 82801 USB Universal Host Controller - 24D7"
    "Intel (R) 82801 USB Universal Host Controller - 24DE"
    "Intel (R) 82801 USB2 Enhanced Host Controller - 24DD"
    "USB Root Hub" (Repeated five times)

    The first four devices, are USB1.1 . Each device is a software
    construct that controls two USB ports. These ports will be in
    the same connector stack. Thus, the first four line in the
    quote above, control eight USB jacks. Some of the jacks are
    on the back of the computer, while the other jacks require
    installation of adapter plates which may not be included in
    the motherboard box.

    The fifth line is important. The word "Enhanced" implies
    USB2. Enhanced as in EHCI driver. The Universal ones are
    UHCI driver. The device on the fifth line is a software
    construct that controls any USB port that wishes to run
    at USB2 rates.

    The five lines which might appear below that, say USB Root Hub.
    These are a software construct for controlling the power to
    each set of ports. Windows can turn them off to save power, and
    if the USB ports on your computer are not being used, then not
    all of the five "USB Root Hub" lines might be there.

    In my case, the "broken" USB ports showed up as one of the
    USB entries in the Device Manager having a red "X" through it.
    Checking the status of that line in the Device Manager, said
    the device was disabled and had a status of 22 (whatever that
    means). I clicked the "enable" box, and the two "broken" ports
    started to work. When I plug in a USB mouse now, the mouse LED
    lights up on those two ports.

    If, when you look in Device Manager, you don't see the 24DD
    device, then you may need to install a Service Pack for the OS.
    I think you would need at least SP1 for WinXP and SP4 for Win2K.
    For Win98se, you would need an Orangeware driver, and these are
    sometimes provided by the chipset maker (Intel in this case, but
    you could also check the Asus download page for them). They
    won't be listed as Orangeware, but Orangeware is the company
    who writes USB2 drivers for Win98 for Intel/Via/etc.

    If, after installing the Microsoft Service Pack, the Device
    Manager still doesn't have the line above listed, follow this
    procedure. Basically, you delete the entries in the Device
    Manager, while in Safe Mode, and then on the next reboot,
    Windows will discover the "new" ports, and use the drivers
    included in the Service Pack you just installed.

    http://www.usbman.com/Guides/Cleanup Device Manager Safe Mode.htm

    The picture at the bottom of this page, shows a computer using
    an Intel Southbridge, plus the user of the computer must also
    have installed a USB PCI plugin card as well. There are more
    entries than normal in this picture, but it gives an example
    of what they look like.


    After you are finished all of this, I hope when you plug in a
    USB mouse, it lights up like mine did.

    Paul, Dec 8, 2004
    1. Advertisements

  3. bios settings?
    Niclaas Grehling, Dec 8, 2004
  4. Victor

    Victor Guest

    Checked and re-checked.
    I even tried to update 865 chipset ..and updated the BIO and then
    checked it again.

    Victor, Dec 9, 2004
  5. Victor

    Victor Guest

    I checked the Device Manager and all USB entries look correct...with
    no indication that anything is wrong ... all lines including the USB
    Root Hub is accounted for.

    I'm going to remove all entries and see if XP finds them again.
    PS all BIOS info has been checked.
    Victor, Dec 9, 2004
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.