P5LD2 strange problem with SATA drives

Discussion in 'Asus' started by WhiteStar, Jun 28, 2006.

  1. WhiteStar


    Jun 27, 2006
    Likes Received:

    Probably someone will be able to help me. I have Asus P5LD2 motherboard with two SATA drives and one IDE drive. Due to a lack of space, I have installed OS on the IDE drive (damn slow, but works).

    The issue is very strange, so I will try to explain step by step:
    1. When the computer turned on and BIOS scans SATA drives, it shows both and then just stuck on BIOS screen (no keyboard, just nothing but reset)
    2. I have tried to eliminate the issue and disconnected all drives, so BIOS reports of no hard disks found and just requires for the OS.
    3. I have plug the IDE drive back and everything started without any problem.
    4. I have plugged one of SATA drives and BIOS stuck immediately after scanning it.
    5. I have plug another SATA drive instead with the same result.
    6. Last final try: I have turned off all SATA drives from the BIOS - just put them to "Not Installed" mode and BIOS did not recognize any of them, booted with my IDE disk and (oh my!) inside Windows I SEE ALL DISKS!!!

    It was such a big luck, that at least in this mode everything is working, but as you can imagine, I would like to resolve the issue - installing OS on SATA drive will make things work much quicker.

    What else could be done? I have the latest versions of ASUS mother board BIOS (1103). Most recent change was the graphical card - I have now new GeForce 7600GS, but I do not have other card to test the system with.

    I will appreciate any help! Thank you in advance!
    WhiteStar, Jun 28, 2006
Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.