P5Q Deluxe ESATA Question

Discussion in 'Asus' started by me, May 7, 2011.

  1. me

    me Guest

    I enabled the Marvel in the bios and I turn the external ESATA drive on
    before booting and it works fine. If the drive is off at boot and I turn it
    on after booting the drive won't show up. Is this the way it should work?
    Is there no way to leave the drive off until you need access to it? Thank
    me, May 7, 2011
    1. Advertisements

  2. me

    Clas Mehus Guest

    Is AHCI for the Marvell-controller enabled in the BIOS?
    Clas Mehus, May 7, 2011
    1. Advertisements

  3. me

    Rob Guest

    Take a look at the 'Hotplug' tab of your Marvel 61xx properties
    in Device Manager. Make sure 'Enable' is checked for all ports.
    If you don't see the Hotplug tab, try updating to the latest
    drivers from Marvel.
    FYI, I have a P5Q Deluxe and hot-plugging e-sata drives into
    the rear panel port works fine in XP. Drives appear in the
    Safely Remove Hardware list from the status bar icon, just
    like external USB drives do.
    Rob, May 9, 2011
  4. me

    me Guest

    I have enabled the Marvel controller but never thought to check the
    properties. I will do that and I thank you for the help! Much appreciated!
    me, May 10, 2011
  5. me

    me Guest

    If I understand correctly I need to enable marvel in bios then in device
    manager Enable "Hotplug"? BTW, I do have all drivers installed correctly.
    me, May 10, 2011
  6. me

    me Guest

    I enabled the Marvel IDE in Bios and when machine boots the Marvel Boot Rom
    displays the drive as long as it is on and the drive works but no status
    bar icon appears like it does with a usb drive. I can't find Marvel in the
    device manager. Where would it be? Thanks.
    me, May 10, 2011
  7. me

    Rob Guest

    It will be under "SCSI and RAID Controllers" listed as
    "Marvell 61xx RAID Controller". Just right-click and
    select Properties and you should see the Hotplug tab.
    If still no-go, you probably need to install new drivers.
    The ones you want are under the SATA section for the P5Q deluxe
    at support.asus.com - you want "Marvell 6121 SATA Driver
    v1.2.0.68 for Windows XP.."
    This link may work, if not start from home page and manually
    select Motherboard, Socket 775, P5Q deluxe and WinXP.

    Rob, May 11, 2011
  8. me

    me Guest

    BTW, I am using XP 64 Bit and reinstalled the driver, enabled marvel ide in
    bios but not raid controller/Marvel appears in device manager. When I
    installed XP I believe the bios is set sata in ide mode or something like
    that. I tried changing a setting to AHCI but got a blue screen and changed
    it back and it boots fine, so I assume I didn't hurt anything. Is there
    some other Raid driver/bios setting etc that I need to do also? I know
    quite a bit about the system I built but I have never used Raid and don't
    know about the settings etc. I really appreciate you trying to help me
    here. Thanks.
    me, May 11, 2011
  9. me

    Rob Guest

    This motherboard has 3 hard drive controllers. You would normally
    have your boot drive and any other internal SATA drives connected
    to the the Intel ICH10R SATA ports (See p2-29 of the manual.)
    Most folk don't use the SIL5723 (EZ) ports (p2-30) and I recommend
    you avoid using those sockets completely.
    The 3rd controller is the Marvell 88SE6121 which controls the
    40-way PATA (IDE) ports and the e-SATA port on the back, which is
    the one we are trying to use.
    The Intel controller can be left in whatever mode you used when
    you installed XP64 - you don't need to change to AHCI or RAID on
    that one (that option is in the Main BIOS page under Storage
    Configuration and only applies to the Intel ICH10R Controller.
    Chenges here will have no effect on the Marvell controller.)

    All you need to do is enable Marvell IDE in the BIOS and install
    the driver for the Marvell controller. There is no option to select
    AHCI or RAID on this controller in the BIOS. When the Marvell is
    enabled in the BIOS, it will always appear under "SCSI and RAID
    Controllers" in Device Manager, regardless of any other BIOS
    settings, as far as I can tell.

    Basically, if you have installed the drivers I linked to, it should
    'just work' when you enable 'Hotplug' in the Marvell driver

    If you plug an external e-Sata drive in, after the system has started,
    can you see it in Windows explorer? If you can but it doesn't appear
    in 'Safely Remove Hardware' in the Status bar, it may be that XP64
    doesn't support that - I have no way of knowing as my system is
    running XP32.
    If you can only see it if it was plugged-in before you booted, then
    either the Marvell drivers aren't installed properly, you haven't
    enabled 'Hotplug' in the Marvell drivers Properties page in Device
    Manager, or XP64 just doesn't support this feature.
    Rob, May 12, 2011
  10. me

    me Guest

    In the bios the storage configuration is set to "enhanced"
    and "configure SATA is set to "IDE".

    When I enable the Marvel I do get the Marvel Boot ROM on screen and it
    detects the drive as long as it is powered up when I boot but still no
    Marvel appears in device manager. If the drive is not on the Marvel ROM
    detects no devices. When booting with drive powered it shows in windows
    explorer but when I shut it down it still shows it but maybe that is

    I have installed the correct driver a few times now and since the drive
    works if powered up first I would assume there is a glitch in the XP X64
    driver. I checked the Marvel site and cannot find any updated info for X64.

    BTW, SATA 1 shows my Seagate 1.5t drive, SATA 2 shows one Asus DVD burner,
    and SATA 3 shows my other Asus burner. I built this system a few years ago
    and it's had zero problems except for the ESATA issue. It is really no big
    deal because I have my two externals connected via USB and they work great
    but I would like to connect another drive to the ESATA port if possible. Is
    there anything else in my bios settings that may not be correct? I am going
    to keep trying to get that darn Marvel controller to show in device
    manager. Should I have the Marvel Boot Rom enabled or not or does that
    matter? Thx.
    me, May 12, 2011
  11. me

    Rob Guest

    I have the Marvell boot rom enabled on my system. I don't think it
    matters though.
    One more thing to try and find the controller in Device Manager:
    Change the view to 'devices by connection' and expand the items.
    On my system, the Marvell 61xx adapter is found under:
    Intel(R)ICH10 Family PCI Express Root Port 5
    If you find it, you should find the Hotplug tab in its Properties.
    If you find it and there is no Hotplug tab in it Properties, it
    probably means XP64 can't use the feature.
    As a last resort you could try 'update Driver' and point it to the
    folder where you extracted the driver you downloaded earlier, just
    in case Windows is still using an old driver for some reason.
    That controller *must* be there somewhere, or you wouldn't be able
    to see the drive even when it is powered when you boot!

    Rob, May 13, 2011
  12. me

    me Guest

    I checked again and cannot find it. I even reinstalled the driver and still

    Remember I told you I enabled the AHCI and got a blue screen? Well, the
    system works just fine when I changed it back but I noticed that HD Tune
    and xp disk management showed a "Disk 0 8GB". I googled it and found out
    that Asus Drive Expert was enabled on my system and when I disabled it the
    8gb drive is gone and system still runs perfect. Do you know what may have
    caused that drive to show up? BTW, when I went to XP disk management the
    screen to initialize it popped up. Should disk management be enabled and
    did i do anything to my system because of the 8gb disk 0 showing up? I am
    worried that I may have caused something.

    Also, I am going to power up the esata drive before I boot then check the
    device manager for the marvel. Otherwise I have come to the conclusion that
    hot plugging will not work for XP 64 bit. Thank you Rob.
    me, May 15, 2011
  13. me

    me Guest

    I think I have solved the problem! The marvel was installed in start
    menu/programs and I uninstalled it. I rebooted and reinstalled the driver
    and it works and I see it listed under SCSI/Raid controller in device
    manager. Hotplug is enabled on the first two ports. I did notice in the
    bios that when I installed the driver it must have modified the bios
    because marvel IDE was enabled again and boot rom was off, and it was
    disabled before. I notice that I don't have the "Safely Remove Hardware"
    on the taskbar. Can you think of anything else I should check? I really
    appreciate your help as I have been trying on and off for a couple years to
    get this working correctly. Is there two more ESATA ports inside the
    machine I could use too? Thanks again!
    me, May 15, 2011
  14. me

    Anssi Saari Guest

    There's only the one eSATA port. Other ports of the Marvell controller
    are used for PATA and the Silicon Image raid thingy, Drive Xpert or
    whatever it's called by Asus marketing. You could use a port
    multiplier, but I think eSATA interface boards are a lot more common
    and cheaper too.

    It's also possible to use any of the internal Intel SATA ports for
    eSATA with an adapter. I've been doing that, I have the same board as

    Of course, hotplugging those would require a switch to AHCI mode.
    There's a recipe for how to do that in Windows XP without
    reinstalling, but it's a little risky. Worked for me, but I did have
    an image backup handy too.
    Anssi Saari, May 16, 2011
  15. me

    me Guest

    Thank you for the reply. The port seems to be working fine after I
    uninstalled and reinstalled the driver. Is Asus drive xpert supposed to be
    enabled by default in the bios? Mine is not enabled but when I enable it
    the device manager shows a zero byte 8gb drive. When xpert o disabled the
    drive is not there, maybe this is normal. Also, should I installed the
    Intel matrix controller in just to have it in case I use raid? Would it
    hurt anything to install it?

    I have also read about converting to AHCI mode without reinstalling and it
    looks risky. Here is where I found the recipe:

    I will back it up before attempting this just in case.

    Thank you for the help.
    me, May 16, 2011
  16. me

    me Guest

    I uninstalled the Marvel, installed it again, and all is well. The device
    manager already had ports 0 & 1 et to hotplug enable already and when I
    enabled hotlug on port 3 it reverts back to hotplug enable on 0 & 1 only.
    Port 3 will not stay in hotplug mode. I don't have a safely remove icon in
    the status bar but that's no big deal. The main thing is that it now works
    thanks to your advice. The Marvel is not listed in the device manager under
    Scsi controllers etc.

    I have heard that I could switch my system to AHCI without re-installing
    windows but after googling for a few hours can't figure out what benefit it
    would produce. I have one internal sata boot drive, one esata drive, and
    one sata usb drive. I have the registry mods for enabling AHCI on a
    preinstalled operating system but understand that it is risky and cannot
    figure out what good it would do me. If you can give me some advice please
    real free, thank you.
    me, May 18, 2011
  17. I'm not really expert enough to add much to this thread, but as I'm also
    running a P5Q Deluxe I'll jump in with my experience. Stick with me --
    I'll get around to eSATA eventually.

    I'm running four internal SATA drives -- one is one terabyte and the
    other three are 1.5 terabytes each. I'm using the RAID controller
    mainly because back when I was setting the system up I decided I'd try
    to get fancy and combine the three 1.5 TB drives into one humongous 4.5
    TB drive -- leaving the 1 TB drive partitioned for multi-boot
    installations. Actually it all worked for a few weeks, and then one of
    the drives dropped out of the array, which meant my 4.5 TB RAID array
    was belly-up. The drive was fine -- it had just decided it didn't want
    to be part of a RAID array any longer. After a little soul-searching I
    decided my experiment wasn't worth the hassle and I reformatted the
    three 1.5 TB drives to stand alone. No more RAID array, and I'm very
    happy with the way the computer is set up.

    But having originally set the drives up for RAID, I was now using the
    P5Q Deluxe RAID controller and I just left that alone. My drives don't
    show up in BIOS -- they show up briefly in some sort of RAID display
    every time I boot. So I'm using the RAID controller, with four drives
    showing individually -- not linked in an array. Make sense? Hope I'm
    getting the terminology right.

    In addition to all this, I have installed on the front of my computer
    one of those panels that provides slots for various camera memory cards
    along with some extra USB ports, and also -- an eSATA port.

    So I've run a fifth SATA cable (four physical drives, remember?) from
    one of the P5Q Deluxe's six internal SATA sockets to that plug on the
    front panel.

    And with no further setup required, I've discovered that if I want to
    connect a spare SATA drive to the computer, all I have to do is plug it
    into my front panel (externally powered, of course) and within seconds
    the drive appears in Windows Explorer and I'm good to go. Because of
    the way the front panel socket is constructed, though, I had to order a
    special SATA cable -- it has little metal clips on each end. Don't know
    what that's supposed to accomplish, but there you are.

    I've never tried to use the eSATA socket on the back of the computer.

    And that's all I know to tell you. Hope it helps.
    Bill Anderson, May 18, 2011
  18. me

    Paul Guest

    If you're referring to using a real ESATA cable, the connector parts
    are designed for 5000 insertions and removals. That means you could
    connect a backup ESATA drive once a day, for years and years without
    the connector wearing out.

    The internal connectors and cables, aren't designed for that.

    ESATA also has a higher signal budget, which is why they allow
    a 2 meter (6 foot) cable with it. By the time you route a motherboard
    SATA port to your front panel, you've already used half of that
    reach budget. That means you might want to use 1 meter cables
    with your drive plugged into the front, for best results.

    While the chipset datasheets mention parameters for SATA and ESATA
    operation, I'm not sure how that is controlled or whether there
    is a way to determine what characteristics are at play. The ESATA
    should work with a 1 meter cable, but to do the 2 meter reach,
    you'd really want the interface electronics to reflect the
    proper ESATA standard. And I find tracking that to be a confusing
    issue. If you connect your motherboard SATA port to the front panel,
    the computer doesn't know the connector has "gone external". It's
    possible they run the interfaces at ESATA signal levels all the time,
    but I don't know that for a fact.

    Some computers have five SATA connectors on the motherboard and
    one ESATA on the back (those six ports are all connected to the
    Southbridge). Because that configuration is known in
    advance, it could be they set things up properly for it. But in
    general, I've never seen any discussions about people verifying
    the interface is electrically "real ESATA", and the only way
    you might notice, is with excessive cable transmission errors.
    And since I don't see a counter for cable errors, it's really
    hard to help people evaluate their drive interfaces.

    Paul, May 18, 2011
  19. me

    Rob Guest

    The 'safely remove' is possibly in a registry setting you *may* be able
    to change - I'll see what I can dig-up about that.
    AHCI does add hot-plug support and NCQ (native command queueing, a
    function of many hard drives) and *might* result in a slight increase in
    performance, but it will be virtually unnoticable.
    However, it may well be that changing the Intel controller to AHCI
    affects the whole XP installation in such a way that Safely Remove will
    also start working work on the Marvell controller. I strongly suspect
    that is the case.
    However, unless you have a real need to hot-unplug the eSATA drive, I
    honestly wouldn't bother trying to change to AHCI as doing this could
    easily trash your system if it doesn't go well. If you do try it,
    make an image of your system first and restore it to a spare drive, just
    to check that the image can be restored properly.
    I use Acronis True Image Home 2011 for this, but there are free versions
    of that at some hard drive manufacturers sites (you must have at least
    one of their drives in your system for it to work) or other
    free system imaging tools.
    An alternative would be a fresh install with AHCI set in the BIOS
    (you would need to create the AHCI drivers floppy in advance and
    press F6 during the installation of XP64.)
    One thing to try is to right-click the eSATA drive in Windows Explorer
    and see if 'Eject' is an option. If it is, you can use that instead
    of Safely Remove in the system tray.
    Rob, May 18, 2011
  20. Hmm. Interesting. I hadn't thought about cable length, as mine are
    nowhere close to a meter long. The internal is standard length -- a
    little less than 20 inches, and the external is about 16 inches. And
    that adds up to ... hey, that's about a yard, isn't it? And a yard
    actually is close to a meter long. Well I declare.

    Still, hot plugging and unplugging are working fine for me.
    Bill Anderson, May 18, 2011
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.