PB Legend 2050

Discussion in 'Packard Bell' started by Chris, Apr 17, 2004.

  1. Chris

    Chris Guest

    Hi, I have a PB Legend 2050 with a PB441A motherboard and a DSX2 50
    mhz. processor. I tried to flash the BIOS with the wrong file(PB450)
    it diddn't take, stayed stuck on "erasing flash eprom 0%". I finally
    gave up then figured out I have a PB441A motherboard.

    The computer still booted up and loaded Windows 3.11, everything
    seemed still OK.

    So I proceeded to FDISK and FORMAT and install Windows 95A. Everything
    went fine. Installed SP1 and went to bed. Today when I turned it on I
    get 2 low pitced long beeps followed by 3 short low pitced beeps. CMOS
    read/write failure.

    Is there a way to recover the BIOS if so does anyone have this
    BIOS.(1.01E) or a newer one?
     
    Chris, Apr 17, 2004
    #1
    1. Advertisements

  2. Chris

    Ben Myers Guest

    If I remember well (the cobwebs in my brain continue to gather), the PB441A does
    not have a flash BIOS. Instead, it has the type of BIOS chip that is removed
    and programed with a special EPROM burner.

    If you want to overcome BIOS limitations (like hard disk?), the best way is to
    install an ISA bus add-in card with its own hard disk BIOS. MicroFirmware once
    sold a replacement BIOS EPROM for the PB441, but they are now out of business.

    The "CMOS read/write failure" has other causes, however. First, I would replace
    the motherboard battery. There is also the possibility that the CMOS chip
    (different from the BIOS EPROM) has failed after all these years.

    Except as a working heirloom, the system has little practical value. Used
    Pentium and Pentium II systems are being scrapped all the time, for want of
    someone to use one. Best to replace the PB 486 system... Ben Myers
     
    Ben Myers, Apr 17, 2004
    #2
    1. Advertisements

  3. Chris

    Chris Guest

    Thanks for replying, I replaced the battery a couple of months ago
    with a solder in NiMH. I also tried booting with the J17 Flash EPROM
    jumper in the Boot-from-Boot Block position(since posting last night)
    and got a "police siren" followed by a different set of high pitched
    beep codes that I couldn't desipher from "uhtksupport" he doesn't
    actually have the PB441A listed.

    I know the computer is way out of date but it is my mom's and is
    virtually unused and would like to keep it for word processing.
     
    Chris, Apr 17, 2004
    #3
  4. Chris

    Chris Guest

    I got this figured out. It turns in removing and reinstalling the hard
    drive(mounts on the side of the CD-ROM cage)it was shorting out on the
    reset switch and LEDs on the front of the case. Looks like a design
    flaw in the case.
     
    Chris, Apr 22, 2004
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.