PC "jerks" occasionally under windows (fairly long)

Discussion in 'IBM' started by Geoff Winkless, Apr 5, 2005.

  1. Hi

    I've built my own machines for about 7 years and my homebuilt desktop PC
    keeps hanging for short periods (a few tenths of a second?), usually when I
    move the mouse (?) and when there's disk and/or network activity. As you can
    probably tell I can't pin it down :(

    Basically when I just play a tune in (eg) Winamp, all will be fine. If I
    open another app at the same time and move the mouse around every so often
    the sound will loop around a small section of sound (almost like bad
    timestretching!) which I assume is the soundcard's internal buffer - at the
    same time the mouse will stop until the system returns to normal (only a
    fraction of a second but noticeable).

    I was wondering if a dodgy hard disk would cause this but it's a fairly new
    disk and it hasn't been getting any worse: further, if I remember rightly
    the problem has been since I upgraded motherboad+processor.

    The soundcard is on-board - Realtek AC97
    Network card was on-board (Realtek 8139) but I tried an Intel Pro100 Server
    card we had here and it made no difference.
    I've tried disabling all the non-essentials (onboard USB, firewire, serial,

    PC Spec:
    Athlon XP2600+ (not overclocked)
    Gigabyte GA-7VAXP (VIA KT400 chipset)
    OEM NVidia GeForce4 MX-220 (I think - the machine's at home) 64MB
    running at 4x AGP
    512MB Kingston RAM (333)
    Hitachi Deskstar 120GB (7200RPM 8Mb cache) (on onboard Promise ATA
    controller 1)
    Mitsumi 16x CD-R (on onboard Promise ATA Controller 2)
    Maxtor 40GB Drive (unused by Windows - for Linux only) (on onboard VIA
    ATA controller 1)
    BenQ 1620 DVD writer (on onboard VIA ATA controller 2)

    I had Win2k installed but upgraded to XP (complete clean reinstall, purely
    to ensure no dodgy DLLs or settings remained) and the problem still exists.

    The fact that all of the hardware is onboard should surely mean that it's
    tested to work well together... so would that mean the graphics card is a
    potential area for concern?

    Would a dodgy power supply cause these kind of problems? I know I'm running
    at a fairly high load but pulling the power cables off the Maxtor and the
    CDs makes no difference, while you would expect it to were power the cause.

    The fact that it always seems to be a mouse movement would suggest IRQ
    issues - or maybe the mouse movement is a red herring and it's the graphics
    card (because of the pointer moving?)

    I don't see the problem under Linux but that could simply be more forgiving
    drivers or less stressful PCI bus settings, or something. Either way, the
    problem occurs with vanilla XP and with the most recent drivers.

    So... does anyone know of any known problems with the cheaper NVidia-based
    cards and the KT400 chipset (or maybe specifically with the Gigabyte 7VAXP)?
    Or indeed have any other suggestions?

    Geoff Winkless, Apr 5, 2005
    1. Advertisements

  2. I suppose that's not necessarily true: hard drives generally run at 12v,
    while (IIRC) the Athlon is 5v.
    I'm not actually sure this is the case. It could be that the mouse
    movement is incidental: it seems that switching windows and/or starting
    new apps is more likely to be the cause (both of which involve mouse
    movement :).

    Geoff Winkless, Apr 5, 2005
    1. Advertisements

  3. It's the GeForce4 MX-420. I was close. :)

    Geoff Winkless, Apr 6, 2005
  4. I think I've had the same problem with a comp, but i don't remember
    what i did to solve it... However, I have some ideas:

    Have you checked that the HDD controllers are using DMA and not PIO

    Have you checked the system logs (in Computer Management or whatever
    it's called in English..) to see if there are any relevant error

    Have you tested your hard drives with the manufacturers test/diagnose

    If so, I'm out of ideas...

    Uh.. not true. I just got one more. :)
    If you're computer is installed as an ACPI computer, try "Standard PC"
    instead. That might sometimes solve IRQ related problems... *if* I
    recall correctly. Better verify with Google or something first. I
    don't remember how to do the change anyway, so you'll still have to do
    some searching. ;)
    Peter Emanuelsson, Apr 8, 2005
  5. Hitachi's DFT says the disk is fine.

    I just tried putting the Windows disk on the VIA controller rather than
    the Promise one and the problem has gone. Whether this means there's a
    problem with the drive+controller combination (unlikely) or whether the
    Windows drivers are screwy (more likely, IMO) is something to investigate.

    The problem is that the drivers for the promise controller are specific
    to the Gigabyte motherboard - the normal 20276 drivers won't work with
    it (I guess some hacking might get around that but that's not exactly
    easy). Promise have updated drivers on their site but the Gigabyte site
    has drivers a couple of clicks behind the promise ones :(

    The whole reason I put the drive onto the Promise controller in the
    first place was because when I had both writers on the controller it
    failed to load the BIOS on boot and accessing the drives was _really_
    slow - I assumed that was because the UDMA wasn't enabled unless the
    BIOS was loaded. An email to gigabyte elicited an extremely unhelpful
    response, unfortunately :(

    Thanks for your help, anyway, at least now I've narrowed it down to the
    MBUltra and I'll start trying to sort that :(

    Geoff Winkless, Apr 9, 2005
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.