1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Philips CDRW not seen by BIOS

Discussion in 'Hardware' started by William, Jun 19, 2004.

  1. William

    William Guest

    My new Philips PCRW5232 is not seen by the BIOS of my Dell Dimension
    XPS R350. In fact, it hides another device connected to the same IDE
    (secondary). However, if I boot with another device connected, and
    then 'hot swap/add' the CDRW, it works perfectly - just not very
    convenient! I have tried every cabling/jumper permutation possible,
    with the exception of 80-conductor cable. What can the BIOS not do
    at startup that W2K can do while running?

    William
     
    William, Jun 19, 2004
    #1
    1. Advertisements

  2. William

    Aaron Guest

    You are plugging in a drive while the computer is running? Please
    wait while I pull my jaw up from the floor.

    Please don't do that. A recent thread demonstrated how someone
    wrecked a harddrive by doing such.

    Otherwise, I don't know what would be causing such a problem.
    Possibly the PS is not up to the task? That wouldn't make sense
    though, with it still working in W2K.

    Is the drive on the same cable as a harddrive?

    Aaron
     
    Aaron, Jun 20, 2004
    #2
    1. Advertisements

  3. William

    William Guest

    My secondary IDE usually has a CD-ROM and a ZIP drive. I've tried
    the CD-RW alone, and with the CD-ROM.

    William
     
    William, Jun 23, 2004
    #3
  4. William

    William Guest

    I've now tried the drive on a HP Brio PIII 900Mhz, and the BIOS finds it
    OK. Just what does IDE device detection do in the BIOS?

    William
     
    William, Jun 25, 2004
    #4
  5. Including cable select? What about BIOS updates?
     
    Anonymous Jack, Jun 25, 2004
    #5
  6. William

    William Guest

    Cable select works OK after booting, as does Master/Slave.

    BIOS upgraded to 'latest' from Dell - A13 (1999!!). Where did Dell
    get their BIOS from? Looks like Award screen layout ...

    What does a device do during BIOS detection? What makes the CD-RW different
    from my 6 year old NEC CD-ROM at this stage, which claims the same spec?

    William
     
    William, Jun 26, 2004
    #6
  7. Yes, the Dell BIOS is probably a modified Award BIOS, IIRC.
    Let me back up a bit... Seeing that 1999 BIOS date threw me for a
    little loop. This is an older PII system? And what you are trying to
    do is boot from your CD-RW?

    When you press F1 to enter setup, you see your HD but BIOS does says
    "not found" or something similar where you would expect to see the CD
    drives?

    Sorry if I seem thick - just reread your original posting and I'm
    still trying to figure out what you're seeing and doing.
     
    Anonymous Jack, Jun 29, 2004
    #7
  8. William

    William Guest

    It is indeed a 350Mhz PII. Two hard drives on the primary IDE - no problems
    there under any circumstances. An original NEC CDROM drive cable-selected
    as master on the secondary IDE. Has always booted identifying the hard drives
    and the CDROM drive in the BIOS - in SETUP you can see them.

    I added the CD-RW as cable-selected slave location on the secondary IDE,
    and the BIOS no longer identifies the CDROM (or the CD-RW). I've tried
    the CD-RW on its own, with all possible permutations of selection, but it
    never appears.

    Under these conditions, Windows 2K does not identify the secondary IDE
    controller in Device Manager, never mind the devices on it! This may not
    be a problem with the controller, as Windows doesn't see it if there are
    no devices connected either.

    However, if you connect just the CDROM and boot, Windows sees the secondary
    IDE controller and the CDROM drive. Then the 'daring' hot-swap/add of the
    CD-RW drive is spotted as new/changed hardware by Windows, which then
    continues to drive the CD-RW perfectly, as far as I can tell.

    I would guess that it wouldn't matter that the BIOS couldn't identify
    the CD-RW, provided my CDROM drive and/or secondary IDE wasn't masked...

    William
    --
     
    William, Jun 30, 2004
    #8
  9. William

    Ron Cook Guest

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1
    While it is frustrating to have a PC not respond the way you think it
    should, you might have a couple of options.

    If you have an extra PCI slot available you might consider an add-in IDE
    interface such as those marketed by Promise, SiiG, or Maxtor.
    This would allow you to install the drive internally (setting it as a single
    or master - no cable-select) and would allow the full speed of the drive.

    Another option, if the machine has usable USB ports, would be an external
    IDE-USB enclosure. The access speed would be slower (especially under USB
    1.1) but that might be alleviated with an internal USB 2.0 PCI card.


    - --
    Ron n1zhi

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.2.2 (GNU/Linux)

    iD8DBQFA41I+a9fyRcf4bIYRAsomAJ9GSnY6RALpwPIv0r7B6oXV90En7wCdGVNy
    QbSCb8llmoP/2q+QIInrdJI=
    =iLiz
    -----END PGP SIGNATURE-----
     
    Ron Cook, Jul 1, 2004
    #9
  10. William

    William Guest

    Ron,

    Thanks for the advice, which I feel I will be taking
    up shortly. Curiosity drives me on, though, and I really
    would like to know what manner of change causes this effect.
    Has the IDE spec changed in the last five years?

    William
    --
     
    William, Jul 6, 2004
    #10
  11. William

    Ron Cook Guest

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1
    As a matter of fact, that's something I completely overlooked.
    Your older drive may be designed to the "IDE" specification while the newer
    drive may be designed to the "EIDE" (Enhanced IDE) or, more likely the
    "ATAPI*" specification.

    In the past I have had trouble when (unknowingly) I connected an EIDE or
    ATAPI drive to an older port.
    In theory you should be able to connect the older drive to a newer port,
    however.

    * www.cnet.com/Resources/Info/Glossary/Terms/atapi.html

    - --
    Ron n1zhi

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.2.2 (GNU/Linux)

    iD8DBQFA6xuxa9fyRcf4bIYRAheIAJ9YVrbTe/QPW7V5+zTXmV7ZJ+k1XwCeMn9t
    nofjLr5a5c67yam0B9yvda8=
    =wJl+
    -----END PGP SIGNATURE-----
     
    Ron Cook, Jul 6, 2004
    #11
  12. William

    William Guest

    The original drive claims Ultra DMA 33 Mode 2 - is this an indication
    of the IDE spec?

    William
    --
     
    William, Jul 13, 2004
    #12
  13. William

    William Guest

    Having explained the problem to Philips, who weren't much help,
    I took the drive back to PC World who exchanged it for a Lite-On
    equivalent. This behaves itself IDE-wise on my machine.

    William
    --
     
    William, Jul 21, 2004
    #13
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.