PIO & DMA Options in BIOS?

Discussion in 'Asus' started by Steve, Nov 13, 2005.

  1. Steve

    Steve Guest

    Been having problems enabling DMA for my DVDRW and CD-R ever since this
    system was put together a month ago. Tried practically every trick in
    the book that is suggested on webpages. Noticed that there are options
    in the BIOS besides the default settings and don't have a clue what
    they are.

    PIO Mode - Auto 0,1,2,3,4
    DMA Mode SWDMAO, SWDMA1, SWDMA2, MWDMAO, MWDMA1, MWDMA2
    UDMAO through UDMA3
    UDMA1 through UDMA5

    Could someone please explain why there are so many choices?


    Thanks -
     
    Steve, Nov 13, 2005
    #1
    1. Advertisements

  2. You shouldn't have to play around with the BIOS settings, those you can
    just leave on Auto. They generally don't have much effect on what the
    drive runs at once it's booted into the OS. What else have you tried?
     
    Robert Hancock, Nov 14, 2005
    #2
    1. Advertisements

  3. Steve

    RonK Guest

    Go into Device Manager, Double click the IDE ATA Controller. Right click
    each (Primary then Seconday) Advanced, and try to set dma there.
     
    RonK, Nov 14, 2005
    #3
  4. Steve

    Steve Guest

    Am running an Asus P5WD2 Premium Board with version 0422 BIOS, if that
    information should help -
    I've switched settings from PIO Only to DMA,

    Deleted the secondary IDE channel,

    I've switched setting from PIO Only to DMA,

    Deleted the secondary IDE channel,

    Disabled XP's burning capabilities,

    Uninstalled drivers for both devices,

    Deleted the CD-R and DVDRW in Device Manager,

    Ran regedit and tinkered with the following key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}
    deleting MasterIdDataChecksum or SlaveIdDataChecksum

    Haven't sacrificed a Chicken during a Full Moon yet, but that might be
    a viable option at this point.

    Thanks for the reply, any and all suggestions will be most welcomed -
     
    Steve, Nov 14, 2005
    #4
  5. Steve

    Steve Guest

    It just reverts back to PIO Mode after burning the first disk and I've
    noticed it will also happen if data is copied from a CD or DVD.
    Never had any problems with Windows 2000 but I am aware of XP's six
    error limit that throws the setting back to PIO.

    thanks for the reply -
     
    Steve, Nov 14, 2005
    #5
  6. Steve

    RonK Guest

    If you have the drives jumpered as Cable Select - Change them to DVD-
    Master, CD - Slave.

    I could not get one of my DVD drives to udma 4 untill I changed the jumper
    settings on both drives.
     
    RonK, Nov 14, 2005
    #6
  7. Steve

    Steve Guest

    That's how the drives were originally setup, DVD master & CD-R slave.
    Read something about enabling the Event Viewer for the errors which
    cause the burners to revert back to PIO. Found another article that
    suggests setting TimingModeAllowed for the specific IDE drive to
    0xffffffff to prevent XP from recording the errors.

    This problem bugged the living daylights out of me for the first two
    weeks and I finally gave up. Have never burned an SVCD faster than
    8 or 12x and DVDs more than 4x, CDs take 6 minutes but the DVDs are
    annoying at almost 35 minutes. My burner on an older computer took ~14
    minutes for a full DVD and that is amount of time that I expected this
    new burner and computer to match. I'm beginning to think that there are
    problems with the motherboard's IDE slot cause the same thing is
    happening in Windows 2000.

    Thanks for the reply -
     
    Steve, Nov 14, 2005
    #7
  8. Steve

    S.Heenan Guest


    I'm not familiar with the 955X chipset in question, though I've found trying
    both older and newer IDE drivers will often work.
     
    S.Heenan, Nov 14, 2005
    #8
  9. Steve

    Troop Guest

    I'm beginning to think that there are
    That board has several ide connectors-intel® ICH7R South Bridge:
    1 x UltraDMA 100/66/33 and the ITE IDE controller:
    2 x UltraDMA 133/100/66

    to which are the drives connected ? The latter does not support
    optical drives.
     
    Troop, Nov 14, 2005
    #9
  10. Steve

    Steve Guest

    They are connected to the blue premium IDE slot

    thanks for the reply -
     
    Steve, Nov 14, 2005
    #10
  11. Steve

    Steve Guest

    Will try this suggestion next -
    thanks
     
    Steve, Nov 14, 2005
    #11
  12. Windows will fall back to PIO if the error rate over DMA is too high.
    The most common cause of that is a bad cable.

    So try using a different/new IDE cable. If you're using a UDMA33 cable,
    try a UDMA66 cable.

    Max Attar Feingold
    maf6 at cornell dot edu
    http://almonaster.sourceforge.net/mfeingol/

    [Not speaking for my employer]
     
    Max Attar Feingold, Nov 14, 2005
    #12
  13. Steve

    tomcas Guest

    I think windows 2000 does the same thing after six errors. As one of the
    other post asked, are you using 80 wire cable?
     
    tomcas, Nov 15, 2005
    #13
  14. Steve

    Steve Guest

    Yes, an 80 strand is being used but am wondering if anyone installed
    the cable that was furnished by Asus which came with the motherboard.
    Isn't that a 40 wire cable?

    Thanks for the help -
     
    Steve, Nov 15, 2005
    #14
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.