1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Please Help! Missing interrupt from rtl8139.

Discussion in 'Embedded' started by leilei, Nov 25, 2009.

  1. leilei

    leilei Guest

    Hi.
    I am writting a small os base on x86 arch.
    I have just written a rtl8139 driver for my os.the device's interrupt
    vector is 11.
    When I run my os, I can 'ping' it through windows for a while.
    But after a few minutes, the rtl8139 network card has not produce any
    interrupt.

    I can assure the os is not dead.Because it can receive the interrupt
    from PIT, and the Ticks in my os is increasing.
    I also check the device's status, it also do not have any problem.

    I have tried a lot of method, still can not solve this problem.

    Please give me some help.
    thanks.
     
    leilei, Nov 25, 2009
    #1
    1. Advertisements

  2. leilei

    Ed Prochak Guest

    SO many possibilities, especially without being able to see your code.

    How do you know the network card does not have any problems?
    Which x86? What interrupt controller? what motherboard/chipset?

    The simplest possibility is some control register is not being
    cleared.

    Not much but I HTH.
    ed
     
    Ed Prochak, Nov 27, 2009
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.