Problem installing XP SP2 on new SATA HD with MSI RS480M2-IL

Discussion in 'MSI' started by halbardicus, Jun 11, 2005.

  1. halbardicus

    halbardicus Guest

    Bought this today for 70 GBP together with the Athlon 64 3000+

    I set up the SATA controller as IDE. The single HD was detected in the
    bios on IDE Channel 2. XP setup did not recognise the drive, whether or
    not I pressed F6 and selected the Si3112 RAID controller driver off the
    floppy. I used the latest drivers from MSI and a new Hitachi Deskstar
    160GB.

    Of course, I tried setting the SATA controller as RAID, pressed F6,
    loaded the driver, crossed my fingers, and "Setup did not find any hard
    disk drives ..."

    So how do I install XP on a single bare SATA HD configured as IDE on
    this mobo?
     
    halbardicus, Jun 11, 2005
    #1
    1. Advertisements

  2. halbardicus

    John Russell Guest

    There are two types of driver on the disk, but your only need both when
    using the Raid function i.e. more than 1 drive. These are the IDE Controller
    Driver, which you need, and the Raid Driver, which combines mutiple disks
    via the IDE Controller Driver, which you don't. When you only have a single
    drive you ignore all Raid options in the bios and treat the thing as a
    normal IDE controller.
     
    John Russell, Jun 11, 2005
    #2
    1. Advertisements

  3. halbardicus

    halbard7 Guest

    And when I treat the thing as a normal IDE controller, XP setup ignores
    it. I have looked for the IDE controller driver of which you speak, but
    it is nowhere to be found. Any suggestions as to where it might be?
     
    halbard7, Jun 11, 2005
    #3
  4. halbardicus

    halbard7 Guest

    Perhaps I should clarify the situation. When I leave XP setup
    unattended, it fails to find any mass storage device (... Press F3 to
    quit). So I deduce that some sort of driver is required. I could be on
    to something. No fool me.

    The floppy that comes with the motherboard has two drivers which, setup
    tells me, are:

    Silicon Image SiI 3x12 SATARaid Controller for Windows XP/Server
    2003
    Silicon Image SiI 3x12 SATARaid Controller for Windows NT 4.0 and
    2000

    Since neither of these drivers allows setup to recognise my HD, which
    sits there undetected on IDE channel 2 (as the bios happily reports), I
    am sad. I look on the floppy and find Si3112r.sys, SI3112r.inf (and
    various other files of the form *r.*). Perhaps the "r" in these
    filenames stands for RAID? Now I begin to suspect, dimly, that the
    floppy has only RAID drivers. Only RAID drivers? No wonder they won't
    work (feigns outrage). Oh, bother.

    Hang on. Wait a moment. I have an idea. Perhaps some sort of SATAIde
    Controller driver is needed? Could it be true? Really? It .. it's
    brilliant! Heaven be praised. I proceed to wet myself out of joy and
    anticipation.

    OK, calm down boy. Take it easy. Dry yourself off. Why not find and
    download to floppy a thing called

    Silicon Image SiI 3x12 SATALink Controller driver

    which might just be what you're looking for (thinks of cowboy riding
    off into sunset, gal, guitar music, end credits)?

    Unfortunately they don't work (Setup cannot..., press F3..., usual
    microsoft aftercare)

    So, I am back to my original question: what do I do now?
     
    halbard7, Jun 11, 2005
    #4
  5. halbardicus

    Gollum Guest

    Try this link
    http://www.msicomputer.com/support/sup_tshoot.asp#3_3


    Under the "no boot" links pick sata configuration

    There is a section on installing a single SATA drive with XP

    HTH
    Gollum
     
    Gollum, Jun 11, 2005
    #5
  6. halbardicus

    halbard7 Guest

    Thanks. This is much more helpful. Regretfully, the ATI SB400/Silicon
    Image chipset is not covered in the troubleshooting guide, only VIA,
    Intel and Promise. The bios settings are dissimilar. Perhaps the ATI
    chipset is too recent? That aside, it does suggest one or two paths to
    pursue. I will give them a try.

    MSI have non-raid x64 drivers, but none 32 bit. Puzzling.

    Has no-one else met, let alone solved, this specific problem on this
    mobo?
    Am I being stupid?
     
    halbard7, Jun 11, 2005
    #6
  7. halbardicus

    CyberMario Guest

    hi

    i had the same problem with this motherboard and a Western Digital
    Caviar SE WD2500JD 250GB drive (and i have a PATA drive on primary
    master) :roll:

    on Integrated peripherals -> South OnChip PCI Device->OnBoard Chip
    SATA: IDE Controller

    - Install Windows XP x64 edition without problems on SATA drive
    - installing without RAID (SATARaid) floppy drives
    - Problem: Boot from PATA

    Choosing SATA as first boot drive i got this error:

    DISK BOOT FAILURE, INSTERT SYSTEM DISK AND PRESS ENTER :x

    and installing Windows with RAID (SATARaid) floppy drives: same!!!

    on Integrated peripherals -> South OnChip PCI Device->OnBoard Chip
    SATA: Raid Controller

    - Windows setup program doesn’t detect SATA drive (with or without
    RAID SATARaid drives)
    - On boot pressing on RAID Configuration can’t do anything , can’t
    create a RAID array because "no enought drives" error msg :(

    i had latest bios on my motherboard, i had RAID SATARaid drives for
    AMD64

    nothing!!! 8O 8O 8O

    i think the problem is detected since windows installation, the PATA’s
    first
    partion is C and SATA’s first partition is D, no matter if SATA is
    configurated as first boot priority :?

    can anyone resolve this?? :(

    thanks :D
     
    CyberMario, Jul 9, 2005
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.