Problem with 8knxp Gigaraid

Discussion in 'Gigabyte' started by Jw, Apr 13, 2005.

  1. Jw

    Jw Guest

    I have been experiencing a problem with the ITE raid portion of my
    8knxp for awhile now but it becomes untenable when I begin to run World
    of warcraft. I have 2 identical 80gb hard drives striped on the array
    as the hardware details will show. When I run World of warcraft the
    raid begins shutting down and restarting the drives simultaneously. As
    soon as I shut off world of warcraft all is well.

    I have the 2 western digitals set to master. One on ide3 and one on ide
    4. Nothing else is on that chain.

    My boot drive is an 80gb hitachi on ide1, dvd-rom as slave on ide1
    cd-rw on ide2, ls-120 as slave on ide2

    I have 1 serial ata hard drive on sata0


    It has passed a strenuous test with burnin test as well. I have gone
    over a month recently without rebooting. Until I started having this
    issue.

    I get these three notices in my event viewer that coincide with the
    raid problem.

    1. ERROR The device, \Device\Scsi\iteraid1, did not respond within the
    timeout period. (likely due to the drives shutting down and restarting)

    2. WARNING An error was detected on device \Device\Harddisk2\D during a
    paging operation. (likely due to the drives shutting down and
    restarting)

    3. WARNING The driver has detected that device \Device\Scsi\iteraid1
    has old or out-of-date firmware. Reduced performance may result. (I
    have the bios the board came with. The ITE sight has many revisions
    newer for their standalone cards which I know won't work for this
    board.)

    So I have searched the gigabyte website for the updated firmware and
    flash program suited specifically to this on-board card but I have only
    found drivers, with which I updated to the most recent ones and the
    problem still exists.

    I have seen one post mentioning that someone did succeed in getting the
    1.7 version of the bios from Gigabyte but so far they have given me no
    real help. Just telling me to make sure the drives are set as master on
    ide3 and ide4 (which they are and always have been)

    I suspect the board doesn't handle having both serial and IDE drives
    active at the same time. I have also tried making the 2 drives seperate
    and turned off the IDE raid function but this did not fix the issue.

    The only thing I have been able to do at this point is unplug those 2
    drives and not use them, leaving my boot drive and my serial ata drive
    in place.

    Does anyone know where I can get the correct bios update or other
    possibilities this might be?
     
    Jw, Apr 13, 2005
    #1
    1. Advertisements

  2. Jw

    Ian Guest

    Regarding point 3, your driver seems to be ahead of your BIOS, so perhaps
    you need to downgrade the driver version?
     
    Ian, Apr 13, 2005
    #2
    1. Advertisements

  3. Jw

    Mercury Guest

    More like GB should get off their bums and into action and update the bios's
    for the mobos that are now well behind.
     
    Mercury, Apr 14, 2005
    #3
  4. Jw

    Ian Guest

    Yes, agreed. But the OP is looking for a quick fix based on what is
    available, I guess.
     
    Ian, Apr 14, 2005
    #4
  5. Jw

    Jw Guest

    It started with the original driver version. I updated AFTER the issue
    began.
     
    Jw, Apr 14, 2005
    #5
  6. Jw

    Jw Guest

    Correct. I am trying everything that is available to me to come to a
    solution and the next step is for a [email protected][email protected]@ way overdue bios update for
    the ITE GigaRAID. If the issue continues after that I just might have 2
    80gb Wd's to sell on ebay in favor of a second SATA Maxtor identical to
    the one I already have. I love the 16mb cache buffer on it.
     
    Jw, Apr 14, 2005
    #6
  7. Jw

    Ian Guest

    Oh dear! Sorry :(
     
    Ian, Apr 14, 2005
    #7
  8. Jw

    Tim Guest

    Firstly, I think it is paramount to find out why the drives were spinning
    down. Was it the power connectors? If so, then fine - fix it , if not then I
    would not use the same config until such time as the cause was found. If the
    issue is occuring only during game play then it could be PSU overloading or
    some over temp situation. Use one of the MBM like tools to monitor temps and
    volts during a Test.

    IMHO, disc drives will not power down unless either they are told to, or
    there is a big voltage problem. I am of the opinion that the spinning down
    of the drives is not due to bios / firmware or driver issues, but the
    problem lies elsewhere. How much juice does you graphics card consumer? Are
    its drivers up to date? How hot do the drives get?

    In your case, if disc drives had been falling off line - spinning down, I
    would have panicked at that point. A raid 1 config can't afford for issues
    on both images at the same time - it has no way of reconciling what is right
    on one disc with what is right on another. One will fail first, the other
    may already be corrupt in such a situation.

    Although it is well known that the GB bios / ITE firmware is out of date,
    what is not known / well known is how good the actual ITE raid
    implementation is. It seems as though the ITE raid is rarely used - SATA
    raid seems much more common and those that want IDE raid often have
    controllers already. So, this could be a red herring. The changes in the
    latest firmware could be as trivial as spelling mistakes for all we know.
    Since the cause in your case is the drive powering down you are right in
    suspecting everything, but it may be absolutely nothing to do with the ITE
    firmware or driver. (A game should not ever be able to affect a disc
    controller or driver - if you have a wonky graphics card or a wonky driver
    on the graphics card this *can* happen).

    Due to GB's inability to maintian the bios adequately, I would not use the
    ITE controller for any raid. I suggest getting something that is better
    supported and has a good reputation EG a Promise controller and rebuild on
    that.

    - Tim
     
    Tim, Apr 15, 2005
    #8
  9. Jw

    Jw Guest

    The drives spin down simultaneously which leads me to believe it IS a
    bios issue. If it were a power issue then only one drive would kick off
    or they wouldn't kick off in synch and kick on in synch. Not to mention
    the event viewer log gives a clear message about out of date bios. If
    it was a 3d graphics and power related issue, then the problem would
    have occured on half-life 2 which has higher specs than WOW.

    The raid is removed and for now the drives are not even plugged in.
    That was done after the initial diagnosis. No data is going to be lost.
    The power supply is a enermax 400 watt. It is not a generic PS.

    I do not need to stick another card in my machine for these drives.
    Should it become clear that I am not going to see a bios update, then I
    will simply sell off the 80gb drives and get a second SATA Maxtor.

    The issue had happened without the game. Just very rarely and not to
    such an extreme extent. I like your idea on the graphics driver though.
    I will give that a test.
     
    Jw, Apr 15, 2005
    #9
  10. Jw

    Mercury Guest

    Well, those are quite helpful observations that blow things out of the
    water.
    Bad news for ITE... never trusted it to start with.
     
    Mercury, Apr 16, 2005
    #10
  11. Jw

    Kris Vorwerk Guest

    Hi,


    As an aside, I ran a RAID0 array with two WD 40GB hard drives off the
    ITE 8212f controller on my rev. 1 8knxp for almost a year. It ran quite
    stably -- albeit, under Linux.

    Eventually, I switched to just a plain (non-RAID, master/slave)
    configuration after extensive frustration with the 8212f driver code
    under the 2.6 kernel. (At the time, Alan Cox hadn't begun his work on
    the ITE driver, so I was spending too much time manually patching the
    kernel with ITE's buggy code.)

    At any rate ... My point is that it sounds to me like a buggy driver,
    not necessarily a BIOS issue. Yes, the BIOS on our Gigabyte mobos is
    "antiquated", but I think that there's more to it than simply a "bad
    BIOS" -- e.g., it seems odd to me that it happens when you start up a
    game, and not as frequently at other times. It also seems odd that I
    could run a stable Linux system for so long without seeing my drives
    power down mysteriously.


    Kris
     
    Kris Vorwerk, Apr 16, 2005
    #11
  12. Jw

    Jw Guest

    I ran a raid 0 for over a year with these 2 80gb Wd's and had no
    issue..Then I installed the SATA drive. The issue started, rarely, but
    it started. The issue has remained consistent with that game regardless
    of the driver version.

    Like I said in an earlier post, I believe it is a conflict between the
    SATA and ITE chipsets that requires a bios update to resolve.

    Still waiting on gigabyte.
     
    Jw, Apr 18, 2005
    #12
  13. Jw

    Kris Vorwerk Guest

    I ran a raid 0 for over a year with these 2 80gb Wd's and had no

    I'm highly sceptical ...


    1) Moreover, I've owned a similar system (with two PATA drives off the
    ITE8212f, and one SATA drive), and haven't witnessed any problems. The
    fact that I run Linux would seem to suggest that it might be your
    Windows drivers.

    2) Take a look at the change log for the most recent IT8212f chip. Most
    of the changes have been to address issues in the user interface or in
    chipsets/BIOSs other than what is on our 8KNXP....


    ====================================
    1.4.1.5:

    1.Return ax=110h instead of 100h when leaving BIOS initial routine.
    2.Bug fixed: DMA transfer failure on certain main boards.


    1.4.1.6:

    1.Setup Utility can’t be displayed when working with Phoenix BIOS
    2.Always boot from 8212 HDD when using Phoenix BIOS


    1.5.1.7:

    1.Force reconstruction restarts if data inconsistent is found.
    2.Include the replacement drive into array if user press <Y> key.


    1.6.1.8:

    1.If BIOS fails to get rebuild status (error code 51h), show message
    "Rebuilding is stopped by target drive write error or source drive read
    error. Please turn off the power and replace disk. Press ANY KEY to
    continue." instead of "fail to get rebuild status"
    2.PCI configuration space offset 51h bit 0: 0.. Show copyright and other
    info, 1.. Do not show copyright and drive info
    3.Bug fixed: for Gigabyte VIA chipset MB, fail to boot from secondary
    HDD.


    1.7.1.92:

    1.Arrays attached on IT8212 can be shown in system BIOS’s hard diskboot
    priority list.
    2.Add detailed error information.
    3.Add single mirrored drive check. When there is only one mirrored drive
    is attached on IT8212, show the following message “A disk member ofthis
    array was removed and it is not functional now. Please press <Y> to set
    up drive n as a IDE drive automatically or press OTHER KEY to setup
    array manually later.�
    4.Change setup utility delete array's key [del] to key [d].


    1.7.1.93:

    1. modify IRQ share issue
    ====================================


    So, I'd be tempted to look into why the problem happens spuriously when
    you start up your game ... (Is it a power issue? A memory issue? A
    driver issue?) I'd only resort to hassling Gigabyte (a futile effort, I
    suspect) once I'd eliminated the more likely candidates.


    regards,
    Kris
     
    Kris Vorwerk, Apr 18, 2005
    #13
  14. Jw

    CSE Guest



    They did for me for a GA-8I875 Ultra same MoBo but with out the DPS2


    The ITE would not boot with 2 drives ATA but would with 4 ..

    I now have the latest ITE bios and I can select what drive that I can boot
    from, I think it came up with 6 devises..



    I just kept asking for a fix plus the New ITE Bios..

    took about 6 weeks from memory, this bios that I have is now 6 month old and
    still not on there web site.
     
    CSE, Apr 19, 2005
    #14
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.