problem with USB 2.0 controller and Adaptec ATA RAID in same system

Discussion in 'IBM' started by scottabel, Feb 14, 2006.

  1. scottabel

    scottabel Guest

    I have an ASUS Socket A M/B machine with 266 Mhz FSB, integrated
    peripherals, including audio and video. I'm trying to add a USB 2.0
    controller and have been partially succussful.

    The new USB 2.0 adapter is in PCI slot 2. In PCI slot 1 is an Adaptec
    1200A RAID controller, which stopped working after I installed the USB
    2.0 adapter. The USB 2.0 adapter works; I used ghost 9.0 to restore
    my drive after a failure using an external USB drive plugged into the
    new USB 2.0 adapter.

    Now the Adaptec RAID controller shows a problem in Device Manager, and
    when I try to reinstall the driver I get this error:

    There was a problem installing this hardware:
    Mass Storage Controller

    An error occurred during the installation of the device:

    The driver installation file for this device is missing a
    necessary entry. This may be because th INF was written
    for Windows 95 or later. Contact your hardware vendor.

    Of course in reality there is nothing wrong with the .INF or .SYS
    files; they were working just fine before I installed the new USB card.
    The Adaptec windows monitoring software says that there is no RAID
    controller present.

    My system has USB 1.1 onboard and after a recent drive failure i
    finally decided not to wait 8 hours for USB 1.1 (that's how long it
    used to take to do the backups, so I figured the restore would take
    just as long). So I bought the USB 2.0 adapter and the restore took
    very little time.

    Unfortunately, I had to plug my new disk drive into the onboard IDE
    because with the USB 2.0 card in PCI slot 2, the RAID controller
    doesn't work with windows any more.

    In the BIOS, I tried disabling the USB 1.1 onboard controller, no help.
    I tried playing with a lot of different IRQ combinations for PCI slot
    1 and 2. However, whenever I choose an IRQ for PCI slot 1, the USB
    controller takes the IRQ I give it for slot 2 BUT also takes the IRQ
    for PCI slot 1, FORCING a conflict every time.

    I cannot use USB keyboard and mouse now; I am forced to use PS/2
    keyboard and mouse. The system doesn't recognize the keyboard/mouse in
    the new USB 2.0 card, and I was having problems depending on which IRQ
    I chose with it recognizing them in the onboard USB 1.1 ports (which
    are now disabled to try to simplify debugging this problem). However,
    the USB keyboard and mouse did work fine in the USB 1.1 port when
    booting from the Ghost CD-ROM to do the restore. So it isn't anything
    obvious like a loose cable or faulty keyboard/mouse.

    When I go into windows and look at the PCI USB 2.0 card in device
    manager, I can see that it is not using those IRQs that I assigned at
    all. It is using IRQ 16/18, but on the BIOS splash screen it says that
    it is using IRQ 10/5. I selected 5 for the Adaptec RAID. If I
    select 9 for Adaptec RAID then it will have IRQ 9 but the USB 2 adapter
    will have 10/9. I can't seem to find a way to avoid that conflict.

    The funny thing is that the Ghost CD-ROM boot doesn't have a problem
    with this hardware configuration. The BIOS has the problem that my USB
    keyboard/mouse don't work depending on which IRQs I set for the new USB
    controller (so I can't use that keyboard in the BIOS screens) and
    Windows XP also has a problem because the usb keyboard/mouse don't work
    AND the Adaptec controller is not recognized.

    BTW, I can see that the Adaptec controller is working fine if I go into
    its BIOS settings by pressing ctrl-H on startup. Also, it was working
    fine before I installed the new USB adapter.

    What is going on here, and how do I fix it?
    scottabel, Feb 14, 2006
    1. Advertisements

  2. scottabel

    scottabel Guest

    The problem turned out to be the way I was installing the Adaptec
    driver. Their driver INF file ships with a different manufacturer's
    name, that is the manufacturer that they based the driver on. As it
    turns out, if you click "Browse" and give a pathname to the folder with
    the INF file, it chooses that other manufacturer's name, and then it
    complains about something missing in the driver file.

    So instead of clicking on "Browse", right below it If you click on the
    "Don't Search, I will choose the driver to install" and then click on
    the "Have Disk" button instead, even though you are browsing to the
    same place, it then finds the Adaptec name and installs the driver just

    So there was no IRQ conflict causing problems with the RAID controller.
    There is a conflict with legacy USB device operation (keyboard and
    mouse) in the BIOS screens, though. If I leave the USB 2.0 card in the
    system, even if I change the legacy USB device settings from Primary to
    Secondary, the USB keyboard and mouse do not work in the BIOS screens.
    So I can't even press the DEL key to enter the BIOS screen or just
    press any key to tell the PC to boot from CD-ROM when it prompts me.
    So for now I gave up on having USB 2.0 ports in this system and just
    pulled the card.
    scottabel, Feb 15, 2006
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.