Problems under Rosetta on Mac OS X 10.4.7 with Star Wars Battlefront

Discussion in 'Apple' started by mrparkerduber, Jul 9, 2006.

  1. Hi,

    I recently upgraded to 10.4.7 using the Software Update but have since
    been unable to play Star Wars Battlefront on my Intel based iMac under
    Rosetta. It worked fine previously although a week ago I had to rebuild
    my machine completely due to a bad experience with Boot Camp (that'll
    teach me to think installing XP is a good idea - thanks Microsoft!) . .
    ..

    .. . . anyway, after rebuilding and restoring my backup, the OS Software
    updated to 10.4.7 and since then the game crashes on load up after
    about 7 secs. I'd rebuild and restore again but it's taken me a week to
    get back to normal as it is and I'm not sure I can be bothered to do
    that just for one game where I've lost the game saves already . . .

    Anyone else experiencing this? I'm guessing it's a glitch with 10.4.7
    and I'll just have to wait fro either 10.4.8 to come out or Aspyr to do
    a Universal patch for the game.

    All responses welcomed.

    PPD
     
    mrparkerduber, Jul 9, 2006
    #1
    1. Advertisements

  2. mrparkerduber

    ThomasPClune Guest

    I have the same problem. Nothing seems to work. I think I am going to
    call tech support in the morning.
     
    ThomasPClune, Jul 28, 2006
    #2
    1. Advertisements

  3. I'd be interested to hear if they say anything about this . . . please
    reply with your findings either way if you will . . .
     
    mrparkerduber, Jul 29, 2006
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.