Problems with DVD burners in Vista on Gigabyte motherboard - Solved

Discussion in 'Gigabyte' started by Kent Smith, May 25, 2007.

  1. Kent Smith

    Kent Smith Guest

    I just managed to resolve this issue, seemed to be related to my mb
    (965P-DS4) so thought I would post it here hoping it may help someone else:

    PROBLEM:
    Conflict/Bug between (unused) Gigabyte SATA controller / IDE controller and
    Vista

    BACKGROUND:
    I had a problem where my DVD burner was not detected in either DVD Maker or
    Media Player. It didn't appear as an option in the list of drives. It could
    burn using Nero.

    Another symptom I noticed was, when I looked at the properties for the
    drive, on the hardware tab, it said my writer was SCSI.

    Sounds like a drive, driver or os problem right? Strangely not...

    SOLUTION:
    A setting in the bios resolves this.

    The setting is on the <Integrated Peripherals> screen. The setting is
    <Onboard SATA/IDE Ctrl Mode>. The setting I set it to 'RAID/IDE'. (Sets the
    SATA channel to RAID mode and IDE channel to IDE mode), when it booted, it
    detected some new devices, installed them automatically and away she went.

    This was not a setting I changed, the default mode is IDE which is what I
    had and seems more logical to me.

    Although I use SATA for my single HDD in IDE mode and IDE for my burner, I
    have no intention to use RAID on SATA. I didn't think my disk would boot
    since I didn't install the RAID drivers on my disk but it did. I did a bit
    of reading and I believe this setting is only for the Gigabyte SATA
    controller. My board has 2 other Intel SATA controllers on it and my HDD is
    connected to the first one of these. But for some strange reason, the unused
    gigabyte SATA controller being set to IDE mode seemed to do something wierd
    to the IDE controller (that my burner was on) and Vista. It still worked
    fine, I could burn with Nero and Nero Infotool could ID all the features of
    the drive without any problem, just not DVD Maker or Media Player.

    So looks like some sort of conflict going on there. This is quite a big
    annoyance to a lot of people if you do some searching on it so I am not sure
    how many boards it affects. Probably MS Vista problem though since I don't
    think this is issue on XP - could be wrong - haven't tried.

    I logged it with Gigabyte so will see what they say.


    -KENT
     
    Kent Smith, May 25, 2007
    #1
    1. Advertisements

  2. Kent Smith

    Bob H Guest

    Thanks for posting this. I'm going to change it on my DS3 now. My DVD
    burner is useless up until this point.
     
    Bob H, Jul 14, 2007
    #2
    1. Advertisements

  3. Kent Smith

    Kent Smith Guest

    The only thing Gigabyte came back with was:
    "The symptom is normal. When you set the controller at IDE mode, the OS will
    recognize the controller as SCSI mass storage controller."

    The mind boggles. :)


    -KENT
     
    Kent Smith, Jul 16, 2007
    #3
  4. Kent Smith

    Bob H Guest

    DVD burner full on now. Giga yes is unreal, so helpful. Again thx for the
    post.
     
    Bob H, Jul 16, 2007
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.