Really REALLY stupid mighty mouse / scroll-wheel problem.

Discussion in 'Apple' started by Jeff Thompson, Oct 25, 2005.

  1. It scrolls left.

    It scrolls right.

    It scrolls up.

    But ... it doesn't scroll down ... !?

    Yesterday, the "scroll-nub" stopped working. Or, I should say, Tiger
    stopped responding to it.

    I kept playing with the keyboard and mouse control panel, disabling and
    reenabling vertical and horizontal scrolling, and now it does work, for
    up left and right. No-go for down. This is true for every
    application, finder included.

    I reinstalled the mighty-mouse drivers. No go.

    Any suggestions? I don't have a spare USB mouse to test to make sure
    that other mice with scrollwheels would have the same problem, but I am
    99.9999% sure that the problem isn't with the mouse itself.

    Please help!
     
    Jeff Thompson, Oct 25, 2005
    #1
    1. Advertisements

  2. It appears to me that the problem is with the mouse itself. It worked
    before and stopped working without any change to any relevant software.
     
    Michelle Steiner, Oct 25, 2005
    #2
    1. Advertisements

  3. Jeff Thompson

    D Guest

    This happens to me (rather, to my mouse) about once a week. It's almost
    certainly some grease or other everyday gunk getting underneath the
    ball messing up the contact between the wheels and the ball itself (a
    stupid design because you can't easily open it up and clean it out).
    What I do is get a clean, non scratching cloth and rub it quite
    vigourously and repeatedly on the mouse ball. (It's important to unplug
    the mouse first!). This usually solves the problem. Long-term I reckon
    it might break the mouse at which point I'll buy a better designed
    mouse. Mighty mouse is a good idea poorly implemented IMHO - unusual
    for apple.
     
    D, Oct 25, 2005
    #3
  4. Ok, I said it was a really stupid problem. <g>

    But I don't know which is more stupid -- me, for not figuring it out
    before asking, or the design of the mouse.

    Michelle and D are right - it is the mouse, not the software.
    Apparently there isn't just a simple "x" roller / "y" roller setup in
    the mouse, but a sensor for each cardinal direction. So it can stop
    working when you scroll up, but still work when you scroll down, or
    vice versa. Or you might lose your right scroll while keeping the
    left.

    Apple's technote suggests (a) cleaning the scrollball as D does - soft
    damp cloth. And then, if that doesn't work, turn the mouse upside down
    and manually roll the ball around with some pressure for a minute or
    two. (!)

    It worked. I turned the mouse over, rolled the ball around for a
    minute or so, and then suddenly my test finder window started scrolling
    in all directions. Apparently it's REALLY easy to gum up those sensors
    with dust or whatever.

    I still love the mouse, but now I worry that the sensors will
    eventually permanently gunk over, and unless it's possible to pop the
    mouse open and clean the sensors I'll be out of luck.
     
    Jeff Thompson, Oct 25, 2005
    #4
  5. Jeff Thompson

    Wes Groleau Guest

    I have a Contour Designs Unimouse.
    I like it, though the #$%^$& rubber grips
    don't stick any more.

    One day, the left mouse button stopped working.
    Tried all sorts of things, like the OP of this thread.
    went to the attic and dug out the original hockey puck,
    and it worked with no software tampering (not even a reboot!)

    So I opened the Unimouse, and found, mysteriously, that the
    plastic doohickey between the button and the microswitch
    had a notch in it exactly the shape of the nub sticking out
    of the switch. My guess is my son pounded it real hard in
    some shoot-em-up game.

    Mixed up some epoxy, put a speck of it in the notch,
    flattened it out by stretching scotch tape over it.....

    This mouse has all sorts of crud every place there's a
    little groove, but it has never had the "dirty ball" problem
    that so often hits so many other brands.
     
    Wes Groleau, Oct 26, 2005
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.