Recurring application install issue

Discussion in 'Apple' started by Tom Deininger, Dec 30, 2004.

  1. Hi:

    I have been have a recurring issue installing some applications for
    several months now, and after much web research have not been able to
    find an a solution, so I thought I'd post here for some advice.

    I have an iMac running Panther. The computer is shared among all
    family members. I have set myself up as the administrator, so that
    all software installs to the system are filtered through me.

    In general, this strategy has worked well. However, in several cases,
    after I do an install of an application (a recent example was Age of
    Empires II) to the "Macintosh HD Applications" directory, I am the only
    one that can successfully run the application. If someone else
    (non-admin) tries, the application gets to some point and then the app
    unexpectedly quits.

    I figured it is permissions related when the app goes to write a file,
    and have tried going in to the applications subdirectory and loosened
    all permissions, but this doesn't seem to help at all.

    Usually what I end up doing is installing the application is a user
    directory. This is fine when there is only one family member that
    will be using the application, but wasteful if multiple family members
    want to use the application.

    Any advice in resolving these situations would be appreciated!
    Thanks in advance
    Tom Deininger
     
    Tom Deininger, Dec 30, 2004
    #1
    1. Advertisements

  2. If you do a Get Info on the game, and, as administrator, unlock the
    permissions and then change the allowed users in "Details", what
    happens?


    Does the installer ask you where you want to install the software? If
    it does, what happens if you install it in /Users/Shared?

    Cathy
     
    Cathy Stevenson, Dec 30, 2004
    #2
    1. Advertisements

  3. When I change the allowed users in "Details" to allow everyone
    Read/Write, it doesn't help at all. The same problems persist.

    Yes, the install programs always ask where to install the software. I
    just picked "Macintosh HD - Applications" because that's what I thought
    I should do. I didn't know anything about /Users/Shared. Maybe
    that's what I should have been doing all along.
    Thanks for the suggestion, I'll try that.

    Tom
     
    Tom Deininger, Dec 31, 2004
    #3
  4. I just tried installing the problematic software to /Users/Shared.
    The result is the same -- I am the only user that can successfully run
    the software. (It just closes right away if any other user tries to
    run it).

    Then I tried changing the permissions -- I changed all installed files
    and folders to have "Others" allowed Read/Write access (default install
    set this to "Read only"). Same result.

    Finally, I tried giving another user admin rights. Then I tried
    running the software under that users account. Still no luck. This
    tells me that the install is somehow binding to the user that did the
    install and somehow disallowing all others.
    Has anyone else seen similar problems?

    Thanks,
    Tom
     
    Tom Deininger, Dec 31, 2004
    #4
  5. Tom Deininger

    matt neuburg Guest

    I have not, but that does not mean that I don't believe you. You are
    suggesting that some applications have badly behaved installers, which I
    am perfectly willing to believe.

    Read-write access will allow a user to see a program, but not to run it.
    For that, he needs execute access. To provide it, you will need to use
    the Terminal. Either that or you're going to have to say more about what
    you mean when you say that other users cannot use the software - what,
    precisely, happens when they try? For instance, what "closes right
    away"? Are you saying that the program starts up and then vanishes? If
    so, this suggests that the program is perfectly accessible - it's just
    crashing. Now you need to figure out why. You'll need the examine the
    crash log for that. A rather desperate solution might be to try
    installing the program multiple times separately logged in as each
    individual user, installing into that user's home. m.
     
    matt neuburg, Dec 31, 2004
    #5
  6. Tom Deininger

    matt neuburg Guest

    Yes, any software that has to recommend 19 different possible voodoo
    procedures, including giving up and installing on a different computer,
    just to get the software installed...

    <http://www.adobe.com/support/techdocs/330718.html>

    ....clearly has its head up an inappropriate anatomical orifice. m.
     
    matt neuburg, Dec 31, 2004
    #6
  7. Along with the recent Illustrator "upgrade", it's an indication that
    many heads at Adobe are stuck in small, dark places.
     
    Neill Massello, Dec 31, 2004
    #7
  8. Macsoft notes the problem you describe and suggests this fix in its
    support section for AE2 - did you also apply to "enclosed items"?

    http://www.macsoftgames.com/products/age2/support/MacSoft-Age2-Support.h
    tml


    Macsoft iis an old Mac company with lots of experience with Mac
    installers. There has to be a solution.

    Do you have FileVault turned on for your account? I have no idea
    whether this would cause the problem - I'm just making stabs in th
    dark.

    What are some of the other programs that cause the same problem?
    I also didn't know whether installing in "Shared" would work - just
    thought it was worth a try.

    Cathy
     
    Cathy Stevenson, Dec 31, 2004
    #8
  9. Well, they could try running "auto levels", but I don't think that
    would help with the smell :)
     
    Matthew Russotto, Jan 3, 2005
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.